Bug 3660 - (int-90556) going off- then on-line with ad-hoc doesn't reconnect wifi
(int-90556)
: going off- then on-line with ad-hoc doesn't reconnect wifi
Status: RESOLVED FIXED
Product: Connectivity
WiFi
: 4.1.1 (4.2008.30-2)
: ARM Maemo
: Medium normal (vote)
: 4.1+
Assigned To: unassigned
: wifi-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-09-02 01:26 UTC by Paul M
Modified: 2008-12-29 01:30 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Paul M (reporter) 2008-09-02 01:26:17 UTC
SOFTWARE VERSION:
4.2008.23-14

STEPS TO REPRODUCE THE PROBLEM:
* Connect to an ad-hoc network which uses WEP and has a DHCP server on it; the
antenna icon * flashes whilst getting an IP etc.
* Press power button and select offline mode. Wait one minute.
* Press power button and select online mode.
* Antenna icon immediately switches to online state

EXPECTED OUTCOME:
Tablet should renew DHCP lease and connect to wifi network.

ACTUAL OUTCOME:
Tablet does not reconnect. 
It has the correct IP address but ifconfig -a doesn't say wlan0 is up; using
"ifconfig wlan0 up" doesn't fix the problem.


REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:
n/a

OTHER COMMENTS:
tapping antenna icon, disconnecting then connecting solves the problem. I have
only ever observed this with ad-hoc network. I did not have this problem with
earlier versions of Maemo, and I flashed Diablo from scratch and did not
restore a backup, every configuration was manually re-added.
Comment 1 Andre Klapper maemo.org 2008-09-02 13:30:10 UTC
Thanks for reporting this.
Can you please install the available updates for 4.2008.30-2 (though I don't
assume that this will fix it)?

Does running "/etc/init.d/networking restart" help? To do this, you have to
become root first. Please see http://wiki.maemo.org/Root_access for
instructions.

A packet capture could also be helpful. tcpdump can be used on the Nokia device
(wireshark/ethereal could be used on other hosts). Please take a look at
http://maemo.org/development/documentation/man_pages/tcpdump.html for more
information.
Comment 2 Paul M (reporter) 2008-09-02 16:51:11 UTC
I have done an apt-get update/upgrade/dist upgrade, but for some reason it
hasn't bumped the system revision. I will check it over and verify that there's
no missing updates.
Comment 3 Ryan Abel maemo.org 2008-09-02 17:13:04 UTC
(In reply to comment #2)
> I have done an apt-get update/upgrade/dist upgrade, but for some reason it
> hasn't bumped the system revision. I will check it over and verify that there's
> no missing updates.
> 

That's not a supported upgrade path, and can actually lead to quite a few
problems depending on your repository layout and installed packages. This could
easily be an issue due to your choice in upgrade methods. My personal
recommendation is to reflash Diablo and upgrade to 30-2 through the Application
manager. :)
Comment 4 Paul M (reporter) 2008-09-15 18:37:54 UTC
I have attempted to use the application manager to get the fixed product code,
but I think that is a red herring. This problem has been there ever since I
flashed Diablo, whereas I never had the same problem with chinook.
Comment 5 Paul M (reporter) 2008-09-22 01:30:52 UTC
I have succesfully fixed the repository bug that prevented me from upgrading to
latest product, am now on 4.2008-30-2, and the bug is still present. It's
pretty irritating.
Basically, it appears that it simply doesn't kick off DHCP when coming out of
offline mode when it had previously been doing ad-hoc.
It's hard for me to diagnose since I don't know how the tablet does its
different modes.
I did try the network restart script in /etc/init.d and it didn't help. I also
tried running the dhcp client and all it did was break my resolver settings!
Comment 6 Paul M (reporter) 2008-10-14 02:06:00 UTC
I thought of something else to try: setting a static IP, dns and gateway.

As before, going offline when connected and then back to online mode makes the
tablet indicate immediately it is reconnected. However, network access doesn't
work, and on examination with "ifconfig -a" it is apparent that wlan0 has the
wrong netmask, and is not up. No route gets set either, I presume because it
cannot.

This never happened in chinook, as I have been using wep and ad-hoc for a long
time, so I presume the ad-hoc network management scripts were broken in Diablo.

I would be very grateful as this is a major PITA, as it's impractical for me to
get a wireless access point, and the wireless card in my linux router/firewall
doesn't do hostap and therefore not WPA of any kind.
Comment 7 Jukka Rissanen nokia 2008-10-21 17:41:26 UTC
This is fixed in libicd-network-wlan 0.47-diablo7
(sorry, I do not know the release date)
Comment 8 Andre Klapper maemo.org 2008-10-21 17:45:46 UTC
Jukka: Great, thanks for updating! I'm going to take care of announcing when
it's available in public.
Comment 9 Paul M (reporter) 2008-10-26 01:35:28 UTC
I look forward to getting the update; FWIW, I have this version:

libicd-network-wlan 0.47-diablo4
Comment 10 Andre Klapper maemo.org 2008-11-07 13:18:20 UTC
Fixed in package
libicd-network-wlan 0.47-diablo7
which is part of the internal build version
diablo build x.2008.45
(Note that 2008 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 11 Jukka Rissanen nokia 2008-11-10 09:04:52 UTC
I have good and bad news about this bug.

The good news is that there was a bug in icd2 which happened when a connection
was being established and the system entered offline mode. This problem can be
seen more easily with adhoc networks, were the connection establishment (like
getting ip address) can be long. In this case the icd2 was in incorrect state
and it did not do full interface close and an error was seen. This problem is
now fixed.

The bad news is that autoconnect to adhoc network is not supported in diablo, I
do not know if this is mentioned in the documentation (probably not). An
enhancement request should be created if you want this to be changed.
Comment 12 Paul M (reporter) 2008-12-29 01:30:55 UTC
this problem definitely still exists in 2008.43-7

yes, this is quite important to me, as I frequently use ad-hoc to connect
laptop to tablet when out and about and there's no AP - laptop's Intel wireless
chipset doesn't do wifi master/AP mode :-(

|Fixed in package
|libicd-network-wlan 0.47-diablo7
|which is part of the internal build version
|diablo build x.2008.45

I had been hoping that when the new release was made, which turned out to be
2008.43-7, it would have been the above, but sadly not. Any chance of getting
access to that version of the library?