Bug 3639 - (int-87926) Attachments of Forwarded email from Modest sometimes not displayed
(int-87926)
: Attachments of Forwarded email from Modest sometimes not displayed
Status: RESOLVED DUPLICATE of bug 3369
Product: Email
General
: 4.1.3 (5.2008.43-7)
: N800 Maemo
: Low normal (vote)
: ---
Assigned To: Sergio Villar Senin
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-08-27 10:17 UTC by Uwe Kaminski
Modified: 2009-03-30 15:50 UTC (History)
3 users (show)

See Also:


Attachments
core dump after the browser crashs (1.05 MB, application/x-lzop)
2008-09-07 21:45 UTC, Uwe Kaminski
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Uwe Kaminski (reporter) 2008-08-27 10:17:06 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)
maemo OS2008 version 4.2008.23-14

STEPS TO REPRODUCE THE PROBLEM:
Forward an email whitch contains an attachement (e.g. a pdf) to an other mail
account and receive this mail via a desktop mail application.

EXPECTED OUTCOME:
The forwarded mail contains the original mail and its attachment.

ACTUAL OUTCOME:
The forwarded mail contains the original mail but not the attachment.

REPRODUCIBILITY:
(always/sometimes/once)
always

EXTRA SOFTWARE INSTALLED:
tons of... :)

OTHER COMMENTS:
Comment 1 Andre Klapper maemo.org 2008-08-27 11:46:45 UTC
(In reply to comment #0)
> SOFTWARE VERSION:
> maemo OS2008 version 4.2008.23-14

Please do run the latest updates available and not the old Diablo release.
There has been lots of Modest fixes.

> STEPS TO REPRODUCE THE PROBLEM:
> Forward an email whitch contains an attachement (e.g. a pdf) to an other mail
> account and receive this mail via a desktop mail application.

What is "a desktop mail application"? Which ones (names, exact versions) did
you try?

> EXPECTED OUTCOME:
> The forwarded mail contains the original mail and its attachment.
> 
> ACTUAL OUTCOME:
> The forwarded mail contains the original mail but not the attachment.

I tried this forwarding an HTML email with an attachment from my GMail account
in Modest to my Desktop (running Evolution 2.22.3.1) POP account.
The attachments were not displayed, but included in the email, see the size.

Can you please take a look at the size? The attachments DO get forwarded.
I expect that Modest sends the email having a
  Content-Type: multipart/mixed;
header line. Might be related to bug 3607.
Comment 2 Andre Klapper maemo.org 2008-08-27 12:13:18 UTC
Any chance to fotrward the message privately to me, if it is not confidential?


I've sent an email with a png attachment to my GMail account, fetched GMail
from Modest, forwarded the email back to a private POP account and to my IMAP
work account, both on my desktop computer (running Evolution 2.22.3.1). This
worked perfectly and the attached was correctly displayed in Evolution.

Sent an email with a larger pdf attachment from my GMail account in Modest to
my private account on my desktop computer. This did not work, the attachment is
included but not displayed in Evolution.

The message that fails for me comes from Hotmail, is much more nested, and its
boundary looks very suspicious to me:

--=-h6Q9bAnd2FXmtFFA/mjv
Content-Description: Forwarded message: Business proposal
Content-Disposition: inline
Content-Type: message/rfc822

Delivered-To: example@gmail.com
(....)
Mime-Version: 1.0
Content-Type: multipart/mixed; boundary="----=_NextPart_000_59ec_44f8_18f9"
X-OriginalArrivalTime: 16 Mar 2007 11:47:56.0779 (UTC)
        FILETIME=[F0639BB0:01C767C0]
Return-Path: example@hotmail.com
X-Mailer: Modest 1.0
Content-Disposition: attachment
Content-Transfer-Encoding: base64
Content-ID: <1219826529.3679.8.camel@Nokia-N810-23-14>

VGhpcyBpcyBhIG11bHRpLXBhcnQgbWVzc2FnZSBpbiBNSU1FIGZvcm1hdC4KCi0tLS0tLT1fTmV4
(....)
NGY4XzE4ZjktLQo=

------=_NextPart_000_59ec_44f8_18f9--

--=-h6Q9bAnd2FXmtFFA/mjv--
Comment 3 David Mery 2008-09-07 12:58:51 UTC
I encountered this issue with an attachment not showing up in Modest. I found a
way to reproduce it with Apple Mail on Tiger.

In Apple Mail preferences set Composing/Message format to Rich text. Then send
an email with one line that includes some UTF-8 and a PDF attachment. This will
show up fine (ie listed as having one attachment) in the list view of Modest,
but when opening it up in Modes the content will be empty (similar to bug
#3607) and no attachment will show.

If the one line content of the email is pure ASCII text then the email will
show up fine with its attachment.

Comparing my test emails, the one difference I notice:
* The test emails that work fine with Modest, are multipart with text/plain and
application/pdf sections.
* The ones that don't show the attachment in Modest have first a text/plain
section (containing the plain text of the email) followed by the
multipart/mixed that has text/html and application/pdf subsections.

Beginning of email that does not work with Modest:
----------------------------------------
Mime-Version: 1.0 (Apple Message framework v753.1)
To: David Mery <dmery@acm.org>
Message-Id: <0B407A5D-85B3-4329-AF36-89892B2E5C67@acm.org>
Content-Type: multipart/alternative;
    boundary=Apple-Mail-63--191862070
From: David Mery <dmery@acm.org>
Subject: Test - Rich text by default and UTF8 content
Date: Sun, 7 Sep 2008 18:49:49 +0900


--Apple-Mail-63--191862070
Content-Transfer-Encoding: quoted-printable
Content-Type: text/plain;
    charset=UTF-8;
    format=flowed

One line with UTF-8 (=ED=8C=90=EB=8B=A4) and an attachment

=EF=BF=BC=

--Apple-Mail-63--191862070
Content-Type: multipart/mixed;
    boundary=Apple-Mail-64--191862069


--Apple-Mail-64--191862069
Content-Transfer-Encoding: quoted-printable
Content-Type: text/html;
    charset=UTF-8

<html><body style=3D"word-wrap: break-word; -webkit-nbsp-mode: space; =
-webkit-line-break: after-white-space; ">
One line with UTF-8 (<span class=3D"Apple-style-span" style=3D"font-size: =
11px; ">=ED=8C=90=EB=8B=A4</span>) and an =
attachment<br><br><div></div></body></html>=

--Apple-Mail-64--191862069
Content-Transfer-Encoding: base64
Content-Type: application/pdf;
    x-unix-mode=0644;
    name=MIT-CSAIL-TR-2007-034.pdf
Content-Disposition: inline;
    filename=MIT-CSAIL-TR-2007-034.pdf
<snip>

Beginning of email that works with Modest:
---------------------------------

Mime-Version: 1.0 (Apple Message framework v753.1)
To: David Mery <dmery@acm.org>
Message-Id: <07F32A29-B81F-4326-A000-13884D0D2CCD@acm.org>
Content-Type: multipart/mixed;
    boundary=Apple-Mail-59--192403210
From: David Mery <dmery@acm.org>
Subject: Test - Rich text by default
Date: Sun, 7 Sep 2008 18:40:48 +0900


--Apple-Mail-59--192403210
Content-Transfer-Encoding: 7bit
Content-Type: text/plain;
    charset=US-ASCII;
    format=flowed

One line and then an attachment


--Apple-Mail-59--192403210
Content-Transfer-Encoding: base64
Content-Type: application/pdf;
    x-unix-mode=0644;
    name=MIT-CSAIL-TR-2007-034.pdf
Content-Disposition: inline;
    filename=MIT-CSAIL-TR-2007-034.pdf
<snip>
Comment 4 Uwe Kaminski (reporter) 2008-09-07 21:45:33 UTC
Created an attachment (id=928) [details]
core dump after the browser crashs
Comment 5 Uwe Kaminski (reporter) 2008-09-07 21:48:35 UTC
pleas delet attachment, its for an other bug:
https://bugs.maemo.org/show_bug.cgi?id=3682
Comment 6 Uwe Kaminski (reporter) 2009-03-30 15:46:08 UTC

*** This bug has been marked as a duplicate of bug 3369 ***