Bug 3626 - incoming call to my gizmo5 account now fails
: incoming call to my gizmo5 account now fails
Status: RESOLVED INVALID
Product: Chat & Call & SMS
VoIP
: 4.1.1 (4.2008.30-2)
: N800 Linux
: Low normal (vote)
: ---
Assigned To: rtcomm@maemo.org
: internet-call-bugs
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2008-08-23 00:36 UTC by Mark Waters
Modified: 2008-08-31 21:19 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Mark Waters (reporter) 2008-08-23 00:36:56 UTC
SOFTWARE VERSION: 4.2008.30-2
(Control Panel > General > About product)

STEPS TO REPRODUCE THE PROBLEM: incoming call to my gizmo5 account

EXPECTED OUTCOME: internet call app to load and show incoming call pop-up

ACTUAL OUTCOME: internet call app loads , no pop-up, caller told number is not
active / registered / online

REPRODUCIBILITY: always
(always/sometimes/once)

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS: rtcomm was working perfectly with my gizmo5 account before the
last update (4.2008.30-2).
Incoming calls to voxalot still work fine so I guess its an incompatibility
between gizmo and the the updated software.
As a workaround I've now forwarded all my incoming gizmo calls to voxalot and
they work.
Comment 1 Andre Klapper maemo.org 2008-08-25 11:16:25 UTC
Hi Mark,
what exact hardware is this (N800 or N810)?
So you are using your Gizmo account as a SIP account in rtcom ("Internet Call")
and this does not work anymore, right?
Does it work when you use the Gizmo application (which is not from Nokia)
itself (available from the Gizmo software catalog, latest version is
gizmo-project 4.0.0.95)?
Comment 2 Andre Klapper maemo.org 2008-08-25 14:38:04 UTC
Outgoing calls work perfectly?
Do you use NAT?
A packet capture could help to clarify what causes the problem. Please take a
look at http://maemo.org/development/documentation/man_pages/tcpdump.html for
more information.
Could you also provide a syslog?
To do so, start a terminal window. Now export TPORT_LOG=1 and export
SOFIASIP_DEBUG=all in the environment (e.g. by editing
/etc/osso-af-init/af-defines.sh) for telepathy-sofiasip. Launch
/usr/lib/telepathy/telepathy-sofiasip standalone from the terminal. Now SIP
traffic logs get dumped into syslog. Also see
http://maemo.org/development/tools/doc/diablo/syslog/ .
Comment 3 Andre Klapper maemo.org 2008-08-25 14:53:28 UTC
might be a duplicate of/related to bug 3273.
Comment 4 Mikhail Zabaluev nokia 2008-08-25 15:10:08 UTC
(In reply to comment #2)
> Could you also provide a syslog?
> To do so, start a terminal window. Now export TPORT_LOG=1 and export
> SOFIASIP_DEBUG=all in the environment (e.g. by editing
> /etc/osso-af-init/af-defines.sh) for telepathy-sofiasip. Launch
> /usr/lib/telepathy/telepathy-sofiasip standalone from the terminal. Now SIP
> traffic logs get dumped into syslog.

There is some confusion in these guidelines. These environment variables will
cause output to syslog as well as to process' stderr descriptor.
Launching the process in a terminal will give you that output on the terminal.
Doing this way, it also helps to set SOFIASIP_PERSIST=1 environment variable to
prevent telepathy-sofiasip from exiting due to no connections being requested:

SOFIASIP_PERSIST=1 run-standalone.sh /usr/lib/telepathy/telepathy-sofiasip
Comment 5 Mark Waters (reporter) 2008-08-25 15:19:35 UTC
hardware is a n800.

yep , got my gizmo5/project account setup in rtcomm as before.
outgoing calls work fine , the problem is only with incoming calls.

if i disable the accounts in rtcomm and start the gizmo5 application instead
then incoming calls work perfectly , the app pops up and i can pickup and
complete the call.

I do use NAT , but all the sip accounts have the STUN server setup and work
fine.
voxalot still works fine for incoming calls as expected and I have setup my
gizmo account to forward calls there as a workaround.

rtcomm is obviously seeing the call come in as it wakes the n800 and starts the
internet call app if its not already running , just that the answer/ignore
requester doesn't popup. the caller is then told that the account isnt online
currently.

i thought it might be a codec problem but have since disabled the ilbc codec
and restarted the device - still the problem persists.

I will try and get the syslog dumped for you.
thanks
mark
Comment 6 Mikhail Zabaluev nokia 2008-08-25 15:21:50 UTC
What are the account parameters?
Check if transport is set to UDP in Advanced settings of your SIP account for
Gizmo.
Comment 7 Mark Waters (reporter) 2008-08-31 17:31:44 UTC
after leaving it a week I just tried again and now its working , so I guess it
was a problem at the gizmo5 / sipphone end somewhere.

sorry to hassle you guys unnecessarily.