Bug 3623 - Bugzilla Version choices should match tablet's version number
: Bugzilla Version choices should match tablet's version number
Status: RESOLVED WONTFIX
Product: maemo.org Website
Bugzilla
: unspecified
: All All
: Low enhancement (vote)
: ---
Assigned To: Andre Klapper
: Ferenc Szekely
:
:
:
:
  Show dependency tree
 
Reported: 2008-08-22 10:03 UTC by Uwe Geuder
Modified: 2008-10-22 09:57 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Uwe Geuder (reporter) 2008-08-22 10:03:58 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)

Does Bugzilla have (visible) version numbers???


STEPS TO REPRODUCE THE PROBLEM:

1. Create a new bug report

2. there is a pull-down menu called "version". The choices are something like
1.0, 2.0, 3.0, 4.0, 4.1

3. Check the version in your device: Sttings --> Control Panel --> about
product
There is some like 4.2008.30-2

EXPECTED OUTCOME:

Teh version dispalyed by the device should be available in the pull down menu

ACTUAL OUTCOME:

insider knowldege is needed to map the output from the device to the correct
input in bugzilla

REPRODUCIBILITY:
(always/sometimes/once)

Always

EXTRA SOFTWARE INSTALLED:

N/A 

OTHER COMMENTS:

If the pull down menu choices are improved, the version number section can be
removed from the template. 

Alternatively the version pull down could be dropped completely. But I think 
specific fields are always better then free text (even when required by
template)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.15)
Gecko/20080623 Firefox/2.0.0.15
Comment 1 Andre Klapper maemo.org 2008-08-22 15:28:28 UTC
"Target Milestone" already links against
http://wiki.maemo.org/Codenames#Release_Table , I'm going to have "Version"
also linking.

The problem is that a version like 4.0 not always refers to only one release
like 2.2007.51-3, so we cannot easily do this.
Comment 2 Uwe Geuder (reporter) 2008-08-22 17:20:10 UTC
Adding help is definitely a step into right direction. I appreciate your quick
response.

Is the version really needed? Well in searches one might have to select several
releases, if version is not available.

But if the the version can be derived from the release via a simple table
lookup, and the user has to enter the release anyway, than system should do the
lookup, not the user. 

(But of course this is a minor issue, so you might have more important things
to do)
Comment 3 Uwe Geuder (reporter) 2008-08-22 17:29:35 UTC
And please don't forget to add 4.1.1 to the Wiki. This version is available in
the pull down menu, but not mentioned in the Wiki. I somehow guessed it might
mean the first update release to 4.1 (i.e. 4.2008.30-2) , but if you say that
they don't match 1:1 my guess was probably wrong.
Comment 4 Andre Klapper maemo.org 2008-08-22 17:46:03 UTC
The version info is definitely needed for tracking purposes.

> But if the the version can be derived from the release via a simple table
> lookup, and the user has to enter the release anyway, than system should 
> do the lookup, not the user. 

Might be possible, but coding that will not be trivial and my current
priorities are different.
I tend to currently close this as WONTFIX, but I hope to improve this in the
future...

I opened bug 3625 which is about linking the string "Version" against
http://wiki.maemo.org/Codenames#Release_Table .
Comment 5 Ryan Abel maemo.org 2008-08-22 19:45:10 UTC
My votes for WONTFIX, too. Maemo's moving in the direction of the current
versioning system seen in bugzilla, anyway (rather than OS2008 and a build week
string).
Comment 6 Uwe Geuder (reporter) 2008-10-22 09:57:19 UTC
Nice. Even though it is WONTFIX, it has been fixed. (See comment #13 of
https://bugs.maemo.org/show_bug.cgi?id=3747)