Bug 3622 - Ctrl-A does not work in URL field
: Ctrl-A does not work in URL field
Status: RESOLVED INVALID
Product: Browser
User interface
: 4.1.3 (5.2008.43-7)
: N810 Maemo
: Medium normal with 3 votes (vote)
: 5.0 (1.2009.41-10)
Assigned To: unassigned
: browser-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-08-22 09:30 UTC by Uwe Geuder
Modified: 2009-06-05 14:14 UTC (History)
3 users (show)

See Also:


Attachments
This is the packagelist of my device extracted from a rich core (14.61 KB, text/plain)
2008-08-22 09:35 UTC, Uwe Geuder
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Uwe Geuder (reporter) 2008-08-22 09:30:02 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)

4.2008.30-2

STEPS TO REPRODUCE THE PROBLEM:

1.) Make sure that you have focus in the URL field. (This might need extra
tapping as reported in https://bugs.maemo.org/show_bug.cgi?id=3298 and
https://bugs.maemo.org/show_bug.cgi?id=3592).

2.) Make sure that there is still an URL (or part thereof) in the URL field 

3.) Press Ctrl-A

EXPECTED OUTCOME:

All text in the URL field is selected.

ACTUAL OUTCOME:

Nothing happens.

REPRODUCIBILITY:
(always/sometimes/once)

Always

EXTRA SOFTWARE INSTALLED:

see attached file

OTHER COMMENTS:

I'm quite sure this worked in the initial Diablo release. It has probably
stopped working when I upgraded to 4.2008.30-2.

Ctrl-A still works in Bookmarks. So I don't think any of my additional installs
should have ruined the whole gtk or anything like this. 

I haven't come up with a better way to type a completely new URL than selecting
everything of the old URL with Ctrl-A to delete it quickly. Currently I have to
press and hold delete, which is pretty tedious for long URLs




User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.15)
Gecko/20080623 Firefox/2.0.0.15
Comment 1 Uwe Geuder (reporter) 2008-08-22 09:35:27 UTC
Created an attachment (id=899) [details]
This is the packagelist of my device extracted from a rich core
Comment 2 Andre Klapper maemo.org 2008-08-22 15:25:56 UTC
This does not refer to fullscreen, I assume?
Comment 3 Uwe Geuder (reporter) 2008-08-22 17:10:25 UTC
Sorry, I intended to mention it, but I forgot to do it...

- Behavior is the same whether in full screen mode or not.

- Behavior is the same whether toolbar is permanently visible or not.
Comment 4 Andre Klapper maemo.org 2008-08-25 18:16:25 UTC
I can't reproduce this here.

I started the browser (non-fullscreen), clicked into the URL field with the pen
(this highlights the entire URL), then clicked for a second time at the end of
the URL to only get a cursor. Ctrl+A always works for me.
Did I get something wrong?
Comment 5 Uwe Geuder (reporter) 2008-08-28 10:20:09 UTC
Yes, the very first time I use the address field just after the browser has
been started, Ctrl-A does sometimes work (I'd guess less than 50% of the cases,
but I have not measured systematically)

But normally I never close the browser and in all later usage Ctrl-A has never
worked, I don't think I have seen a single exception.

As I wrote before this used to work before on the same device in Diablo, but it
broke at some stage. I guess it was the the system update, but I have no proof
for my guess.

Could you please attach the packagelist file of your reference device to this
report, so we can investigate the differences?

Or is there any configuration file (X-wide or gtk-wide or hildon-specific) that
could cause such a problem?

Doesn't sound to likely. I'm not aware of anything I would have changed and
Ctrl-A works already 100% reliably in the browser bookmarks. But you never
know.
Comment 6 Frantisek Dufka maemo.org 2008-12-17 16:18:42 UTC
No change with 5.2008.43-7, still happens.

Both ctrl+A does not work and also selecting any part of url highlights text
but after raising pen is is immediatelly unselected so I even can't delete part
url by single backspace key press. The only way is to go to end of the line and
hold backspace and wait for all characters to be deleted one by one. With long
URL it is actually faster to open new window with ctrl+n and close the old one
later.

I can confirm is sometimes works fine after boot in first window but sooner or
later it stops working.
Comment 7 Frantisek Dufka maemo.org 2008-12-17 18:42:42 UTC
(In reply to comment #6)
> I can confirm is sometimes works fine after boot in first window but sooner or
> later it stops working.

Looks like it happens only when url toolbar is turned off (View->Show
toolbar->Full screen) and one shows it temporarily via ctrl-L when needed. I
did some quick testing and cannot reproduce the bug when url toolbar is
permanently enabled. Once it is hidden and it is shown few times via ctrl-l it
breaks sooner or later. Then it does not help if toolbar is permanently enabled
in menu again until all windows are closed. Once all windows are closed it
works fine again in newly opened windows.
Comment 8 Andre Klapper maemo.org 2008-12-18 02:26:35 UTC
I can reproduce this and wonder whether it's just a duplicate of bug 3298.
Codewise speaking.
Comment 9 Andre Klapper maemo.org 2009-05-20 16:11:04 UTC
Duplicate I think.

*** This bug has been marked as a duplicate of bug 3298 ***
Comment 10 Frantisek Dufka maemo.org 2009-05-20 17:08:23 UTC
(In reply to comment #9)
> Duplicate I think.
> 
> *** This bug has been marked as a duplicate of bug 3298 ***
> 

This may be related to bug #3298 but I think it is not duplicate. It may be
that fixing code causing bug #3298 may fix this too but the symptoms and
behavior of this bug is different. #3298 is about field not getting focus. This
bug is that even when you set the focus by hand and the URL field has focus now
and text entry works, ctrl+A and text selection still doesn't work.
Comment 11 Andre Klapper maemo.org 2009-05-25 17:10:52 UTC
(In reply to comment #10)
> (In reply to comment #9)
> This may be related to bug #3298 but I think it is not duplicate.

Hmm, you have valid arguments. Reopening and wondering whether this still
applies for Fremantle (CC'ing Quim).
Comment 12 Andre Klapper maemo.org 2009-06-05 14:14:22 UTC
This issue cannot happen anymore in Fremantle because of a different
implementation. => INVALID for Fremantle.

Unfortunately this is also a WONTFIX for Diablo as Diablo is in maintenance
mode and Nokia will only provide bugfixes for critical issues if at all.
For your interest the Mer project aims to provide a community backport of
Fremantle for N8x0 devices. See http://wiki.maemo.org/Mer for more information.