Bug 3607 - (int-88253) text/plain not showing in multipart/mixed emails
(int-88253)
: text/plain not showing in multipart/mixed emails
Status: RESOLVED DUPLICATE of bug 3369
Product: Email
General
: 4.1.1 (4.2008.30-2)
: N800 Maemo
: Unspecified normal (vote)
: ---
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-08-18 17:15 UTC by Oskar
Modified: 2008-12-06 15:22 UTC (History)
2 users (show)

See Also:


Attachments
Two Testmails (421.89 KB, application/x-gzip)
2008-08-19 23:52 UTC, Oskar
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Oskar (reporter) 2008-08-18 17:15:27 UTC
SOFTWARE VERSION:
4.2008.30-2

STEPS TO REPRODUCE THE PROBLEM:
I receive mails sent from an iPhone. The content type is multipart/mixed. They
start with "Content-type: text/plain;", next section is "Content-type:
image/jpeg;", then "text/plain" again etc.

EXPECTED OUTCOME:
I should see *all* sections with content type "text/plain" as well as the
JPEG-images. - (Even better: The client should be able to keep the images
within the flow of the text as each text as each text refers to the image
immediately below and you cannot tell which text refers to whcih image if all
of the JPEGs are attachments outside the text area. This is what happens on a
desktop email client, but I guess it would be an enhancement rather than a
bug.)

ACTUAL OUTCOME:
Only the images are shown as attachments. All (!) but one sections that contain
the actual text part of the email ("Content-type: text/plain;") are not
displayed nor is there any indication that there is something missing at all. -
The only exception is the very last text/plain section, which (in my case) only
contains the sender's name and phone number. 

REPRODUCIBILITY:
always, although only tested with mails from an iPhone.

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
You see an example with screenshots at 
http://www.internettablettalk.com/forums/showthread.php?t=22927
where somebody suggested this could be related to Bug #3369. - I'm not sure
about this, as I'm not using IMAP (as in 3369) and the symptoms aren't exactly
the same. I thought I'd report here and let wiser ppl. do the "marked
duplicate"-stuff once it's confirmed. 

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.8.1.16)
Gecko/20080720 BonEcho/2.0.0.16
Comment 1 Andre Klapper maemo.org 2008-08-19 22:58:50 UTC
I also expect this to be a duplicate of bug 3369. The offending example message
is also in multipart/mixed (multipart/digest and text/plain).

Can you please attach a sample message and make sure that it does not contain
confidential data?
Comment 2 Oskar (reporter) 2008-08-19 23:52:33 UTC
Created an attachment (id=894) [details]
Two Testmails

Two testmails: The one sent from an iPhone will miss the first paragraph, image
and last piece of texct shows correctly. The second (I guess it was sent from a
desktop mac) doesn't show any text on the N800, only the images.
Comment 3 David Mery 2008-09-07 12:22:29 UTC
I can confirm this when sending from Apple Mail on Tiger.

When sending one email with two sections: text/plain followed by image/jpeg
will show on Modest the text content with an image attachment.

When sending a similar email with three sections: the same text/plain and
image/jpeg followed by an minimal text/email third section (just a carriage
return after the pic) will show on Modest an empty content with an image
attachment.
Comment 4 Andre Klapper maemo.org 2008-09-09 23:56:42 UTC
The current implementation of the message viewer only allows to show one mime
part at a time if I'm not wrong, and the other text/plain is not shown because
its mime type is not considered as an attachment by modest.

According to the developer this is the same issue as bug 3369, hence marking as
duplicate.

*** This bug has been marked as a duplicate of bug 3369 ***