Bug 3560 - Updates horribly confused, can't find missing packages
: Updates horribly confused, can't find missing packages
Status: RESOLVED INVALID
Product: Settings and Maintenance
Application manager
: 4.1 (4.2008.23-14)
: All Windows
: Low major (vote)
: ---
Assigned To: unassigned
: application-manager-bugs
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2008-08-12 18:28 UTC by tz
Modified: 2008-09-17 22:42 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description tz (reporter) 2008-08-12 18:28:55 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)
4.2008.23-14

STEPS TO REPRODUCE THE PROBLEM:
Application Manager, Check for updates, update all

EXPECTED OUTCOME:
Maybe one or two packages would have problems at most, and none from nokia.

ACTUAL OUTCOME:
Almost no Maemo/Nokia software updates (e.g. map).
nokia-repository says nokia-repository (= 5.6) is missing.  I never touched it.
Of course it is really nasty going package by package.
microb-engine (=1.0.4-60.9) is missing.  The browser works, but it says both
that it has an update but can't update it.  It also says 1.0.4-60.9 is
installed.

There was a "Feature Upgrade" which apparently contained these things, but
Update-All didn't do anything about it, but tried and failed on the specific
packages.

REPRODUCIBILITY:
(always/sometimes/once)
It happened continually during the session.  I'm trying the feature upgrade and
if it doesn't brick it probably won't do it

EXTRA SOFTWARE INSTALLED:
lots, but nothing affecting this

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8)
Gecko/20071008 Firefox/2.0.0.8
Comment 1 tz (reporter) 2008-08-12 19:04:15 UTC
Bricked after the reboot.  And there isn't a combined update I can use to
reflash, only the original diablo release (that will probably do the same thing
when I try).

So, I couldn't get all the real updates (like a stable browser - maybe the bug
I reported earlier is related) individually because of something broken in app
manager, and the Feature update bricks the tablet.
Comment 2 Ryan Abel maemo.org 2008-08-12 19:41:06 UTC
We should be clear about our terminology here. "Bricking" is when a device no
longer shows any signs of life and requires manufacturer-level intervention to
be repaired. This is distinct from the "reboot loop" that you're experiencing
where the device cannot finish booting due to important system services either
crashing or not starting during boot and the device being reset by a watchdog.

I'm marking this moreinfo, as it's about as un-useful as a bug report can get
(I'm inclined to mark this INVALID and wait for a real report). We really need
something specific and reproducible to make any progress on this.
Comment 3 Andre Klapper maemo.org 2008-08-12 21:25:14 UTC
(In reply to comment #2)
> I'm marking this moreinfo, as it's about as un-useful as a bug report can get

Ryan, also feel free to link to
https://bugs.maemo.org/page.cgi?id=bug-writing.html now that it's in place to
save time.

The report also looks vague to me.
"The browser works, but it says both that it has an update but can't update it.
 It also says 1.0.4-60.9 is installed."
Having exact error messages, explicit step by step explanation and avoiding
"it" would help me trying to reproduce it (though my update worked out without
any problems here), but I had flashed to a clean Diablo before updating, I have
to admit.
Comment 4 tz (reporter) 2008-08-12 21:45:42 UTC
OK, infinite reboots instead of "bricked".

Sorry I can't give a better bug report, but I don't have a serial console
adapter attached.

I do know app manager had problems.  To reconstruct as best I can:

It had a "feature upgrade" in the app manager update screen and about 30
distinct packages.

I did "update all", and it did some (e.g. map) without much bother.

microb-engine and most others included in the "feature upgrade" said "Cannot
Install" when I went through the update all.  That is all the application
manager gave me, so fix the application manager to be more specific if you want
better reports.

When I clicked Details, it said in each case something of the form App X 1.9
depends on App X (=1.8).

It would say this in the "Problems" pane for the info about the upgrade.

It listed NO OTHER problems besides the dependency on the version which was the
currently installed program and version.

I stopped it about halfway through then did the feature upgrade, which didn't
indicate any "problems" but failed to install.

In all the cases I checked, App X 1.8 was the version installed (e.g.
microb-engine above).

I did a fresh reflash, then feature upgrade, and it didn't show these extra
packages.  I may have been in the red-pill mode (there should be an easy way of
exiting instead of doing the hack, and it should be ignored for upgrades).
Comment 5 Daniel Martin Yerga 2008-09-16 01:46:43 UTC
(In reply to comment #4)
> OK, infinite reboots instead of "bricked".
> 
> Sorry I can't give a better bug report, but I don't have a serial console
> adapter attached.
> 
> I do know app manager had problems.  To reconstruct as best I can:
> 
> It had a "feature upgrade" in the app manager update screen and about 30
> distinct packages.
> 
> I did "update all", and it did some (e.g. map) without much bother.
>
> [SNIP]
>
> I did a fresh reflash, then feature upgrade, and it didn't show these extra
> packages.  I may have been in the red-pill mode (there should be an easy way of
> exiting instead of doing the hack, and it should be ignored for upgrades).

Generally, if you are in red-pill mode and do update-all or to do apt-get
upgrade in the terminal, you can have problems like infinite reboots. Specially
if you have problematic repositories like the SDK one, mix repositories from
various versions, or have some problematic 3rd party repository. It isn't the
standard way to upgrade and if it's a hidden feature is for something.

With a fresh reflash, you hadn't problems because:

1) Possibly the repositories you have active are only the Nokia ones and
maemo.org extras.
2) Without the red pill mode, the application manager only upgrades the
end-user packages (or the Nokia upgrade in this case) and not the possible
'problematic' libraries what are in the repositories.


I am going to close this bug as INVALID. If someone doesn't agree, reopen it.
Comment 6 tz (reporter) 2008-09-16 17:17:25 UTC
I am not talking about UPGRADING ANY PACKAGE.

IT FAILS TO RESTORE ALL PREVIOUSLY INSTALLED PACKAGES EVEN IF THEY ARE
AVAILABLE IN THE REPOSITORY LIST.

IT FAILS TO MAINTAIN A PROPER LIST OF PREVIOUSLY INSTALLED PACKAGES SO I CAN DO
IT MANUALLY OR AT LEAST KNOW WHAT IS MISSING.

IT FAILS TO INDICATE THAT IF I INSTALL ANY GIVEN PACKAGE THAT IT IS REMEMBERING
OR NOT REMEMBERING IT FOR A REINSTALL AFTER A REFLASH.

Even the latter would be a big improvement since I can then write down the
packages I will need to manually reinstall.

You pop up various annoying and useless messages during the installs and take a
long time to even create the list.  What is so hard in telling me whether or
not, yes or no, that a package will be flagged for restore after a reflash?

I can submit this as a distinct bug instead (not telling me it won't restore
instead of just not restoring after a reflash), but will you mark it as
confirmed since you admit this is the behavior?
Comment 7 Ryan Abel maemo.org 2008-09-16 17:36:01 UTC
(In reply to comment #6)
> I am not talking about UPGRADING ANY PACKAGE.
> 

Clearly, based on the bug summary and the description in comment #0 you're
talking about updating packages.

> IT FAILS TO RESTORE ALL PREVIOUSLY INSTALLED PACKAGES EVEN IF THEY ARE
> AVAILABLE IN THE REPOSITORY LIST.
> 

I haven't experienced this myself, but my own guess is that you're installing
packages outside of user/ in Red Pill. Application manager doesn't let the user
deal with stuff outside of user/ directly, so this is the correct, expected
behavior. If you insist on breaking things on purpose, then that's your own
prerogative, but pretend that that makes them bugs.

> I can submit this as a distinct bug instead (not telling me it won't restore
> instead of just not restoring after a reflash), but will you mark it as
> confirmed since you admit this is the behavior?
> 

Every bug should have its own report, each report should ONLY cover one issue.
Bug summaries should be clear, to the point, and reflect the content of the
bug. Steps to reproduce should be accurate, detailed, and clear. Expected
outcomes should be clear and specific.

This reports fails most of the above requirements, and bugs which fail these
requirements are difficult to understand, difficult to triage, and difficult to
fix. What is the end result? Not anything productive, that's for sure.

tz, please read through https://bugs.maemo.org/page.cgi?id=bug-writing.html
before filing your next report.

Based on the description outlined in the bug, this is clearly INVALID.
RESOLVING again. . . .
Comment 8 tz (reporter) 2008-09-17 21:40:44 UTC
I REPEAT THIS HAS NOTHING TO DO WITH UPGRADING.

I can do a backup of the current state on either my n800 or n810.

I then do a complete reflash using the windows tool Nokia provides which will
RESTORE THE SAME VERSION of the software it is currently running.

I can then tell it to restore the backup it finds.

Nothing I can do will preserve the list of applications.  It will not tell me
which applications are being backed up and which aren't.

So I will end up with an unknown fraction of the applications I had.

Tell me where this is an "Upgrade".

And tell me where there is any place it is documented that Application Manager
will NOT remember packages it installs, much less specifically which ones are
remembered and which ones aren't or any way of telling BEFORE you install the
application or even AFTER.

I'll go read it if you can find it.  I can't find it with google or with the
other searches.  But all the same, expecting some totally undocumented and
unexpected behavior to be not reported as a bug is just as bad.

I am resubmitting this as another bug with more appropriate descriptions.

I submitted this one because when the application manager will willy-nilly
(unless you can point to the documented logic it uses other than in the source)
remember to restore or forget to restore applications, it is confused.  The
packages are missing from my system.
Comment 9 Ryan Abel maemo.org 2008-09-17 22:42:49 UTC
(In reply to comment #8)
> I REPEAT THIS HAS NOTHING TO DO WITH UPGRADING.
> 

(In reply to comment #0)
> STEPS TO REPRODUCE THE PROBLEM:
> Application Manager, Check for updates, __update__ all
> 
> EXPECTED OUTCOME:
> Maybe one or two packages would have problems at most, and none from nokia.
> 
> ACTUAL OUTCOME:
> Almost no Maemo/Nokia software __updates__ (e.g. map).
> nokia-repository says nokia-repository (= 5.6) is missing.  I never touched it.
> Of course it is really nasty going package by package.
> microb-engine (=1.0.4-60.9) is missing.  The browser works, but it says both
> that it has an update but can't __update__ it.  It also says 1.0.4-60.9 is
> installed.
> 
> There was a "Feature __Upgrade__" which apparently contained these things, but
> __Update-All__ didn't do anything about it, but tried and failed on the specific
> packages.
> 
> REPRODUCIBILITY:
> (always/sometimes/once)
> It happened continually during the session.  I'm trying the feature __upgrade__ and
> if it doesn't brick it probably won't do it
> 

I've marked the relevant parts from comment #0 for clarity.

When you try to do things in an unsupported BROKEN-MODE (read: Red Pill), then
things will break. That's normal and to be expected.