Bug 3537 - (int-87588) Can't WPA-PSK connect to Zyxel G2000plus & 660HW after upgrade to Diablo
(int-87588)
: Can't WPA-PSK connect to Zyxel G2000plus & 660HW after upgrade to Diablo
Status: CLOSED FIXED
Product: Connectivity
WiFi
: 4.1 (4.2008.23-14)
: N800 Linux
: Medium normal (vote)
: 4.1.2
Assigned To: unassigned
: wifi-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-08-03 20:12 UTC by AlekSi
Modified: 2008-09-30 22:39 UTC (History)
4 users (show)

See Also:


Attachments
Syslog of trying to connect to the WPA protected zyxel access point with diablo (29.09 KB, application/zip)
2008-08-15 16:07 UTC, Kimmo Kinnunen
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description AlekSi (reporter) 2008-08-03 20:12:16 UTC
SOFTWARE VERSION: 4.2008.23-14 (Diablo)
(Control Panel > General > About product)

STEPS TO REPRODUCE THE PROBLEM:
Upgrade N800 to Diablo. Try to connect to WPA/WPA2 network.

EXPECTED OUTCOME:
Tablet connects and everyone's happy.

ACTUAL OUTCOME:
I'm asked for key. Again. And again. And again...

REPRODUCIBILITY: always

OTHER COMMENTS:
But I still can connect to open and WEP networks.
Comment 1 Ryan Abel maemo.org 2008-08-04 00:02:31 UTC
Are you certain you're entering your key correctly, or that the network isn't
something weird, or that it isn't an issue with the router?

Have you encountered this issue on more than one router? After a fresh reflash
with no restored backup?

I'm inclined to mark this WORKSFORME, as I connect to several WPA/WPA2 routers
daily without issue and know several other people who do too.
Comment 2 AlekSi (reporter) 2008-08-04 07:03:50 UTC
(In reply to comment #1)
> Are you certain you're entering your key correctly, or that the network isn't
> something weird, or that it isn't an issue with the router?
It's my own router, it works and key is correct.

> Have you encountered this issue on more than one router?
Test only on my own router.

> After a fresh reflash with no restored backup?
After refresh and restore from backup.
Comment 3 Ryan Abel maemo.org 2008-08-04 08:42:47 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > Have you encountered this issue on more than one router?
> Test only on my own router.

Then clearly the summary of this bug is incorrect and you should've mentioned
that fact somewhere. Something like "Can't connect to XXXX router with
WPA/WPA2" might've been appropriate.

So, now that we know that the issue hasn't been tested with more than one
router, we need two things. Another test or two with some other routers using
WPA/WPA2 and information about your router.
Comment 4 Andre Klapper maemo.org 2008-08-04 12:58:47 UTC
AlekSi, 
what Access Point you have?
o Make and model?
o Firmware version?
o Hardware revision?
o What are the exact encryption settings? (open/WEP/WPA-PSK/WPA-EAP) 
o What's the distance to the Access Point?
Comment 5 tweety 2008-08-14 23:24:38 UTC
i have the same probleme here, after upgrading to diablo.

when i make a downgrade to 2.2007.51-3 connection to my to WPA/WPA2 network is
normally .. after refreh to diablo .. same problem again
after i entered the psk it will take about 1 minute and i am asked again to
enter the key .. and again and again

access point: zyxel g-2000plus
Firmware version: V3.60(HU.2) | 06/20/2005
Hardware revision: i don't know
What are the exact encryption settings: WPA-PSK 
What's the distance to the Access Point: 1 meter
Comment 6 Kimmo Kinnunen nokia 2008-08-15 10:04:05 UTC
I have same problem with standard Nokia HOC access point, Zyxel 660HW.

Works ok with WEP / unencrypted and chinook. Doesn't connect with WPA if N800
is running Diablo. WPA-PSK, 1 meter to the access point

System Name: P660HW-61_EN
ZyNOS F/W Version: V3.40(PE.8) | 12/23/2004
DSL FW Version:TI AR7 03.00.09.00
Standard:ADSL_G.dmt

Some settings related to WPA in Zyxel web admin:

802.1x Authentication
ReAuthentication Timer 1800s
Idle Timeout 3600s


Related dmesg output:

[   43.890625] (c)opyright 2004 Conexant
[   43.890625] 
[   43.890625] build info: PRISM SoftMAC
[   43.890625]   creator: [kvalo]
[   43.890625]   date: [07/10/05-11:45]
[   43.890625] 
[   43.898437] cx3110x: MAC address --------------.
[   43.906250] cx3110x: libumac version 2.12.0.0.a.9.15-5
[   43.906250] cx3110x: lmac version 2.13.0.0.a.22.8
[   43.906250] cx3110x: PSM disabled.
[   45.757812] cx3110x: scanned 13 channels.
[   46.015625] cx3110x: shut down softmac.
[   50.968750] EAC mode: play enabled, rec enabled
[   52.976562] cx3110x: loading 3826.arm firmware.
[   53.109375] JFFS2 warning: (1229) jffs2_sum_write_sumnode: Not enough space
for summary, padsize = -562

....

[   54.453125] menelaus 1-0072: Setting voltage 'VMMC' to 3000 mV (reg 0x0a,
val 0xb8)
[   55.156250] cx3110x: scanned 13 channels.
[   55.328125] cx3110x: shut down softmac.
[   55.710937] EAC mode: play enabled, rec enabled
[   56.734375] JFFS2 warning: (1229) jffs2_sum_write_sumnode: Not enough space
for summary, padsize = -1538
[   57.109375] JFFS2 warning: (1229) jffs2_sum_write_sumnode: Not enough space
for summary, padsize = -678
[   57.601562] JFFS2 warning: (1229) jffs2_sum_write_sumnode: Not enough space
for summary, padsize = -372
[   58.648437] JFFS2 warning: (1229) jffs2_sum_write_sumnode: Not enough space
for summary, padsize = -642
[   60.414062] JFFS2 warning: (1229) jffs2_sum_write_sumnode: Not enough space
for summary, padsize = -642
[   60.859375] JFFS2 warning: (1229) jffs2_sum_write_sumnode: Not enough space
for summary, padsize = -570
[   61.320312] JFFS2 warning: (1229) jffs2_sum_write_sumnode: Not enough space
for summary, padsize = -822

... repeats once ..


While trying to connect:

[   68.054687] cx3110x: scanned 13 channels.
[   70.265625] cx3110x: associated to 00:13:49:60:92:50 (bcn 200 msec, DTIM 2).
[   74.125000] EAC mode: play disabled, rec disabled
[   82.359375] cx3110x: DISASSOCIATE trap.
[   84.328125] EAC mode: play enabled, rec enabled
[   84.523437] cx3110x: associated to 00:13:49:60:92:50 (bcn 200 msec, DTIM 2).
[   90.218750] EAC mode: play disabled, rec disabled
[   96.742187] cx3110x: DISASSOCIATE trap.

.. repeats couple of times..
Comment 7 Kimmo Kinnunen nokia 2008-08-15 10:22:06 UTC
(In reply to comment #6)
> Works ok with WEP / unencrypted and chinook. Doesn't connect with WPA if N800
> is running Diablo. WPA-PSK, 1 meter to the access point

I mean, with chinook, WPA works. 
With Diablo, the same WPA settings don't work, WEP or no encryption works.
Comment 8 Kalle Valo nokia 2008-08-15 10:50:31 UTC
We haven't been able to reproduce this, so this is a tricky bug and we need
help from the community. Few questions:

o What happens if diablo is flashed without restoring backup? (already asked in
comment #1)

o Is the problem related to the WPA-PSK key? Maybe the lenght or certain
characters have something to do with this? Please try changing the key and see
what happens.
Comment 9 Kimmo Kinnunen nokia 2008-08-15 10:56:43 UTC
(In reply to comment #8)
> We haven't been able to reproduce this, so this is a tricky bug and we need
> help from the community. Few questions:
> 
> o What happens if diablo is flashed without restoring backup? 

I at least didn't use backup. I flashed without backup, just a clean N800.

> o Is the problem related to the WPA-PSK key? Maybe the lenght or certain
> characters have something to do with this? Please try changing the key and see
> what happens.

I used string 'aaaabbbb' as password, didn't work.

I could try with some other N800/N810 devices later..
Comment 10 Kalle Valo nokia 2008-08-15 11:01:36 UTC
(In reply to comment #9)
> (In reply to comment #8)
> > We haven't been able to reproduce this, so this is a tricky bug and we need
> > help from the community. Few questions:
> > 
> > o What happens if diablo is flashed without restoring backup? 
> 
> I at least didn't use backup. I flashed without backup, just a clean N800.
> 
> > o Is the problem related to the WPA-PSK key? Maybe the lenght or certain
> > characters have something to do with this? Please try changing the key and see
> > what happens.
> 
> I used string 'aaaabbbb' as password, didn't work.

This is good to know, thanks.

> I could try with some other N800/N810 devices later..

Please do. Also it would be good to test with other APs. I would like to know
if this is specific to ZyXel APs or some more general problem.

I'll confirm the bug because of multiple reporters.
Comment 11 Kimmo Kinnunen nokia 2008-08-15 16:07:59 UTC
Created an attachment (id=874) [details]
Syslog of trying to connect to the WPA protected zyxel access point with diablo

I tried 2 other N800 and a N810, they couldn't connect.

Attachment contains a syslog from N800 connection attempt.
Comment 12 Kalle Valo nokia 2008-08-17 09:33:26 UTC
One of our (remote) labs had a ZyXEL G2000plus and they were able to reproduce
the problem. The lab also had Zyxel P660HW-61 with firmware V3.40 (PE.11) |
05/22/2006, which is never than Kimmo has, and they weren't able to reproduce
the problem with that.

But now that we can reproduce the problem it's easier to fix this.

Alek, I would like to know more information about your Access Point/Router (see
comment #4). Do you have a ZyXEL or something else? Your problem might be the
same or something different.
Comment 13 tweety 2008-08-17 22:56:55 UTC
just for info: i updated my zyxel g2000plus firmware to 

ZyNOS Firmware Version: V3.60(HU.4) | 06/01/2006  which is the newest for this
product

nothing changed, still no chance to connect
Comment 14 Andre Klapper maemo.org 2008-08-18 12:26:01 UTC
@Kimmo:
I assume you run 4.2008.30-2 already?

@Aleksi:
As Kimmo tracked this down for the Zyxel 660HW, can you also provide the output
of "dmesg | tail" and a syslog for the Zyxel g-2000plus? Please see
http://maemo.org/development/tools/doc/diablo/syslog/ and
http://maemo.org/development/documentation/man_pages/sysklogd/ .
Please also provide information about your Access Point as requested in comment
4.

In general:
So from my community point of view this is a good example of working more
transparently having Kalle and Kimmo adding comments here (thanks guys!).
From my bugmaster point of view and the current workflows/error management
processes that exist within Nokia (means: cloning bugs to the internal closed
bugtracker) I'm afraid to make the bugfixing process less transparent by
cloning it to internal. Sigh...
Comment 15 Kimmo Kinnunen nokia 2008-08-19 08:27:26 UTC
(In reply to comment #14)
> @Kimmo:
> I assume you run 4.2008.30-2 already?

Yes, I think so, if the 30-2 was the first update through app manager? The
syslog was generated with 32-6. So none of the 23-14, 30-2, 32-6 work..

So in my case, updating to newer Zyxel 660HW firmware might fix the problem. I
try to refrain myself from updating, so that I could confirm the possible n800
firmware fix, when it is released.
Comment 16 Andre Klapper maemo.org 2008-09-03 22:01:11 UTC
Fixed in package
osso-wlan-security 1.3.17
which is part of the internal build version
diablo build 4.2008.35

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 17 Kalle Valo nokia 2008-09-04 09:17:09 UTC
I could tell a bit about the problem. This was a bug in the AP. It takes a long
time for this AP to start the EAPOL 4-way handshake and in diablo eapd had a
feature that if the AP doesn't start the handshake eapd will start it. But this
AP got confused in this case and that's why the handshake failed.
Comment 18 Andre Klapper maemo.org 2008-09-04 14:01:54 UTC
Ah. Thanks for taking the time to explain this!
Comment 19 tweety 2008-09-06 00:14:46 UTC
i would like to try if this bug is fixed, but where can i get the build version
diablo 4.2008.35  ??


nokia internet tablet software update wizard tells me, that the last version is
4.2008.23-14 .. the last update with application manager on n800 updated to 
build version 4.2008.30-2
Comment 20 Ryan Abel maemo.org 2008-09-06 00:37:58 UTC
(In reply to comment #19)
> i would like to try if this bug is fixed, but where can i get the build version
> diablo 4.2008.35  ??
> 

You don't, it hasn't been released yet. :)
Comment 21 Andre Klapper maemo.org 2008-09-29 15:41:37 UTC
Fix included in today's 4.2008.36-5 update.
Please verify if you find some time.
Comment 22 Kimmo Kinnunen nokia 2008-09-30 08:55:10 UTC
(In reply to comment #21)
> Fix included in today's 4.2008.36-5 update.
> Please verify if you find some time.

I'm happy to confirm that the fix works for me. My access point was Zyxel
660hw:

System Name: P660HW-61_EN
ZyNOS F/W Version: V3.40(PE.8) | 12/23/2004

Thank you very much!
Comment 23 Andre Klapper maemo.org 2008-09-30 15:37:11 UTC
Great, thanks!
Comment 24 tweety 2008-09-30 22:39:51 UTC
great ... now it works like it should ... thanks