Bug 3512 - Wiki does not import usernames with special characters
: Wiki does not import usernames with special characters
Status: RESOLVED FIXED
Product: maemo.org Website
Wiki
: unspecified
: All Windows
: Medium normal (vote)
: ---
Assigned To: Ferenc Szekely
: midgard@maemo.org
:
:
:
:
  Show dependency tree
 
Reported: 2008-07-29 15:21 UTC by Adam Harwell
Modified: 2008-12-09 14:18 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Adam Harwell (reporter) maemo.org 2008-07-29 15:21:14 UTC
STEPS TO REPRODUCE THE PROBLEM:
Create a maemo.org account with a special character in the username (for
example, an underscore).

EXPECTED OUTCOME:
The account works on all of maemo.org (garage, wiki, etc)

ACTUAL OUTCOME:
The wiki login page says the username does not exist.

REPRODUCIBILITY:
Only tried once

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET
CLR 1.1.4322; .NET CLR 2.0.50727; InfoPath.2; .NET CLR 3.0.04506.648; .NET CLR
3.5.21022)
Comment 1 Marcell Lengyel maemo.org 2008-07-29 15:26:24 UTC
None of the garage users with an "_" in their user name exist in the wiki
special pages / user list page. Maybe it is something to do with the
gforge-mediawiki account sync script...
Comment 2 Ferenc Szekely maemo.org 2008-08-19 11:47:44 UTC
started to work on it...
Comment 3 Ferenc Szekely maemo.org 2008-08-20 04:43:06 UTC
It was not a bug in my gforge authentication extension, but it is a 'feature'
in mediawiki itself: includes/Title.php line 2106 (secureAndSplit function),
where they replace all _ (underscores) with spaces. 

I implemented a workaround for that in the authentication extension. Now users
with _ in their user names should be able to login.
Comment 4 Adam Harwell 2008-09-08 10:05:38 UTC
I can now authenticate, but it will not retain my session at all. It thanks me
for logging in and gives me a link to go back to where I was, but upon visiting
that page or any other wiki page I am no longer logged in.
Comment 5 Niels Breet maemo.org 2008-12-09 14:18:38 UTC
I think I fixed your issue together with the other wiki login problem last
week. Can you please test if this was fixed for you, if not, please reopen this
bug.