Bug 3504 - Browser apparently hangs or closes due to an "internal error"
: Browser apparently hangs or closes due to an "internal error"
Status: RESOLVED INVALID
Product: Browser
MicroB engine
: 4.1 (4.2008.23-14)
: N800 Maemo
: Medium normal (vote)
: ---
Assigned To: unassigned
: microb-bugs
:
: crash, moreinfo
:
:
  Show dependency tree
 
Reported: 2008-07-27 16:55 UTC by luca
Modified: 2009-01-20 20:22 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description luca (reporter) 2008-07-27 16:55:32 UTC
SOFTWARE VERSION:
4.2008.23-14


The new combo browser/browserd is very unreliable. Things that happened to me
so far:

1) Browser apparently hangs or closes due to an "internal error". Sometimes
killing browserd is enough, sometimes you have to restart it and sometimes a
reboot is the annoying only way out.

2) Sometimes when you "open a link in a new window" and quickly try to switch
to the original window (this is necessary since there's no "open in background
window" option), the link will be opened in the original window and the new
window remains blank with the url pointing to the old location.

3) Sometimes it is futile to try to select a window in the taskbar since the
browser will put in the foreground whatever window it choses (usually the one
it has just loaded).

None of this happened with chinook.


OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux armv6l; es-ES; rv:1.9a6pre)
Gecko/20080606 Firefox/3.0a1 Tablet browser 0.3.7
RX-34+RX-44+RX-48_DIABLO_4.2008.23-14
Comment 1 Andre Klapper maemo.org 2008-07-27 17:32:07 UTC
Please always file seperate bug reports for seperate issues. Never file a list
of issues in one bug report. Thanks.
Comment 2 Andre Klapper maemo.org 2008-07-27 17:33:14 UTC
And "sometimes" is also problematic, having some kind of reproducible testcases
helps a lot to hunt down problems.
Comment 3 luca (reporter) 2008-07-27 23:20:11 UTC
I know (I have to hunt my own bugs from time to time).
2 and 3 happen quite often (you just have to be quick trying to switch to the
original window).
I couldn't isolate a specific set if conditions to trigger 1, though. It too
happens quite often here, though not as often as 2 and 3.
I didn't file separate reports because 1) I was extremely frustrated after
various unsuccessful attempts to start the browser (finally I had to reboot)
and 2) I think that these are related to some funky interaction between browser
and browserd.
Oh, and bugzilla spewed a database error, so I thought that the bug wasn't even
reported.
Silly me, trying to file a bug using the tablet ;-)
Comment 4 luca (reporter) 2008-07-27 23:57:47 UTC
Please consider this bug report only for issue 1), I will file separate bugs
for 2 and 3.
Comment 5 Andre Klapper maemo.org 2008-07-28 12:28:03 UTC
OK, so we talk about this here:
Browser apparently hangs or closes due to an "internal error". Sometimes
killing browserd is enough, sometimes you have to restart it and sometimes a
reboot is the annoying only way out.


In general for browser issues: Please create a browser logfile: Enter
about:config?prefname=browser.consolelogfile&prefvalue=/tmp/browserlog in the
browser location bar, set that preference, reproduce the browser problem and
post the content of the file /tmp/browserlog here.

In this special case it sounds like crashes.
Please run the browser in a terminal window (Applications Menu -> Utilities > X
Terminal, then enter the command "maemo-summoner /usr/bin/browser.launch > log
2>&1" and hit the Enter key) and attach the resulting "log" file here after it
has crashed?
Having a core dump could be even more useful. It requires installing the
"sp-rich-core" package from the tools repository[1] and creating a "core-dumps"
directory to the memory card with at least few megabytes of free space. You can
get core dumps also without the rich-core package, but they are much less
useful (and without it pre-installed applications core dumps are then named
maemo-launcher-*).
Comment 6 Andre Klapper maemo.org 2008-08-05 17:38:22 UTC
Luca: Can you answer my last question, please?
Comment 7 luca (reporter) 2008-08-11 00:55:26 UTC
No, since it didn't happen again. When I can reproduce it I'll try to get a
more detailed report.
Comment 8 Andre Klapper maemo.org 2009-01-20 20:22:58 UTC
Closing this bug report as no further information has been provided for more
than five months. Please feel free to reopen this bug if you can provide the
information asked for/if you can still reproduce this. Thanks!