Bug 3481 - (int-87071) PSM Interoperability problem with Freebox ADSL Access Point
(int-87071)
: PSM Interoperability problem with Freebox ADSL Access Point
Status: RESOLVED WORKSFORME
Product: Connectivity
WiFi
: 4.1 (4.2008.23-14)
: All Linux
: Low normal with 1 vote (vote)
: 5.0 (1.2009.42-11)
Assigned To: unassigned
: wifi-bugs
:
: use-time
:
:
  Show dependency tree
 
Reported: 2008-07-21 23:08 UTC by Frederic Crozat
Modified: 2010-02-04 10:47 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Frederic Crozat (reporter) 2008-07-21 23:08:14 UTC
French ISP Free is providing ADSL set-top-box called Freebox with included Wifi
AP (powered by Ralink chipset) which have an interoperability issue regarding
PSM (Power Saving Mode) with Nokia IT (either 770 / n800 / n810).

When an Nokia IT is connected on Wifi provided by Freebox AP, tablet autonomy
is 7 to 8h maximum (test with n800, with Diablo or Chinook image, freshly
flashed).
Comment 1 Ryan Abel maemo.org 2008-07-21 23:16:26 UTC
If the router doesn't properly support PSM then there's really nothing that can
be done tablet-side to fix it. . . .
Comment 2 Frederic Crozat (reporter) 2008-07-21 23:34:13 UTC
reopening : This bug was opened on request of Kalle Valo to track the issue and
maybe help Freebox engineer on fixing router (but we are not sure yet which
side is buggy).
Comment 3 Andre Klapper maemo.org 2008-07-22 14:39:58 UTC
Hej hej Frederic!

What exact model, firmware version, hardware revision?
Which encryption settings? (open/WEP/WPA-PSK/WPA-EAP)

AP settings:
What's the beacon interval?
What's the DTIM period? 

Could be helpful to track this down...
Comment 4 Frederic Crozat (reporter) 2008-07-22 14:58:03 UTC
On Internet Tablet side, tests are done with either n800 and n810, with both
Chinook and Diablo release, freshly flashed, no additional software installed.

On Freebox side, test are done with 
Freebox ADSL v5 FBX-ADSL05-00  (wifi chipset used is Ralink rt2500 on mini-pci
card).

Firmware on Freebox is 1.3.4 (which contains fixes for PSM which was dropping
incoming packets from AP to tablet when PSM was enabled).

Authentication used is WPA-PSK.

There is nothing configurable regarding Wifi parameters such as DTIM and beacon
interval.
Comment 5 Andre Klapper maemo.org 2008-07-22 15:27:14 UTC
I have to warn that there is one internal ticket (int-32990) about Freebox asdl
modems that was closed as WONTFIX because nobody was able to get a box to test
this. :-/

Anyway, let's try again...
Comment 6 Frederic Crozat (reporter) 2008-07-22 15:33:47 UTC
as I wrote on maemo-users mailing list, Freebox can only be used when
synchronized with Free ISP ADSL DSLAM. So, sending a Freebox to Finland would
be like sending a brick :)
Comment 7 Andre Klapper maemo.org 2008-07-22 15:38:51 UTC
Can i haz a brick too? :-D
Comment 8 Kalle Valo nokia 2008-07-23 23:10:57 UTC
(In reply to comment #2)
> reopening : This bug was opened on request of Kalle Valo to track the issue and
> maybe help Freebox engineer on fixing router (but we are not sure yet which
> side is buggy).

Yes, please keep this bug open, at least for a while. I asked Frederic to file
this bug so that we have the problem properly archived somewhere. I'm sure
Frederic isn't the only one experiencing the same problem with this AP.

Here's a link to the archives which contain our discussion:

http://lists.maemo.org/pipermail/maemo-users/2008-July/022005.html
Comment 9 Andre Klapper maemo.org 2008-08-11 12:24:46 UTC
WONTFIX for Diablo, should be checked again for Fremantle.
Comment 10 Andre Klapper maemo.org 2009-07-16 17:45:33 UTC
I've found no internal Fremantle Connectivity ticket mentioning "Freebox" so I
assume that we're blocked by the fact that it cannot be tested in Finland. :-/

Btw, the bug report by Fred in French is at
http://bugs.freeplayer.org/task/2538
Comment 11 Frederic Crozat (reporter) 2009-07-17 11:36:46 UTC
indeed, my guess it could be tested by some Nokia people in France.
Comment 12 Andre Klapper maemo.org 2009-09-28 17:06:06 UTC
Kalle, do you know if there's some Nokia folks located in France that could
test this?
Comment 13 Kalle Valo nokia 2009-10-12 11:16:57 UTC
(In reply to comment #12)
> Kalle, do you know if there's some Nokia folks located in France that could
> test this?

Sorry, no.
Comment 14 Yves-Alexis 2009-10-26 12:47:34 UTC
Hmh, I don't know much about PSM (but have an n810 and a freebox so I have the
same problem) but aIui, the device can't sleep when it sees packets arriving.
Are those packets only for itself, or does it wakes up even when the traffic
isn't for itself (because it needs to check if it's for itself or not)?

I usually have quite some machines awake and using wifi, and people often link
their Freebox ADSL with the Freebox HD (the part which deals with TV stuff)
using wireless. Meaning the wireless link is always busy, and the device never
sleeps.

Could that be related?
Comment 15 Andre Klapper maemo.org 2009-12-30 15:51:10 UTC
This report was filed against Maemo4 ("Diablo").
The N900 and Maemo5 ("Fremantle") have been available for some time now.

If you own an N900, we kindly ask you to retest this with Maemo5 if possible,
and update this report by describing whether this still happens and which exact
Maemo5 version you use (Settings > General > About product).

This is unfortunately a WONTFIX for Maemo4 as Maemo4 is in maintenance mode and
Nokia will only provide bugfixes for critical issues if at all, as Nokia
currently seems to concentrate on Maemo5 and future Maemo releases. Hence
without any status updates, this report will be closed within the next months.

Sorry that your issue could not be fixed for Maemo4. For your interest the Mer
project aims to provide a community backport of Maemo5 for 770/N8x0 devices.
See http://wiki.maemo.org/Mer for more information.
Comment 16 Yves-Alexis 2009-12-30 16:02:36 UTC
I (In reply to comment #15)
> This report was filed against Maemo4 ("Diablo").
> The N900 and Maemo5 ("Fremantle") have been available for some time now.
> 
> If you own an N900, we kindly ask you to retest this with Maemo5 if possible,
> and update this report by describing whether this still happens and which exact
> Maemo5 version you use (Settings > General > About product).

I own an N900 with 1.2009.42-11 and it seems to be reproducible too. I need to
check a bit more but it seems that using it on a quite active wireless lan
drains battery really fast (even faster than on 3G) even when the device is
idle.

Is there a way in M5 to tune PSM settings?
Comment 17 Frederic Crozat (reporter) 2009-12-30 17:39:54 UTC
you can tune PSM the same way on n900 as on n8x0.

I also own a n900 and it doesn't seem to have the same issue as n8x0 regarding
Freebox Wifi. But it is difficult to compare, since GSM/3G consumes a lot of
power and comparing battery usage between n810 and n900 is not really relevant. 

Moreover, n900 wifi chipset is no longer a Conexant CX3110x (like n810) but a
Texas Instruments WL1251 so PSM interoperability is probably different. I also
had a similar issue with Nokia n82 wifi and Freebox but I don't know which wifi
chipset is used in it.
Comment 18 Yves-Alexis 2009-12-30 18:35:39 UTC
(In reply to comment #17)
> you can tune PSM the same way on n900 as on n8x0.

Good point. So it's set (using defaults) to:

WLAN transmission power: 100mW
WPA2-only mode: disabled
Power-saving: on (maximum)
> 
> I also own a n900 and it doesn't seem to have the same issue as n8x0 regarding
> Freebox Wifi. But it is difficult to compare, since GSM/3G consumes a lot of
> power and comparing battery usage between n810 and n900 is not really relevant. 

But you can compare battery usage with and without wireless, and with different
access points.

Here I just noticed that letting the n900 idle with wifi on would drain the
battery pretty fast, but can't really reproduce reliably so it'll need more
tests.
Comment 19 Frederic Crozat (reporter) 2009-12-31 09:34:38 UTC
I just did some tests with n900 (2009-42.11 firmware): 
- almost fully charged
- running with GSM disabled (SIM card in it but without PIN code, so no
connection to GSM / 3G network)
- wifi enabled on Freebox AP
- no network activity on Wifi (either external or N900) so PSM is in effect

after 9h, battery level is about 75% (with n8x0, 7h30 of wifi in PSM mode was
draining the entire battery).
Comment 20 Andre Klapper maemo.org 2010-01-22 13:23:01 UTC
(In reply to comment #19)
> after 9h, battery level is about 75% (with n8x0, 7h30 of wifi in PSM mode was
> draining the entire battery).

According to this I'd close this as WORKSFORME (acceptable values), but

> letting the n900 idle with wifi on would drain the battery pretty fast

Sounds like it's way worse for Yves-Alexis.
Comment 21 Andre Klapper maemo.org 2010-02-04 10:40:55 UTC
Closing as per comment 19 (WORKSFORME as it's not perfect, but definitely way
better).

Yves-Alexis, if this is still an issue in 2.2009.51-1, please reopen.
Comment 22 Yves-Alexis 2010-02-04 10:47:31 UTC
(In reply to comment #21)
> Closing as per comment 19 (WORKSFORME as it's not perfect, but definitely way
> better).
> 
> Yves-Alexis, if this is still an issue in 2.2009.51-1, please reopen.
> 
Yeah, fair enough. The thing is, the way wifi works, if there is a lot of
traffic it /will/ wake on the n900 anyway and PSM won't be able to do anything.
I need to do a test on a quiet wifi to be really sure (but it's hard to find
nowadays :)