Bug 3424 - Don't display account settings & "bad username" error on connection failure
: Don't display account settings & "bad username" error on connection failure
Status: RESOLVED DUPLICATE of bug 3728
Product: Email
General
: 4.1 (4.2008.23-14)
: All Linux
: Low enhancement (vote)
: ---
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-07-09 01:37 UTC by Ian Burrell
Modified: 2009-10-22 06:16 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Ian Burrell (reporter) 2008-07-09 01:37:32 UTC
When there is a connection failure to a mail server, Email displays a dialog
box with "Unable to connect", a notification message about "bad username or
password", and show the account settings dialog.  This seems to be new
behavior; older versions of modest just displayed the dialog box.

It should be able to detect the difference between a potentially temporary
connection failure and a bad login.   Showing the account settings in the
latter case is helpful.  In the former, it is annoying and is another dialog
box that needs to be closed when there a network problem.
Comment 1 Lucas Maneos 2009-10-22 06:16:21 UTC
Hm, this is actually the same issue as bug 3728 (and fingers crossed, may
actually be fixed internally).  This one was reported first, but I'll mark it
as duplicate for housekeeping purposes since bug 3728 has had a lot more
discussion.

*** This bug has been marked as a duplicate of bug 3728 ***