Bug 3409 - RFE: Send-Only Identities in Modest Email Client
: RFE: Send-Only Identities in Modest Email Client
Status: RESOLVED WONTFIX
Product: Email
General
: 5.0-beta
: N800 All
: Low enhancement with 13 votes (vote)
: ---
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-07-06 18:08 UTC by Mike Lococo
Modified: 2012-03-24 11:42 UTC (History)
6 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Mike Lococo (reporter) 2008-07-06 18:08:09 UTC
DESCRIPTION:
Send-only email identities are useful for users that have several addresses
forwarding to a single account/mailserver, in order to be able to send messages
that appear to originate from the forwarded addresses. 

Thunderbird supports this via sender identities, other clients have "do not
automatically retrieve mail" checkboxes that allow send-only accounts to be
hacked together by entering bogus information for the mailserver.  Modest
appears to support neither method.

SOFTWARE VERSION:
4.2008.23-14 (Diablo/4.1)

STEPS TO REPRODUCE THE PROBLEM:
1) Look in the preferences of the "Email" application for send-only identity
configuration options.
OR AS A WORKAROUND

2) Configure account with bogus incoming mailserver information.

EXPECTED OUTCOME:
1) Find sender-only settings preferences, similar to those present in
Thunderbird under: Edit | Tools ) -> Account Settings -> your incoming account
(select a toplevel item in the tree, that is) -> Manage Identities.

OR AS A WORKAROUND

2) Be able to disable automatic retrieval for the send-only accounts that have
bogus incoming mailserver information entered.

ACTUAL OUTCOME:
1) Fail to find the desired options.

OR AS A WORKAROUND

2) Receive persistent error messages about the bogus information every time the
account is checked.  Two error dialogs per account appear every time mail is
checked.



REPRODUCIBILITY:
Always.

EXTRA SOFTWARE INSTALLED:
None.

OTHER COMMENTS:
I queried about this issue on Maemo-Users on 7/5 in a thread named "Send-Only
accounts in Modest" to confirm that the user community is not aware of an
end-user appliable workaround to this issue, and that there are other users
interested in seeing a viable solution created.

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.15)
Gecko/20080623 Firefox/2.0.0.15
Comment 1 Mike Lococo (reporter) 2008-07-10 20:49:36 UTC
A fair bit of discussion around this bug occurred in the maemo-users list. 
Check the gmane links below for the full threaded discussion:

  http://thread.gmane.org/gmane.comp.handhelds.maemo.user/11226
  http://thread.gmane.org/gmane.comp.handhelds.maemo.user/11245

Some highlights, pasted for convenience...

---------------------------------
Dirk-Jan.Binnema said:

There's currently no built-in way to handle this in modest; the reason
for the minimalism is that features tend to confuse many users (e-mail
setup is hard!). But obviously, that's not always the right choice for
users who know what they are doing...

What you *could* do (admittedly, a hack) is to get yourself a
pop-account somewhere that does not receive any messages, and use that
for the 'send-only' account.

---------------------------------
Mike Lococo said:

The above may be a general comment, but since you're a Modest dev and it has 
the feel of "wontfix" about it, I'll make the case for the bug/rfe:

1) Clearly, it's possible to have too many options in an application. 
However, major/respected desktop mail clients (including Thunderbird, 
Eudora, and Outlook) have made the decision to support this feature in 
one way or another (either through explicit sender identity support or 
by issuing error messages during mail checking in a non-intrusive way). 
  Furthermore, there's nothing unique about the mobile use-case that 
makes this an undesirable feature.

2) Modest already has methods to shield non-power-users from account 
setup complexity, namely the wizard process and the built-in presets for 
major mail providers.  A feature like this could default to the common 
state (no additional sender identities, as is currently the case), and 
not appear in any of those luser-friendly setup-interfaces while still 
being available in the edit-account settings to provide the 
functionality for power users.

3) It would be possible to greatly improve the state of things without 
any additional options at all by issuing missing mailserver errors 
during the new message check as an info-alert (is that the right term 
for the little popup messages in the upper right-corner of the screen 
that don't require user interaction to clear?), rather than as two 
separate popup boxes requiring user interaction to clear (one error 
message + the account preferences box in order to "fix" the faulty 
account).  It's worth noting that Modest already throws an error during 
account creation if the mailserver is bogus, so it's not necessary to 
issue such a loud error message during mail-check.

Thanks,
Mike Lococo

---------------------------------
Harri Haataja said:

The setup wizard has a "service provider" field, doesn't it?

Would it be sufficient to add a "send only" provider there that
would be a permanently blank inbox and no connections?
Hide this "advanced option" there with no extra UI.

---------------------------------
Dirk-Jan.Binnema said:

> 3) It would be possible to greatly improve the state of 
> things without  any additional options at all by issuing
> missing mailserver errors  during the new message check
> as an info-alert...

Yeah, that makes sense. Maybe leaving the incoming mail server empty
would be possible. But still, many users don't even understand the different 
universes of incoming and outgoing mailservers, and its hard to make it 
somehow hard for non-technical users to something wrong, while still
giving flexibility to powerusers...
Comment 2 Andre Klapper maemo.org 2009-06-05 14:45:39 UTC
If you set up an account manually it is not possible to change the Account type
for Incoming mail to "None" (this is the Evolution workaround for this).
Comment 3 Andre Klapper maemo.org 2010-01-14 14:09:16 UTC
*** Bug 7908 has been marked as a duplicate of this bug. ***
Comment 4 Adam Williamson 2010-11-23 04:31:08 UTC
Just bought an N900, and was frankly shocked to see this bug; never even
considered that a platform commonly used by F/OSS types wouldn't have this
feature. It makes email basically unusable for me and, I'm sure, others - I
regularly send email from five or six different addresses via my own mail
server. I've seen a workaround which looks like it'll work but really this
seems like something that should be fixed.
Comment 5 Paul 2010-11-23 04:40:58 UTC
This is a workaround that I proposed for fremantle:

http://talk.maemo.org/showthread.php?t=62838

It is an ugly hack, but seems to work *most* of the time.  The discussion about
keeping the email client configuration interface "simple" seems to
misunderstand who the is the target market for N900.  Hint: the N900 is the
most hackable phone in existance.
Comment 6 Adam Williamson 2010-11-23 04:52:39 UTC
yep, that's the workaround I saw - most ingenious (nice job!), but it really
oughtn't to be necessary :/
Comment 7 Otto Kekäläinen 2010-11-23 11:10:23 UTC
Thanks for the tip! I'll try it today.

I was already thinking of ditching my N900 for a Android phone, since I
really need to be able to send e-mail using different from-identities
and signatures. Also, my signatures are 72 characters wide, which does
not fit the e-mail app signature field (#11612).

The mobile computing experience is quite crippled if it's limited to
just reading e-mail and sending using just one from-address/signature. I
want to have a phone I can use to read and write e-mail anywhere,
anytime and with full e-mail client features.

I hope that soon a better e-mail client would be released for some Maemo/Meego
platform that I can install on my N900.

I guess I an not the only one who considers e-mail the most important app of an
smart phone. I hope the client would be open sourced so that others could add
the missing features if Nokia does not consider a proper e-mail client a
priority themselves.
Comment 8 Andre Klapper maemo.org 2010-11-23 15:20:34 UTC
(In reply to comment #4)
> Just bought an N900, and was frankly shocked to see this bug; never even
> considered that a platform commonly used by F/OSS types wouldn't have this

I had to laugh a bit - GNOME Evolution on Fedora, provided by Red Hat (very
likely your employer according to your address) does not have this either. ;-)

Anyway, let's please reduce the forum talk here.

Plus Maemo5 is now feature-frozen so I wouldn't expect a fix for this.
Comment 9 Xavier Bestel 2010-11-23 15:23:05 UTC
Uh ? Of course it does, I'm using it for several addresses.
Comment 10 Andre Klapper maemo.org 2010-11-23 15:25:13 UTC
(In reply to comment #9)
> Uh ? Of course it does, I'm using it for several addresses.

By not setting a server, yeah. Hackish workaround and popular support question.
Comment 11 Otto Kekäläinen 2010-11-23 15:35:48 UTC
Both Evolution and Thunderbird have genuine support for identities (with and
without custom SMTP servers). Modest does not have this.
Comment 12 Adam Williamson 2010-11-23 18:16:57 UTC
andre: "GNOME Evolution on Fedora, provided by Red Hat (very
likely your employer according to your address) does not have this either. ;-)"

Er, eh? Of course it does. By, as you say, not setting an incoming server. I
guess you can call that a 'hackish solution', but it's exactly what the
implementation of an identity is: an account with no incoming server. Think
about it; that's the definition of a sending identity. A name, an email
address, and an outgoing server. If Modest implemented this in exactly the same
way, that'd be fine.
Comment 13 Adam Williamson 2010-11-23 18:18:18 UTC
otto: the client is open sourced, see http://modest.garage.maemo.org/ (click
Development). Unfortunately I'm a QA guy not a coder, so I can't fix this
myself.
Comment 14 Andre Klapper maemo.org 2012-03-24 11:42:00 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia and it seems that there are no
plans for official updates currently, hence nobody plans to work on this
enhancement/wishlist request. 
(And in case you feel like discussing this situation: Nokia Customer Care or
http://talk.maemo.org would be the place to do so as you will not reach Nokia
officials in this community bugtracker - though all of this is really no news.)

Reflecting this status by setting RESOLVED WONTFIX for this
enhancement/wishlist request (see
https://bugs.maemo.org/page.cgi?id=fields.html#status for status explanations).

There is a small chance for issues in those Maemo components that are open
source: Contributed patches could be included and made available in the Maemo 5
Community CSSU updates. 
The Maemo CSSU project is run by a small team of volunteers; see
http://wiki.maemo.org/CSSU for more information.
So in case that you can provide a patch that fixes the reported problem, please
feel encouraged to file a request under
https://bugs.maemo.org/enter_bug.cgi?product=Maemo%205%20Community%20SSU .
Please note: The Maemo CSSU project is not related in any way to Nokia.


( Tag for mass-deleting bugmail: [cleanup20120324] )