Bug 3405 - Bluez-utils-test not available for installation
: Bluez-utils-test not available for installation
Status: RESOLVED INVALID
Product: Connectivity
Bluetooth
: 4.1 (4.2008.23-14)
: All Linux
: Low normal (vote)
: ---
Assigned To: unassigned
: bluetooth-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-07-06 05:37 UTC by tz
Modified: 2008-07-06 19:22 UTC (History)
0 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description tz (reporter) 2008-07-06 05:37:22 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)
Latest Diablo

STEPS TO REPRODUCE THE PROBLEM:
Run app manager, see available applications.  apt-get from the terminal. 
bluez-utils is installed.  bluez-utils-test isn't.

EXPECTED OUTCOME:
bluez-utils-test should be available (hcitool, l2ping, rfcomm, etc.) for use by
shell scripts or other programs that don't wish to either embed the functions
or use dbus or some other mechanism

ACTUAL OUTCOME:
bluez-utils already installed, no way to get the -test bits.
The .deb is created as part of dpkg-buildpackage under the SDK, but is
apparently not in any of the standard or even extras or extras-devel
repositories.  It was available under chinook.

REPRODUCIBILITY:
(always/sometimes/once)
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
l2ping could use this added to sudoers to allow normal users to access it:
user ALL = NOPASSWD: /usr/bin/l2ping *

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.15)
Gecko/20080625 Ubuntu/7.10 (gutsy) Firefox/2.0.0.15
Comment 1 Ryan Abel maemo.org 2008-07-06 15:56:35 UTC
Seems to be available here.
http://repository.maemo.org/pool/diablo/free/b/bluez-utils/
Comment 2 tz (reporter) 2008-07-06 18:10:20 UTC
How do I get it to appear in "Application Manager"?

It autorestored after a diablo update so something may be missing, but all the
other nokia stuff seems to be there.

Which repository do I need to add to make this appear in the list (or do I
require red or blue pill mode)?

Where is the packages, dist, or index file which lists it or does apt just read
every directory recursively?
Comment 3 Ryan Abel maemo.org 2008-07-06 18:25:15 UTC
(In reply to comment #2)
> How do I get it to appear in "Application Manager"?
>

I believe it's probably here: http://maemo.org/development/tools/

Anyway, closing, as the package is definitely available.
Comment 4 tz (reporter) 2008-07-06 18:47:32 UTC
Should I resubmit it as "Not in Application Manager"?

Having a needed package "somewhere" is not the same as having it somewhere it
can be installed.
Comment 5 tz (reporter) 2008-07-06 18:48:54 UTC
Note: It was in Application Manager under Chinook
Comment 6 Faheem Pervez maemo.org 2008-07-06 19:17:03 UTC
This one can be found in the Diablo SDK repo. The structure of dists is
different though. I can see it in my Diablo with N800 in redpill.

Details:
Catalogue Name: Maemo Diablo
Web address: http://repository.maemo.org/
Distribution: diablo
Components: sdk/free tools/free sdk/non-free tools/non-free

Or (not tested), these lines in your sources.list[.d]:
deb http://repository.maemo.org/ diablo/sdk free non-free
deb-src http://repository.maemo.org/ diablo/sdk free
deb http://repository.maemo.org/ diablo/tools free non-free
deb-src http://repository.maemo.org/ diablo/tools free
Comment 7 tz (reporter) 2008-07-06 19:22:59 UTC
Thank You.  This needs to be in the FAQ or wiki somewhere.

I missed that the repos (beyond extras and extras-devel) needed to add the SDK
entries.

I have a package I'm working on turning into a correct .deb for diablo and use
some of the tools in scripts, but couldn't figure out how to point at it.

(I would suggest that original l2ping sudoers entry though)