Bug 3389 - mail about summit should not say "1" when it means "Yes"
: mail about summit should not say "1" when it means "Yes"
Status: RESOLVED FIXED
Product: maemo.org Website
General
: unspecified
: All Windows
: High normal (vote)
: ---
Assigned To: Henri Bergius
: midgard@maemo.org
:
:
:
:
  Show dependency tree
 
Reported: 2008-07-03 22:05 UTC by timeless
Modified: 2008-07-30 14:48 UTC (History)
2 users (show)

See Also:


Attachments
Patch that translates 1 etc. to True / False (906 bytes, patch)
2008-07-23 02:08 UTC, Benjamin Podszun
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description timeless (reporter) 2008-07-03 22:05:14 UTC
STEPS TO REPRODUCE THE PROBLEM:
1. register for the maemo summit (#1)

EXPECTED OUTCOME:
email should be consistent

ACTUAL OUTCOME:
I'm requesting for Nokia to sponsor my trip:
  No
...
I understand that it is in my responsibility to present passport or whatever
visa I need to travel:
  1

REPRODUCIBILITY:
can't try to reproduce

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
1 should be "yes"
Comment 1 Andre Klapper maemo.org 2008-07-21 18:00:18 UTC
(not a calendar bug)
Comment 2 Benjamin Podszun 2008-07-23 02:08:54 UTC
Created an attachment (id=835) [details]
Patch that translates 1 etc. to True / False

Disclaimer: I'm a complete newbie here.

I attach a patch that should (to my limited understanding) fix this cosmetic
issue. The file in question is
midgard-data/snippets/sitegroup-config/net.nemein.registrations/schemadb.php

HTH
Comment 3 Oskari Kokko 2008-07-25 16:01:09 UTC
Needs a modification to net.nemein.registrations (registration.php, line 218,  
      $registration_data = $registration_dm->get_content_csv();).
get_content_csv needs to be changed to something else, because get_content_csv
returns boolean datatype just the way it should be. Assigning to bergie.
Comment 4 Henri Bergius 2008-07-30 14:48:09 UTC
This should fix the issue: http://trac.midgard-project.org/changeset/17003

midcom.helper.datamanager2 and net.nemein.registrations need to be packaged and
updated on the server.