Bug 3378 - (int-82482) Connection dialog presents only previous connections and doesn't scan
(int-82482)
: Connection dialog presents only previous connections and doesn't scan
Status: RESOLVED FIXED
Product: Connectivity
WiFi
: 4.1 (4.2008.23-14)
: All All
: High normal (vote)
: ---
Assigned To: unassigned
: wifi-bugs
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2008-07-03 09:59 UTC by G Billios
Modified: 2008-11-17 11:51 UTC (History)
5 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description G Billios (reporter) 2008-07-03 09:59:08 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)
4.2008.23-14
STEPS TO REPRODUCE THE PROBLEM:
- Open the connect-to dialog
EXPECTED OUTCOME:
- Scan for WLANs in range and display them in order to connect
ACTUAL OUTCOME:
- It presents the WLANs list from previous scan and either doesn't scan for new
or it doesn't present them

You must restart the device in order to work properly.
REPRODUCIBILITY:
(always/sometimes/once)
always
EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
This happens after upgrading my N800 to Diablo and restoring from a backup.
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9)
Gecko/2008052906 Firefox/3.0
Comment 1 Andre Klapper maemo.org 2008-07-04 15:13:59 UTC
Does running "/etc/init.d/networking restart" as root update the list?

Do you have some saved wifis in your list? Are they correctly displayed at
least?
This happens with different SSIDs?
Comment 2 G Billios (reporter) 2008-07-04 22:20:30 UTC
I have preconfigured connections and all I would get in the connection dialog
was the 2 packet connections I have plus any other wifi I scanned previously
including the preconfigured connections.

I will try what you write but I will report back probably in a week due to
incoming vacations :)
Comment 3 G Billios (reporter) 2008-07-15 12:21:26 UTC
I'm back and tested to restart the networking service but it failed with the
following output:

/home/user # /etc/init.d/networking restart
/etc/network/options is deprecated.
Setting up IP spoofing protection...done (rp_filter).
Reconfiguring network interfaces...mc-disconnect[4611]: GLIB DEBUG default -
checking MC status
mc-disconnect[4611]: GLIB DEBUG default - mission_control_get_presence: MC not
running.
run-parts: /etc/network/if-post-down.d/zz_proxy_unset exited with return code 1
ifdown: don't seem to have all the variables for eth0/inet
mc-disconnect[4635]: GLIB DEBUG default - checking MC status
mc-disconnect[4635]: GLIB DEBUG default - mission_control_get_presence: MC not
running.
route: SIOC[ADD|DEL]RT: No such device
ifconfig: SIOCGIFFLAGS: No such device
run-parts: /etc/network/if-up.d/00_proxy_set exited with return code 1
ifup: don't seem to have all the variables for eth0/inetifconfig: SIOCGIFFLAGS:
No such device
ifconfig: SIOCSIFADDR: No such device
route: SIOC[ADD|DEL]RT: No such device
failed.

As I wrote, saved wifi's appear even if they are not present and also data
packet connections appear, in general only the networks that were found the
first time after I restart the device appear. If afterwards I move to another
location with other access points - even saved ones - they don't appear until I
restart the device.
Comment 4 Andre Klapper maemo.org 2008-07-21 14:30:31 UTC
OK, sounds like something is not updated, or somehow the hardware connection is
lost...
Wild guessing:
What are the encryption settings? (open/WEP/WPA-PSK/WPA-EAP)
Does disabling Power Save Mode (PSM) in N800/N810 help?
Does this always happen with the same Access Point you have at home? How often
does it happen?
Comment 5 G Billios (reporter) 2008-07-24 20:26:37 UTC
Answers to Andrew:

What are the encryption settings? (open/WEP/WPA-PSK/WPA-EAP)
- WPA-PSK on all AP 

Does disabling Power Save Mode (PSM) in N800/N810 help?
- No

Does this always happen with the same Access Point you have at home? How often
does it happen?

- No, it happens with every access point and it happens always.


One way to resolve this, was to reflash the device and not restore the backup.
Probably if I restore the backup but not the settings it will keep working
fine, but there is no point to restore a backup without the settings!
Comment 6 Andre Klapper maemo.org 2008-08-08 16:45:23 UTC
So according to your last comment, it is related to applying the backup from
Chinook?
Comment 7 G Billios (reporter) 2008-08-15 17:00:07 UTC
Exactly, it seems that restoring a backup made with chinook breaks the
connection dialog.
Comment 8 Eero Tamminen nokia 2008-09-17 12:08:58 UTC
We had an internal bug with similar symptoms, but it's not related to 
backup/restore.  The bug was hard to reproduce (and debugging it seems
often to require syslog data for over a day previous to when the issue
first appears), but it should be fixed in the w30 software upgrade.

Could you test whether your issue goes away with that?
Comment 9 G Billios (reporter) 2008-10-19 20:37:02 UTC
(In reply to comment #8)
> We had an internal bug with similar symptoms, but it's not related to 
> backup/restore.  The bug was hard to reproduce (and debugging it seems
> often to require syslog data for over a day previous to when the issue
> first appears), but it should be fixed in the w30 software upgrade.
> 
> Could you test whether your issue goes away with that?
> 

I'm sorry for the late response but the bug email was lost between work and
work :D 

I can test of course with a backup/restore if you want.
Comment 10 Andre Klapper maemo.org 2008-10-20 11:20:09 UTC
Please do if you have some time.
Comment 11 Quim Gil nokia 2008-11-17 08:22:05 UTC
This bug is in the Bug Jar top 10 and according to Eero is either fixed in the
last release or quite wontfix (because of its rarity). Can you please check
again? Thank you!
Comment 12 Armin M. Warda 2008-11-17 09:38:43 UTC
(In reply to comment #11)
> This bug is in the Bug Jar top 10 and according to Eero is either fixed in the
> last release or quite wontfix (because of its rarity). Can you please check
> again? Thank you!
> 

I did not see this bug anymore during the last weeks or even months. Seems to
be fixed. (4.2008.36-5, Nokia-N810-23-14 2.6.21-omap1)
Comment 13 Andre Klapper maemo.org 2008-11-17 11:51:07 UTC
Assuming that it is FIXED by latest comment.
If this still happens for anybody running 4.2008.36-5, please REOPEN.