Bug 3369 - (int-87598/int-117875) only one mime part of message is shown
(int-87598/int-117875)
: only one mime part of message is shown
Status: CLOSED FIXED
Product: Email
General
: 5.0-beta
: All Maemo
: Low normal with 1 vote (vote)
: 5.0-beta2
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-07-02 14:49 UTC by Glazov Arkadiy
Modified: 2009-07-14 13:38 UTC (History)
8 users (show)

See Also:


Attachments
Modest main screen (69.75 KB, image/png)
2008-07-04 14:26 UTC, Glazov Arkadiy
Details
Loaded messages without body (20.97 KB, image/png)
2008-07-04 14:27 UTC, Glazov Arkadiy
Details
command shell output (21.32 KB, image/png)
2008-07-04 14:28 UTC, Glazov Arkadiy
Details
Original message from Gmail (65.81 KB, image/png)
2008-07-04 14:29 UTC, Glazov Arkadiy
Details
Example message triggering the bug (5.79 KB, application/x-gzip)
2008-08-17 01:28 UTC, Andre Klapper
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Glazov Arkadiy (reporter) 2008-07-02 14:49:37 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)
4.2008

STEPS TO REPRODUCE THE PROBLEM:
Subsribe and recieve letters from maemo-developers-request@maemo.org via google
imap

EXPECTED OUTCOME:
I am subscribed to maemo-developers-request@maemo.org to my private box on
gmail.com. In browser I can see all letters. But then I try to receive letters
from maemo-developers-request@maemo.org to modest by IMAP, i don't see messages
body. Modest write "retrive..." and show only header after them with blank
body.

ACTUAL OUTCOME:

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9)
Gecko/2008052906 Firefox/3.0
Comment 1 Neil MacLeod maemo.org 2008-07-02 16:01:03 UTC
*** Bug 3368 has been marked as a duplicate of this bug. ***
Comment 2 Andre Klapper maemo.org 2008-07-04 14:03:11 UTC
(In reply to comment #0)
> SOFTWARE VERSION:
> 4.2008

That version does not exist.

> EXPECTED OUTCOME:
> I am subscribed to maemo-developers-request@maemo.org to my private box on
> gmail.com. 

You can't subscribe to that, probably you meant maemo-developers@maemo.org ?

I just tried this too with my gmail address in Modest on 4.2008.23-14 and I
haven't had any problems.

> REPRODUCIBILITY:
> always

So this happens to all messages from maemo-developers mailing list to you? Does
this also happen with other emails? 
Also, starting from the commandline ('modest showui') might give some valuable
output - please post it here.

In general, please provide a step-by-step how-to.
Comment 3 Glazov Arkadiy (reporter) 2008-07-04 14:26:16 UTC
Created an attachment (id=808) [details]
Modest main screen

Main screen with messages list
Comment 4 Glazov Arkadiy (reporter) 2008-07-04 14:27:23 UTC
Created an attachment (id=809) [details]
Loaded messages without body

Open message without body
Comment 5 Glazov Arkadiy (reporter) 2008-07-04 14:28:20 UTC
Created an attachment (id=810) [details]
command shell output

result of run command "modest showui"
Comment 6 Glazov Arkadiy (reporter) 2008-07-04 14:29:08 UTC
Created an attachment (id=811) [details]
Original message from Gmail

How really message look in web browser
Comment 7 Glazov Arkadiy (reporter) 2008-07-04 14:32:39 UTC
My version also is 4.2008.23-14.
I'm subscribed on https://lists.maemo.org/mailman/listinfo/maemo-developers
Subscribed email is uglobster@gmail.com on Gmail server.
Modest connect to gmail by IMAP.
Command line run 'modest showui' don't get any output.

A attached screenshot's from my tablet for demo of bug.
Comment 8 Andre Klapper maemo.org 2008-08-04 16:11:23 UTC
Again: Please provide a step by step explanation.
"Subsribe and recieve letters from maemo-developers-request@maemo.org via
google
imap" is not sufficient to reproduce this.
Comment 9 Glazov Arkadiy (reporter) 2008-08-05 08:52:25 UTC
If you want to reproduce this bug - is very simple.
1. Create if you don't have gmail account. I can to send invite if you need.
2. Subscribe on https://lists.maemo.org/mailman/listinfo/maemo-developers to
"maemo-developers Digest" with plain-text option for this gmail email.
3. On modest NIT to create GMAIL IMAP account for this email.

After them we will be on receive one bug letters per day (or more).

I think that this modest bug in next: It can't receive letters with attachments
as another letters in plain text.
Comment 10 Andre Klapper maemo.org 2008-08-13 02:28:15 UTC
I still could not reproduce this.
Can you please forward the offending message to my gmail imap account? My
address is    andre /dot/ klapper \at/ gmail \dot\ commm
(yes, i hate getting even more spam. ;-)
Comment 11 Glazov Arkadiy (reporter) 2008-08-13 19:55:53 UTC
I made redirect to your address required letters.
Comment 12 Andre Klapper maemo.org 2008-08-17 01:28:04 UTC
Created an attachment (id=876) [details]
Example message triggering the bug

I could reproduce this several times with any the maemo-developers digest
emails on Modest, using my GMail IMAP account.

Attaching such an offending email (.tar.gz to avoid spam bots harvesting the
addresses) which was saved on my desktop computer where it is displayed
correctly (mail application on desktop: Evolution 2.22.3.1).
Comment 13 Sergio Villar Senin 2008-08-18 19:50:14 UTC
Thx for the report!. The problem is that we're not detecting the email body
correctly in this case. We're investigating why. Actually I fixed a small issue
and I can see part one of the text mime parts that the message includes, but I
wont commit it until I improve a little bit the body detection for these cases.
Comment 14 Andre Klapper maemo.org 2008-08-19 22:57:31 UTC
Bug 3607 might be a duplicate.
Comment 15 Andre Klapper maemo.org 2008-09-09 23:56:42 UTC
*** Bug 3607 has been marked as a duplicate of this bug. ***
Comment 16 Andre Klapper maemo.org 2008-09-14 20:24:04 UTC
(In reply to comment #11)
> I made redirect to your address required letters. 

Glazov, can you please revert that now? :-)
Comment 17 Andre Klapper maemo.org 2008-11-22 16:49:48 UTC
*** Bug 3018 has been marked as a duplicate of this bug. ***
Comment 18 Andre Klapper maemo.org 2009-02-09 13:30:24 UTC
Sergio, are there any news here?
Comment 19 Andre Klapper maemo.org 2009-02-09 13:31:30 UTC
*** Bug 4067 has been marked as a duplicate of this bug. ***
Comment 20 Lucas Maneos 2009-03-07 10:49:37 UTC
*** Bug 2720 has been marked as a duplicate of this bug. ***
Comment 21 Uwe Kaminski 2009-03-30 15:46:08 UTC
*** Bug 3639 has been marked as a duplicate of this bug. ***
Comment 22 Andre Klapper maemo.org 2009-05-19 19:12:03 UTC
Sergio said that there are currently no plans to fix this because there hasn't
been time for that. Hence still valid in Fremantle.

"If you have several plain text mime parts there is no easy way to know which
one is the important part. So the solution would be to show them all."
Comment 23 Andre Klapper maemo.org 2009-05-19 19:26:13 UTC
*** Bug 3942 has been marked as a duplicate of this bug. ***
Comment 24 Lucas Maneos 2009-05-19 20:11:07 UTC
(In reply to comment #22)
> "If you have several plain text mime parts there is no easy way to know which
> one is the important part. So the solution would be to show them all."

Ideally the user should be able to see a list of the message's MIME parts and
navigate between them, and in the case of message/rfc822 parts even perform
message operations like reply, forward etc on those parts.  See claws-mail and
mutt (view-attachments, bound to 'v' by default) for decent multipart
presentation implementations.
Comment 25 Andre Klapper maemo.org 2009-05-25 19:01:29 UTC
So,
changes have been pushed to modest master at
https://git.maemo.org/projects/modest/gitweb?p=modest;a=summary :
Commits 24a3eee9a7ec6968ff0b3bb25b80d50cfca546c6 to
3a69262f88128f4dd3c78bbe62abc90f13491ded.
Verification highly welcome!

Quoting from the internal ticket:
   * Changed the body detection. Now we only use the html/text preference when
we find a body in a multipart/alternative. If not, we show as body the first
text/ part in the message.
   * Now we show the messages in a multipart/digest, if the message has one
attached. Then we can show properly all the messages in the digest.
   * The other possible bodies we find in the message are shown as attachments.

Using tinymail revision 3924 also properly sorts the mimeparts.
Comment 26 Lucas Maneos 2009-05-25 19:27:34 UTC
Verified, it works very nicely now :-)
Comment 27 Andre Klapper maemo.org 2009-05-26 12:55:37 UTC
Thank you!
Comment 28 Andre Klapper maemo.org 2009-07-14 13:38:18 UTC
Fix should be included in Fremantle SDK beta 2 hence updating Target Milestone.
If you are the reporter of this bug: Feel free to verify the fix if possible.