Bug 3359 - BT keyboard lags and loses typed characters.
: BT keyboard lags and loses typed characters.
Status: RESOLVED WONTFIX
Product: Connectivity
Bluetooth
: 4.1 (4.2008.23-14)
: ARM Maemo
: Low major with 2 votes (vote)
: 5.0 (1.2009.41-10)
Assigned To: unassigned
: bluetooth-bugs
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2008-07-01 11:58 UTC by luarvique
Modified: 2009-09-28 16:38 UTC (History)
5 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description luarvique (reporter) 2008-07-01 11:58:39 UTC
SOFTWARE VERSION:
Latest ITOS firmware from Nokia (aka Diablo)

STEPS TO REPRODUCE THE PROBLEM:
Connect BT keyboard to the tablet (tested with Apple BT keyboard), bring up an
application (XTerm, Notes, XChat, etc) and start typing.

EXPECTED OUTCOME:
Typed characters appear immediately and are not getting lost.

ACTUAL OUTCOME:
There is noticeable lag between key presses and display and if you type fast,
typed characters just get lost. This behavior does not depend on the CPU load
and cannot be fixed by elevating hcid priority.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9)
Gecko/2008052906 Firefox/3.0
Comment 1 Andre Klapper maemo.org 2008-07-01 15:08:42 UTC
Sounds like pairing issues, please see bug 2640 for other reports, especially
some other Apple keyboard users.

Wild guess: Does https://bugs.maemo.org/show_bug.cgi?id=2640#c9 fix the problem
for you?
Comment 2 luarvique (reporter) 2008-07-01 16:05:33 UTC
>Sounds like pairing issues, please see bug 2640 for other reports, especially
>some other Apple keyboard users.
I have no problem pairing with Apple BT keyboard.

>Wild guess: Does https://bugs.maemo.org/show_bug.cgi?id=2640#c9 fix the problem
>for you?
It does not, as I have no problems pairing with Apple BT keyboard. What I have
is the lag issue and skipped characters. This problem has been confirmed to
exist by other users with other (non-Apple) BT keyboards.
Comment 3 Andre Klapper maemo.org 2008-07-01 16:16:22 UTC
(In reply to comment #2)
> It does not, as I have no problems pairing with Apple BT keyboard. What I have
> is the lag issue and skipped characters. This problem has been confirmed to
> exist by other users with other (non-Apple) BT keyboards.

Well, I can't see those confirmations here, would be nice to have them together
with exact information about the keyboards used.
Comment 4 kenneth 2008-07-05 02:20:31 UTC
could there be some kind of outside interference?
wireless phone or something close by?

or near-dead batteries in the keyboard?
Comment 5 luarvique (reporter) 2008-07-05 09:08:17 UTC
There is a laptop using WiFi in the immediate vicinity of the tablet (20-50cm).
There was also a cell phone with BT turned on nearby but I removed it to ~20m
distance for this experiment. It did not change a thing.

Keyboard batteries are about 3 months old and have been used for the total of
~1 hour.
Comment 6 Andre Klapper maemo.org 2008-07-15 16:17:52 UTC
> This problem has been confirmed to exist by other 
> users with other (non-Apple) BT keyboards.

Can you please come up with at least one reference to other users complaining
about this, please? Having more people running into this makes it easier to
track it down. Thanks.
Comment 7 John 2008-07-15 20:18:27 UTC
I'll add my two cents.

I have a generic USB mini-keyboard connected to my N800. I can confirm that
there is noticeable lag between keys being pressed and letters appearing, but
only during periods of fast typing. As a test app I used "Notes."

With prediction on and cpufreq scaling_governor set to ondemand (default) I get
noticeable lag, sometimes up to 5 characters or so when typing at full speed.
(CPU usage seems to be pretty high, over 50%)

With prediction off (and ondmeand cpufreq scaling_governor) it comes down to
two characters of lag.

With prediction off and and cpufreq set to "performance" the lag is reduced to
almost nothing, I can't get more than 1 character ahead.

I notice no dropped characters in any situation. I think the lag and dropped
cahracters may be a combination of several factors or possibly not directly
related to each other.

Note: It's difficult for me to test consistently, as my keyboard is a little
bit less than full sized. I can't touch type like I can on a normal sized
desktop keyboard, so it's possible that I'm typing at different speeds in
different situations, though I tested each setup at least twice and my results
seemed similar. For a really painful example of the lag, try typing in the body
of an email message in gmail.
Comment 8 Ryan Abel maemo.org 2008-07-15 20:45:34 UTC
+1 for John, there's definitely noticeable lag when typing (with both Bluetooth
and USB).

The only reason I haven't confirmed this is because I have never seen dropped
characters. But the lag is definitely significant and has been complained about
main times on itT and the mailing lists.
Comment 9 krisse 2008-07-27 12:32:54 UTC
I've got Nokia's own SU-8W keyboard, which is the one they officially recommend
for their tablets and smartphones.

If I use the SU-8W on any of my Nokia smartphones (which are based on Symbian),
there is absolutely no lag at all, the characters appear instantly just like on
a PC keyboard.

If I use exactly the same SU-8W on any of my Nokia tablets, there is always a
very noticeable lag, and has been with all firmware versions.
Comment 10 krisse 2008-07-27 12:39:55 UTC
PS: I've never had lost characters with the Su-8W, but the lag means I don't
see mistakes instantly, so I have to go back into the text more often to
correct it.
Comment 11 krisse 2008-07-27 12:52:07 UTC
Sorry to reply three times in a row , but I just remembered that I got exactly
the same lag with USB keyboards attached to the tablets in host mode. This
implies the problem isn't necessarily anything to do with Bluetooth at all.

There may be some general problem with the text input system, which would
affect all methods of inputting text.

Text input lag wouldn't be noticeable with the on-screen keyboards because
people type so slowly on them, but with a BT or USB keyboard the typing speed
can be enough to overwhelm the text input system slightly, hence the lag.
Comment 12 Craig Miller 2008-07-29 01:59:11 UTC
I see dropped charactors all the time at the beginning of pairing. That is the
bluetooth icon is white/grey, start typing, and the icon will turn blue. The
first few keystrokes are lost.

This was not the case in OS2007.

(I am using a N800 running Diablo with a iGo BT keyboard)

I recommend confirming this bug.
Comment 13 Andre Klapper maemo.org 2008-08-08 17:28:39 UTC
(In reply to comment #11)
> There may be some general problem with the text input system, which would
> affect all methods of inputting text.

Also see bug 3511.
Comment 14 Michiel Scholten 2008-10-21 12:11:18 UTC
I would like to chime in on this issue. I have a Think Outside iGo bluetooth
keyboard which I use with my n810. I've always had lagging performance while
typing, which results in dropped characters, or repeated ones (while I don't
type them multiple times). The repetition of typed characters happens more
often than droppage.

The batteries of both the keyboard and the tablet are fine and they are paired
correctly.

This issue is even worse when also having the tablet paired with my cellphone
for internet usage, but this is not necessary to see the lag.
Comment 15 Lucas Maneos 2009-03-27 13:25:28 UTC
*** Bug 2767 has been marked as a duplicate of this bug. ***
Comment 16 Michael Casadevall 2009-05-04 00:44:35 UTC
Another vote on this bug, can confirm it with the Freedom Universal Keyboard.
Seems to be a problem in the hildon keyboard layer as CPU performance spikes
with each key press.
Comment 17 Andre Klapper maemo.org 2009-09-28 16:38:16 UTC
This is a WONTFIX for both Maemo5 and Maemo4 as using a Bluetooth keyboard is
not officially supported in Maemo 5 (of course improvements can always be made
by community or third party enhancements).

Please note though that according to
http://wiki.maemo.org/Fremantle_Unsupported_Bluetooth_profiles Maemo5 comes
with the bluetoothd input plugin installed but disabled through
/etc/bluetooth/main.conf.

For Enhancements: You are invited to use the Maemo Brainstorm to
push any ideas with regard to unsupported Bluetooth profiles:
http://maemo.org/community/brainstorm/This issue has been FIXED in the internal
Fremantle version.