Bug 3339 - MediaBox Media Center appears as developed by Nokia when it's not
: MediaBox Media Center appears as developed by Nokia when it's not
Status: RESOLVED FIXED
Product: maemo.org Website
Downloads
: unspecified
: All Linux
: Medium normal (vote)
: 4.1+
Assigned To: Henri Bergius
: downloads@maemo.org
: https://maemo.org/downloads/product/O...
:
:
:
  Show dependency tree
 
Reported: 2008-06-29 11:56 UTC by Quim Gil
Modified: 2009-05-20 17:15 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Quim Gil (reporter) nokia 2008-06-29 11:56:53 UTC
STEPS TO REPRODUCE THE PROBLEM:

Go to https://maemo.org/downloads/product/OS2008/mediabox/

EXPECTED OUTCOME:

No "Application developed by Nokia" is shown since this is developed by a thrid
party aka Martin Grimme.

ACTUAL OUTCOME:

Shows "Application developed by Nokia" although the "Nokia Provided" field in
the edit form is not selected.

REPRODUCIBILITY:
always

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en; rv:1.8.1.13)
Gecko/20080325 Epiphany/2.20 Firefox/2.0.0.13
Comment 1 Jamie Bennett 2008-06-29 23:23:23 UTC
CAn you be more specific? Where does it say developed by Nokia? The Author is
clearly marked as Martin Grimme now, has this been fixed?
Comment 2 Niels Breet maemo.org 2008-06-30 11:40:18 UTC
Yesterday, I set Nokia provided tickbox to selected and saved, to deselected
and saved. This cleared out the Nokia provided field.

The real problem is that the tickbox for 'Nokia Provided' didn't show the
status in the database. I'm thinking that this is a midcom problem, since I can
reproduce this one the following urls:

https://maemo.org/downloads/product/PC/internettabletvideoconverter
Shows Nokia provided

https://maemo.org/downloads/product/edit/516031e6fefe11dc90fc5973a8573c2e3c2e.html
Doesn't show it.
Comment 3 Niels Breet maemo.org 2008-07-04 17:53:29 UTC
I can confirm this on the internal test machine too. I have upgraded every
library there and it still happens.

Check for example the fm-radio application on os2007:

Parameter for the object:
midcom.helper.datamanager2              nokia_application              1

But the edit form doesn't show it.

This seems to be a datamanager bug, not a Maemo downloads bug. So assigning it
to bergie.
Comment 4 Quim Gil (reporter) nokia 2008-07-19 14:54:33 UTC
Low until someone proposes it for a sprint. Now the issues doesn't burn that
much.
Comment 5 Niels Breet maemo.org 2008-11-11 15:26:56 UTC
I tested this in the new ragnaroek install and comment #3 is still valid. Issue
is still there.
Comment 6 Andre Klapper maemo.org 2009-05-20 17:15:29 UTC
Nowadays http://maemo.org/downloads/product/OS2008/mediabox/ mentions
"Author: Martin Grimme", so I consider this FIXED.