Bug 3335 - (int-86718) No automatic refresh of feeds in Diablo after applying backup
(int-86718)
: No automatic refresh of feeds in Diablo after applying backup
Status: RESOLVED DUPLICATE of bug 3542
Product: RSS feed reader
General
: 4.1 (4.2008.23-14)
: N810 Linux
: Medium normal with 4 votes (vote)
: 4.1.3
Assigned To: unassigned
: rss-feed-reader-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-06-28 19:42 UTC by Krischan Keitsch
Modified: 2008-12-22 21:01 UTC (History)
6 users (show)

See Also:


Attachments
My feedlist.opml from osso_rss_feed_reader (1.82 KB, application/xml)
2008-07-01 20:28 UTC, Andrew Flegg
Details
syslog file (5.26 KB, text/plain)
2008-07-05 06:01 UTC, Sanjeev Visvanatha
Details
System calls from trying to refresh RSS feeds (57.18 KB, text/plain)
2008-07-15 15:44 UTC, Andrew Flegg
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Krischan Keitsch (reporter) 2008-06-28 19:42:39 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)
4.2008.23-14

STEPS TO REPRODUCE THE PROBLEM:
Start rss-feed-reader and click refresh button
EXPECTED OUTCOME:
Popup apears to alow user to choose whether he wants to refresh all (1) feeds
or just the selected(2).
if (1): all feed are refreshed - progress is shown in statusbar
if (2): selected feed is refreshed - progress is shown in statusbar

ACTUAL OUTCOME:
On first click after app launch nothing happens
Sometimes the popup dialog apears but no refresh is initiated

REPRODUCIBILITY:
(always/sometimes/once)
yes, I tried it many times. 

EXTRA SOFTWARE INSTALLED:
some, but nothing special ;-)

OTHER COMMENTS:
After flashing the latest image (Diablo 4.2008.23-14) I applied my stored
backups. Maybe the backup interfears with the new settings?

I found a little "workaround": In order to refresh the feeds I have to launch
the homescreen applet of the rss-reed-reader and close the actual application.
If I hit the refresh button on the home applet twice it refreshes the feeds
(all of them).

I use the rss-app a lot and I realy hope for a quick hotfix - especially with
the new software updating mechanism :-)
If you have futher questions - let me know.

Krischan
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9)
Gecko/2008061015 Firefox/3.0
Comment 1 Ryan Abel maemo.org 2008-06-29 04:13:06 UTC
Unsetting submitter-set target milestone.

Krischan, the target milestone is to indicate when the bug has been/will be
fixed. :)
Comment 2 Andre Klapper maemo.org 2008-07-01 00:58:30 UTC
I cannot reproduce this, but I also did not have a backup when flashing to
Diablo. I'd love to see a confirmation by a second person here.
Comment 3 Andrew Flegg maemo.org 2008-07-01 20:27:37 UTC
Yep, I'm definitely seeing this as well.

Copying feedlist.opml from ~/.osso_rss_feed_reader, blasting the directory,
rebooting and copying it back did not help either. (Starting "RSS Reader"
showed the default feeds before copying it back).

Attaching my feedlist.opml, dunno if this'll help recreate.
Comment 4 Andrew Flegg maemo.org 2008-07-01 20:28:10 UTC
Created an attachment (id=801) [details]
My feedlist.opml from osso_rss_feed_reader
Comment 5 Sanjeev Visvanatha 2008-07-02 03:22:31 UTC
I am experiencing the same problem.   I restored a backup after flashing to
Diablo.
Comment 6 Andre Klapper maemo.org 2008-07-02 12:52:38 UTC
Andrew, Sanjeev:
Does Krischan's workaround work for you?
"In order to refresh the feeds I have to launch the homescreen applet of the
rss-reed-reader and close the actual application. If I hit the refresh button
on the home applet twice it refreshes the feeds (all of them)."
Comment 7 Andre Klapper maemo.org 2008-07-02 12:56:19 UTC
I assume this is not related to any special type of connection?
Can anybody provide a syslog? It could be helpful here.
See http://maemo.org/development/tools/doc/diablo/syslog/ for more information.
Comment 8 Sanjeev Visvanatha 2008-07-02 15:26:59 UTC
That workaround did not work for me.  I had to reboot, and now my refresh works
for now...
Comment 9 Sanjeev Visvanatha 2008-07-05 06:01:29 UTC
Created an attachment (id=812) [details]
syslog file

the syslog file contains the output after attempting to refresh the RSS feed
application.  The RSS feed app did not refresh after hitting the refresh
button.
Comment 10 Sanjeev Visvanatha 2008-07-05 06:04:27 UTC
(In reply to comment #9)
> Created an attachment (id=812) [details] [details]
> syslog file
> 
> the syslog file contains the output after attempting to refresh the RSS feed
> application.  The RSS feed app did not refresh after hitting the refresh
> button.  
> 

My RSS feed reader was not refreshing this evening, so I followed the
instructions on starting sysklogd, and have attached the output as attachment
812 [details] to this bug.  The sysklogd daemon was started and then the RSS feed
application was requested to refresh its feeds.  The feeds were not refreshed. 
Please let me know if I can further help.
Comment 11 Andre Klapper maemo.org 2008-07-14 17:59:57 UTC
Krischan, Andrew: I'd be interested to see more syslog files to track this
down. Help appreciated. :)
Comment 12 Andrew Flegg maemo.org 2008-07-15 15:29:15 UTC
Increasing priority from "Low" as most people using the RSS reader will
generally be restoring settings, surely? And the only suggested workaround is
to reflash - somewhat sub-optimal for a release touted as the end to flashing
;-)

Interestingly, *sometimes* mine seems to refresh the first feed after opening
the full-blown app, so I wonder if this is related to some attempt to "improve"
the behaviour of #953; which was fixed to satisfaction in chinook.
Comment 13 Andrew Flegg maemo.org 2008-07-15 15:43:57 UTC
Sorry, hadn't seen the comments attached to this bug (wonder why they weren't
emailed to me)...

The workaround, as I understand it, does not work:
1) Open RSS home applet [I already had it open]
2) Ensure RSS application is closed.
3) Tap "Refresh" button twice. Doing this changes it to the "X" to show it's
refreshing, but then cancels the refresh.

If I tap "Refresh" and wait for it to change back from the "X" to "Refresh"
again, I'm waiting for a long time - in the order of minutes (and hasn't
finished yet) - much longer than it should take to get HTTP responses from the
6 feeds I've got:

* BBC News (World)
* Internet Tablet News
* Facebook friends' updates
* del.icio.us feed of a small tag in my section with 3 entries
* planet maemo.org
* Techmeme

I've attached the result of an strace:

  1) strace -f -o osso_rss_feed_reader.strace run-standalone.sh
osso_rss_feed_reader
  2) Click "Refresh" icon. It flickers briefly and stays as "Refresh".
  3) Close application.
Comment 14 Andrew Flegg maemo.org 2008-07-15 15:44:38 UTC
Created an attachment (id=825) [details]
System calls from trying to refresh RSS feeds
Comment 15 George Kibardin 2008-07-22 11:52:34 UTC
I have the same problem, but tapping refresh button does nothing, even dialog
doesn't appear.
My work around is to set automatic update when WLAN is available and turn WLAN
on when reader application is running.

BTW. When this setting is on manual update via GPRS connection works fine!
Comment 16 Andrew Flegg maemo.org 2008-07-22 12:27:10 UTC
> My work around is to set automatic update when WLAN is available
> and turn WLAN on when reader application is running.

I can confirm this does change the behaviour:

1) Disconnect from current Internet connection (WLAN)
2) Open RSS Feed Reader application
3) Click "Refresh" icon at bottom-left of toolbar.
4) WLAN auto-reconnects to saved WLAN connection.
5) All feeds refresh.

Tapping "Refresh" again does not seem to do anything, but will try again later.
Comment 17 John Parejko 2008-09-08 22:12:15 UTC
I've also had this problem, but I confirm that Andrew's fix above
(disconnecting from the WLAN and letting the RSS reader make the connection
when refreshing) does work.
Comment 18 Dan 2008-09-08 22:41:54 UTC
Andrew's instructions above are a workaround not a fix as you seem to have to
do that every time (at least I do).

I also have a problem adding feeds to the RSS reader (couldn't find a separate
bug for it and the same workaround works so I think they are connected)...
- Connected via Wi-Fi
- I click on the RSS feed in the browser
- RSS reader launches and autofills the Add Feed link so I click OK
- The buttons grey out but it just hangs there forever
- I click cancel
- I disconnect from the Wi-Fi network
- Switching back to the still open browser window (no need to close RSS reader)
I click the RSS button again.
- Tablet switches to RSS reader and autofills the Add Feed link so I click OK
- Tablet auto-connects to network and adds the feed absolutely fine!
Comment 19 Andrew Flegg maemo.org 2008-09-23 14:20:48 UTC
I'm fairly convinced #3335 and #3542 are connected:

 1) RSS feed auto-updating worked at the summit (#3335)
 2) As did email automatic send/receive in modest (#3542)
 3) They've both stopped working since I left.

The only things I can think of which are different:

 * I turned off both RSS & modest auto update.
 * I deleted all entries in /var/lib/alarmd/alarm_queue.xml apart from
   the update notifier ones.
 * Rebooted a number of times.
 * Turned on automatic update of RSS & modest.
 * Connected, and saved, the "maemo" WLAN at the summit: this is a new
   entry in my connections db, with no security & no spaces in the name
   of either the ESSID or the connection name.

Since returning to the UK, neither have worked automatically,
connected to both my home WLAN and work WLAN - one of which has WEP,
the other WPA security; both have spaces in their connection names,
one of which has some spaces in its ESSID; both of which were restored
from a backup of chinook settings. (The summit connection was
obviously not restored).
Comment 20 Eero Tamminen nokia 2008-09-23 16:16:49 UTC
(In reply to comment #19)
> I'm fairly convinced #3335 and #3542 are connected:
> 
>  1) RSS feed auto-updating worked at the summit (#3335)
>  2) As did email automatic send/receive in modest (#3542)
>  3) They've both stopped working since I left.

Hm. Could they be related to bug 3378 (which was supposed to
be fixed with w30 update except for the unconfirmed issue
of it having something to do with backups)?
Comment 21 Andrew Flegg maemo.org 2008-09-23 16:40:01 UTC
(In reply to comment #20)
> 
> Hm. Could they be related to bug 3378 (which was supposed to
> be fixed with w30 update except for the unconfirmed issue
> of it having something to do with backups)?

I've not noticed any other problems with the connection dialogue or similar,
but it is an interesting idea.

I'm going to have to reflash my tablet soon anyway. Unfortunately, the restore
settings dialogue isn't quite granular enough to allow the restore of one WLAN,
or modest settings without doing them all. Hacking inside the backup tarball's
an option, I suppose.
Comment 22 Andrew Flegg maemo.org 2008-09-25 11:07:25 UTC
Right, after doing the process described here
https://bugs.maemo.org/show_bug.cgi?id=3542#c15 - I've identified that deleting
my saved connection (which was restored from a chinook backup) and recreating
it solves both the modest auto/receive problem and my RSS feed auto
update/refresh.

Why these two apps' auto-refresh is affected by a change in connectivity
settings' storage is unclear to me: omweather and update-notifier both work
correctly with scheduled updates and there is no other problem in terms of
auto-connecting to the restored connections and using it to connect to the
Internet.
Comment 23 Andre Klapper maemo.org 2008-10-24 15:16:53 UTC
(In reply to comment #22)
> Right, after doing the process described here
> https://bugs.maemo.org/show_bug.cgi?id=3542#c15 - I've identified that deleting
> my saved connection (which was restored from a chinook backup) and recreating
> it solves both the modest auto/receive problem and my RSS feed auto
> update/refresh.

Bug 3542 was fixed and is part of the internal build version x.2008.42-x (42 is
the week number).
Can you please test this again when a public update has been released with or
after this build version?
Comment 24 Andre Klapper maemo.org 2008-12-17 20:13:15 UTC
Today 5.2008.43-7 SSU update has been released.
Please test this again and report back. Thanks.
Comment 25 Dan 2008-12-18 16:20:50 UTC
Yay!   v5.2008.43-7 seems to fix this perfectly!

Thank you :-)
Comment 26 Andre Klapper maemo.org 2008-12-22 21:01:52 UTC
(In reply to comment #25)
> Yay!   v5.2008.43-7 seems to fix this perfectly!

Closing as duplicate of bug 3542 now that it is clear that this is due to some
underlying connectivity issue that has been fixed by 5.2008.43-7.

*** This bug has been marked as a duplicate of bug 3542 ***