Bug 3319 - (int-71569) In X Terminal, Ctrl-e should not open the search dialog
(int-71569)
: In X Terminal, Ctrl-e should not open the search dialog
Status: RESOLVED FIXED
Product: UI Specification
General
: 4.0
: N810 Maemo
: Low normal with 1 vote (vote)
: 5.0 (1.2009.41-10)
Assigned To: Mikko Nurmi
: ui-specification-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-06-27 01:30 UTC by Vincent Lefevre
Modified: 2009-09-25 15:24 UTC (History)
6 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Vincent Lefevre (reporter) 2008-06-27 01:30:46 UTC
SOFTWARE VERSION:
2.2007.50-2 and 4.2008.23-14

STEPS TO REPRODUCE THE PROBLEM:
1. Open X Terminal.
2. Type "cat[Enter]".
3. Type Ctrl-e.

EXPECTED OUTCOME:
A Ctrl-e character should go to the terminal.

ACTUAL OUTCOME:
The search dialog is opened.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
Ctrl-e is very useful in some apps such as Emacs and shells that follow some
Emacs key bindings (e.g. bash, zsh).
For generalities about keyboard shortcuts in X Terminal, see bug 2033.
Comment 1 Ryan Abel maemo.org 2008-06-27 03:42:41 UTC
Confirmed by N810 owners in #maemo.

Doesn't seem to affect the N800, though, as I was unable to reproduce with my
N800 running 4.2008.23-14 with the vkb.
Comment 2 Andre Klapper maemo.org 2008-06-27 14:02:01 UTC
I can also confirm this.

There has been a debate in the internal ticket, in the end people insisted on
keeping Ctrl+E as th shortcut for Global search and the internal ticket has
been closed as INVALID.
Once again a UI Spec bug because Ctrl+E has been defined to behanve like it
currently does.
Comment 3 Karsten Bräckelmann 2008-07-17 23:45:27 UTC
*** Bug 2472 has been marked as a duplicate of this bug. ***
Comment 4 Karsten Bräckelmann 2008-07-17 23:48:21 UTC
Quoting Marius Gedminas, duplicate bug 2472 comment 2:

> Workaround: Clear the /apps/osso/keybindings/global/osso-global-search key with
> gconftool or gconf-editor.
>
> This shortcut should be configurable from the control panel where all the other
> global shortcuts are listed.
Comment 5 Karsten Bräckelmann 2008-07-17 23:52:31 UTC
*sigh*  Not inheriting Cc'ed users other than the reporter when dupe'ing.
Doing so manually.  Sorry for the noise.
Comment 6 Vincent Lefevre (reporter) 2008-07-18 03:13:12 UTC
(In reply to comment #4)
> Quoting Marius Gedminas, duplicate bug 2472 comment 2:
> 
> > Workaround: Clear the /apps/osso/keybindings/global/osso-global-search key with
> > gconftool or gconf-editor.

This doesn't seem to be possible:

Nokia-N810-23-14:~> gconftool -u
/apps/osso/keybindings/global/osso-global-search
Nokia-N810-23-14:~> gconftool -g
/apps/osso/keybindings/global/osso-global-search
<ctrl>e
Comment 7 Marius Gedminas 2008-07-18 16:40:51 UTC
Vincent: gconftool -u effectively means "reset to default".  Try

gconftool -s /apps/osso/keybindings/global/osso-global-search --type=string ''
Comment 8 Andre Klapper maemo.org 2009-04-23 16:55:51 UTC
Testing this again in Fremantle highly appreciated. WONTFIX for Diablo.
Comment 9 Andre Klapper maemo.org 2009-06-04 18:56:49 UTC
Currently in Fremantle "^E" will be printed in the terminal, but I'm not sure
whether this is a bug or really planned.
Comment 10 Lucas Maneos 2009-06-05 05:06:07 UTC
(In reply to comment #9)
> Currently in Fremantle "^E" will be printed in the terminal,

Just checking, was this in scratchbox or on-device?  It works fine in the
Diablo SDK too, but /apps/osso/keybindings/global/osso-global-search isn't set
there by default, and it breaks if that key is set manually (gconftool-2 -s
/apps/osso/keybindings/global/osso-global-search -t string "<ctrl>e").

In a fremantle-beta osso-xterm ctrl-E works as expected and setting the key to
"<ctrl>e" doesn't change anything.  By default there's nothing in gconf under
/apps/osso/keybindings.
Comment 11 Andre Klapper maemo.org 2009-07-16 16:56:09 UTC
(In reply to comment #10)
> (In reply to comment #9)
> > Currently in Fremantle "^E" will be printed in the terminal,
> 
> Just checking, was this in scratchbox or on-device?

On-device.
While now pressing Control+E does not do anything in the terminal... Sigh.
Comment 12 Andre Klapper maemo.org 2009-09-25 15:24:06 UTC
This issue has been FIXED in the internal Fremantle version.

Unfortunately this is a WONTFIX for Diablo as Diablo is in maintenance mode and
Nokia will only provide bugfixes for critical issues if at all.
For your interest the Mer project aims to provide a community backport of
Fremantle for N8x0 devices. See http://wiki.maemo.org/Mer for more information.