Bug 329 - (int-25020) WIFI connection drops intermittently
(int-25020)
: WIFI connection drops intermittently
Status: CLOSED WONTFIX
Product: Connectivity
WiFi
: 1.1
: 770 Maemo
: Medium normal (vote)
: ---
Assigned To: Maemo QA (deprecated)
: wifi-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2005-12-08 20:44 UTC by Walter Jansen
Modified: 2007-09-03 06:52 UTC (History)
11 users (show)

See Also:


Attachments
dmesg output when 770 drops connection (16.84 KB, text/plain)
2006-02-20 21:29 UTC, Igor
Details
dmesg (7.41 KB, text/plain)
2006-09-25 23:56 UTC, Bernard
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Walter Jansen (reporter) 2005-12-08 20:44:58 UTC
I'm running a 770 with 2005.45-8 in 1m distance from a Netgear ME102 AP
(802.11b, WEP 128bit, no ESSID broadcast).

After a varying amount of time, the wifi connection drops, popping up a msg box
"connection interrupted" (or similar in German). Because of the short distance,
I don't assume a field strength problem. Also, the connection mgr shows 4 green
bars when connected, and a laptop works flawlessly all around the house.

After the dropout, the connection can be re-established immediately.

Here is an edited dmesg output covering the problem:

[13219.070587] Loading 3825.arm firmware
[13219.785369] CX3110x: MAC address xx:xx:xx:xx:xx:xx
[13219.959106] No power saving
[13220.455718] Scan complete, scanned 13 channels
[13220.483642] No power saving
[13220.484130] No power saving
[13221.845855] We wake up for DTIMs
[13333.793182] We haven't received an SPI packet for 1 second...
[13333.809448] Couldn't get the READY bit
[13334.808776] We haven't received an SPI packet for 1 second...
[13334.825073] Couldn't get the READY bit
[13335.824401] We haven't received an SPI packet for 1 second...
[13335.840667] Couldn't get the READY bit
[13336.761932] BSS timeout
[13336.762298] DEAUTHENTICATE trap
[13336.779083] We haven't got a READY interrupt from WAKEUP
[13336.796417] We haven't got a READY interrupt from DMA READY
[13336.813079] We haven't got a READY interrupt from WAKEUP
[13336.829589] We haven't got a READY interrupt from DMA READY
[13336.839965] We haven't received an SPI packet for 1 second...
[13336.855834] Couldn't get the READY bit
[13336.861480] We haven't got a READY interrupt from WAKEUP
[13336.877532] We haven't got a READY interrupt from DMA READY
...4 times...
[13337.021301] We haven't got a READY interrupt from WAKEUP
[13337.037353] We haven't got a READY interrupt from DMA READY
[13337.855651] We haven't received an SPI packet for 1 second...
[13337.871704] Couldn't get the READY bit
[13337.887664] We haven't got a READY interrupt from WAKEUP
[13337.903686] We haven't got a READY interrupt from DMA READY
...5 times...
[13338.646728] We haven't got a READY interrupt from WAKEUP
[13338.662780] We haven't got a READY interrupt from DMA READY
[13338.845581] sm_drv_transmit: sm_frame_tx returned error -9
[13338.871307] SPI timer timeout, getting out of here
[13338.875396] Shut down SoftMAC
[13339.325592] SoftMAC not initialized, chip not booted (Set oid 0x12000001)
[13339.325683] SoftMAC not initialized, chip not booted (Set oid 0x12000002)
[13339.325775] SoftMAC not initialized, chip not booted (Set oid 0x150007e0)
Comment 1 Samuel Ortiz nokia 2005-12-09 11:40:26 UTC
Hi Walter,

(In reply to comment #0)
> [13219.070587] Loading 3825.arm firmware
> [13219.785369] CX3110x: MAC address xx:xx:xx:xx:xx:xx
> [13219.959106] No power saving
> [13220.455718] Scan complete, scanned 13 channels
> [13220.483642] No power saving
> [13220.484130] No power saving
> [13221.845855] We wake up for DTIMs
> [13333.793182] We haven't received an SPI packet for 1 second...
> [13333.809448] Couldn't get the READY bit
> [13334.808776] We haven't received an SPI packet for 1 second...
> [13334.825073] Couldn't get the READY bit
> [13335.824401] We haven't received an SPI packet for 1 second...
> [13335.840667] Couldn't get the READY bit
> [13336.761932] BSS timeout
> [13336.762298] DEAUTHENTICATE trap
> [13336.779083] We haven't got a READY interrupt from WAKEUP
> [13336.796417] We haven't got a READY interrupt from DMA READY
> [13336.813079] We haven't got a READY interrupt from WAKEUP
> [13336.829589] We haven't got a READY interrupt from DMA READY
> [13336.839965] We haven't received an SPI packet for 1 second...
> [13336.855834] Couldn't get the READY bit
> [13336.861480] We haven't got a READY interrupt from WAKEUP
> [13336.877532] We haven't got a READY interrupt from DMA READY
> ...4 times...
> [13337.021301] We haven't got a READY interrupt from WAKEUP
> [13337.037353] We haven't got a READY interrupt from DMA READY
> [13337.855651] We haven't received an SPI packet for 1 second...
> [13337.871704] Couldn't get the READY bit
> [13337.887664] We haven't got a READY interrupt from WAKEUP
> [13337.903686] We haven't got a READY interrupt from DMA READY
> ...5 times...
> [13338.646728] We haven't got a READY interrupt from WAKEUP
> [13338.662780] We haven't got a READY interrupt from DMA READY
> [13338.845581] sm_drv_transmit: sm_frame_tx returned error -9
> [13338.871307] SPI timer timeout, getting out of here
> [13338.875396] Shut down SoftMAC
> [13339.325592] SoftMAC not initialized, chip not booted (Set oid 0x12000001)
> [13339.325683] SoftMAC not initialized, chip not booted (Set oid 0x12000002)
> [13339.325775] SoftMAC not initialized, chip not booted (Set oid 0x150007e0)

I have 2 questions for you:

1) Does your connection always end up like that ?
2) Since you seem to have an xterm, could you please do the following for me:
after closing any existing WLAN connection, run "ifconfig wlan0 up", and let it
run for a while (max 1 hour). I would like to see if you hit the same problem
with simply WLAN on.

Thanks in advance, 
Samuel.
Comment 2 Walter Jansen (reporter) 2005-12-09 16:18:00 UTC
Hi Samuel,
I have (hopefully) answered your questions further down.

(In reply to comment #1)
> Hi Walter,
> 
> (In reply to comment #0)
> > [13219.070587] Loading 3825.arm firmware
> > [13219.785369] CX3110x: MAC address xx:xx:xx:xx:xx:xx
> > [13219.959106] No power saving
> > [13220.455718] Scan complete, scanned 13 channels
> > [13220.483642] No power saving
> > [13220.484130] No power saving
> > [13221.845855] We wake up for DTIMs
> > [13333.793182] We haven't received an SPI packet for 1 second...
> > [13333.809448] Couldn't get the READY bit
> > [13334.808776] We haven't received an SPI packet for 1 second...
> > [13334.825073] Couldn't get the READY bit
> > [13335.824401] We haven't received an SPI packet for 1 second...
> > [13335.840667] Couldn't get the READY bit
> > [13336.761932] BSS timeout
> > [13336.762298] DEAUTHENTICATE trap
> > [13336.779083] We haven't got a READY interrupt from WAKEUP
> > [13336.796417] We haven't got a READY interrupt from DMA READY
> > [13336.813079] We haven't got a READY interrupt from WAKEUP
> > [13336.829589] We haven't got a READY interrupt from DMA READY
> > [13336.839965] We haven't received an SPI packet for 1 second...
> > [13336.855834] Couldn't get the READY bit
> > [13336.861480] We haven't got a READY interrupt from WAKEUP
> > [13336.877532] We haven't got a READY interrupt from DMA READY
> > ...4 times...
> > [13337.021301] We haven't got a READY interrupt from WAKEUP
> > [13337.037353] We haven't got a READY interrupt from DMA READY
> > [13337.855651] We haven't received an SPI packet for 1 second...
> > [13337.871704] Couldn't get the READY bit
> > [13337.887664] We haven't got a READY interrupt from WAKEUP
> > [13337.903686] We haven't got a READY interrupt from DMA READY
> > ...5 times...
> > [13338.646728] We haven't got a READY interrupt from WAKEUP
> > [13338.662780] We haven't got a READY interrupt from DMA READY
> > [13338.845581] sm_drv_transmit: sm_frame_tx returned error -9
> > [13338.871307] SPI timer timeout, getting out of here
> > [13338.875396] Shut down SoftMAC
> > [13339.325592] SoftMAC not initialized, chip not booted (Set oid 0x12000001)
> > [13339.325683] SoftMAC not initialized, chip not booted (Set oid 0x12000002)
> > [13339.325775] SoftMAC not initialized, chip not booted (Set oid 0x150007e0)
> 
> I have 2 questions for you:
> 
> 1) Does your connection always end up like that ?
Yes. When the connection drops out of an existing session, it always has the
same appearance in dmesg.

> 2) Since you seem to have an xterm, could you please do the following for me:
> after closing any existing WLAN connection, run "ifconfig wlan0 up", and let it
> run for a while (max 1 hour). I would like to see if you hit the same problem
> with simply WLAN on.
Done for ~55min. No problem occurs. Here's the dmesg entry:
[  317.442901] Loading 3825.arm firmware
[  318.143310] CX3110x: MAC address xx:xx:xx:xx:xx:xx
[  540.426025] hwa742: setting update mode to disabled
[  540.426086] hwa742_notifier_cb(): event = DISABLED
[ 1422.249694] hwa742: setting update mode to manual
[ 1422.249725] hwa742_notifier_cb(): event = READY
[ 1556.838867] hwa742: setting update mode to disabled
[ 1556.838928] hwa742_notifier_cb(): event = DISABLED
[ 3799.977203] hwa742: setting update mode to manual
[ 3799.977233] hwa742_notifier_cb(): event = READY

An additional observation...
When I have no connection (globe without "W") and start up the browser with a
bookmark, it connects automatically. If I then close the browser, the connection
is closed, too. Is this "works as designed"?

> Thanks in advance, 
> Samuel.
You're welcome. Hope I could help.
Walter
Comment 3 Samuel Ortiz nokia 2005-12-10 16:29:59 UTC
(In reply to comment #2)
> Done for ~55min. No problem occurs.
Ok, could you please run another test: Just connect to an AP through the
connection manager (not through the browser), and leave the connection idle for
an hour or so (do not use the connection at all, no browsing, no radio
streaming, just leave it idling).

> An additional observation...
> When I have no connection (globe without "W") and start up the browser with a
> bookmark, it connects automatically. If I then close the browser, the connection
> is closed, too. Is this "works as designed"?
Yes, it is.

> You're welcome. Hope I could help.
Thanks a lot for your time.
Comment 4 Patrik Flykt nokia 2005-12-12 10:13:25 UTC
(In reply to comment #3)
> Ok, could you please run another test: Just connect to an AP through the
> connection manager (not through the browser), and leave the connection idle
> for an hour or so (do not use the connection at all, no browsing, no radio
> streaming, just leave it idling).

IIRC the defaul idle timeout for a WLAN connection is one hour, so in this test
the connection will terminate after 60 minutes. This behaviour does not affect
the reported bug as long as there has been normal application IP traffic
restarting the idle timeout counter.
Comment 5 Walter Jansen (reporter) 2005-12-13 11:29:22 UTC
Hi Samuel,

> Ok, could you please run another test: Just connect to an AP through the
> connection manager (not through the browser), and leave the connection idle for
> an hour or so (do not use the connection at all, no browsing, no radio
> streaming, just leave it idling).

Done. I connected via connection manager and let it idle for 01:50:25 (displayed
in connection mgr panel). No problem occurs.
(To Patrick: While trying to get hold of this problem, I had previously modified
the WLAN idle time to unlimited in the connection settings, so no timeout here.)

Immediately after doing the above, I started the browser and began surfing.
After approx 10min, the problem occurred.

I've tried to recall my observations from the last few days, but I'm not able to
find a pattern. Sometimes, I can surf undisturbed for 40 or 50min, then get hit
by the problem every 2nd or 3rd page. At other occasions, a surf session starts
to show the problem immediately, then it suddenly disappears, again for 30, 40
or more minutes, only to come back again more frequently afterwards. Under this
aspect, it may be useless to mention that I had some radio streaming sessions of
30 to 45min, which passed completely undisturbed.

Regards,
Walter
Comment 6 Jerome 2005-12-13 18:30:01 UTC
I have had the same bug in the past days. Actually, last week-end, my 770 had
gotten more and more 
unstable, to the point it could not keep the connection long enough to load
more than a page...

I tried to reset the 770's settings, using "control panel" and re-entered my
wpa key manually. This has 
markedly improved things at first. I was able to keep connected for 10-20
minutes. I still got 
intermittent connection drops, though.

Then I restored my network settings from the MMC. The connection is still
relatively stable, although 
the browser crashes on some pages.

A few notes in the case this problem is somewhat caused by corrupted settings:
-when I first set the 770 up, everything went fine, as far as I can recall.
-my wpa key is quite long (35 characters)
-when I first got my 770, I have added and removed 5 to 10 networks to the
connectivity panel (I 
wanted to try things).
Comment 7 paul neefjes 2005-12-22 17:58:11 UTC
I just reported a similar problem. Registered under bug number 341. The 
conversation on this page seems to end on the 13th of december. Any further 
comments??
Comment 8 Jerome 2005-12-26 23:28:50 UTC
To Paul:
No further comments. I have been waiting for a pointer in the right direction or anything for 2 weeks and 
nothing. And frankly, I am not using my 770 any more. Either I have to think about starting an internet 
radio before browsing or I get the "woof" sound and the message "connection lost" every 5 seconds. It 
makes the 770 almost unusable for any browsing.

I tried resetting the 770 and re-entering the connection info from scratch, just to find that it will lose the 
connection on the default bookmarks, from a newly reflashed machine. Pathetic.
Comment 9 paul neefjes 2005-12-27 12:08:14 UTC
Hello Jerome,

Thanks for your reply. My Nokia 770 is lying in the bottom drawer of my desk. 
I must have missed the announcement that I was buying a beta version of a 
concept device for which they needed beta testers that are also willing to 
invest 350 euro's in the product. My pocket pc may not be perfect, but it 
works!
Comment 10 Luciano Sanchez 2005-12-28 13:15:43 UTC
firmware 2005.45-8, Linksys router, WPA. Same behavior (random
disconnects every couple of minutes), same logs with dmesg.

The connection is not dropped while I am pinging the router in
the background and keep the connection busy (i.e., I do a 
"ping 192.168.1.1" in a term and then I can use the browser and
the email without problems.) But, as soon as I kill the ping, 
I lose the connection and get the same messages mentioned before:

We haven't received and SPI packet for 1 second...
[etc]
Shut down SoftMAC
Loading 3825.arm firmware
CX3110x: MAC adress XX:XX: etc
Shut down SoftMAC
tlv320aic23 powering down
tlv320aic23 powering up
tlv320aic23_init_power() done
Comment 11 Jerome 2005-12-31 16:31:55 UTC
Tried firmware 3.2005.51-13 today. The bug is still present, in a slightly
modified form. Now the 770 will 
NOT say "connection lost" (with a woof sound), but the connection is lost
nevertheless. It needs to 
reconnect on every 5th or so web page and dmesg shows the same messages...
Comment 12 Stephane Derville 2006-01-05 00:54:38 UTC
My 770 is flashed with 3.2005.51-13.

I have the same behaviour, the connection drops after a varying amount
of time (between 15 sec and 4 minutes) with or without web activity.
I manage to reach more than 60 minutes (I think) with web radio on.

Netgear WGT624 router Firmware version V4.2.4_1.0.1 (802.11g, WPA-PSK, region
Europe, channel 6, no SSID broadcast, no MAC filtering).
No such a problem with my laptop with WG511 802.11g cardbus card
Same behaviour with other public AP (no security, unknown manufacturer)
This does not happen on a gprs connection.
Comment 13 Jerome 2006-01-10 00:46:28 UTC
I tried it in an internet cafe today, that is without any encryption, and the
bug is not only present, but 
more annoying. At home, the 770 reconnects automatically to its default
network. In the cafe, every other 
minute I get the message that it tried to reconnect, could not find its default
network and if I please could 
select the good one. So I had to dig in the settings and put the network of the
internet cafe as "default" to 
render the connection usable.
Back at home, same story in reverse, of course.
Did I say the bug is annoying?
Comment 14 JMills 2006-01-11 02:39:09 UTC
I tried a few mitigation strategies which have helped (but not actually fixed 
the root-cause):

1) Disable the immediate auto-reconfiguration to '0.0.0.0' of the wlan0 
interface on link-loss. This should really be a soft-failure (i.e., timer-
based), since you're unlikely to be browsing while leaving an AP coverage area 
permanently.


2) Disable _negative_ cache mode in the local dns proxy. This is what was 
making Opera very unhappy.


I've seen the Wi-Fi link-loss behavior on DLink, NetGear, and LinkSys access 
points so far.
Comment 15 Robin Van Loock 2006-01-15 11:11:38 UTC
I can confirm the same problem of dropping WiFi connections. The latest firmware
only removed the 'Connection Lost' dialog, but it keeps dropping all the time. 

Keeping the radio on holds the connection, but anything like normal browsing and
such kills it in a few minutes.
Comment 16 david holmes 2006-01-23 18:01:11 UTC
Confirming this (in particular comments #11 and 15) - running 3.2005.51-13
Comment 17 david holmes 2006-01-23 20:59:08 UTC
(In reply to comment #16)
> Confirming this (in particular comments #11 and 15) - running 3.2005.51-13

 Meant to add that I also find that a slow ping keeps the link running indefinitely - 
e.g.:
          ping -s 1 -i 4 192.168.1.1

and that this was with a BuffaloTech WBR-G54 running 2.20 firmware in "11g(54M)/11b(11M)-Auto".
Comment 18 Luciano Sanchez 2006-01-24 13:10:13 UTC
This comment is directed to people at Nokia:

1) Is this bug common to all Nokia 770's? Does
anybody own a tablet that does not drop the 
WIFI connection?

2) Does this bug happen with all brands of
Access Points? Can anyone report a type of
AP that works?

Perhaps this is not a software bug;
maybe we have been sold defective 
units and then we should ask for a 
replacement.
Comment 19 paul neefjes 2006-01-24 13:58:54 UTC
I would agree with the last commenter. Two colleages of mine also ahve a 770. 
They do not have the problem I have with the dropping connecting. Of course 
they use the same access point. A defect device sounds reasonable.
Comment 20 david holmes 2006-01-24 17:33:57 UTC
I am seeing no problems at all while connected to a Speedstream 6300 box
(supplied by and configured 
for Bell Canada, Sympatico Ultra (DSL) service).  (The Buffalo Tech box
mentioned in my previous 
comments is connected to a Time Warner cable modem in the U.S.)

The connection stays up indefinitely without ping or the radio stream running. 
 The general datasheet for
this Speedstream box says it runs both g and b and there is a dropdown config
menu which lists possible 
data rates up to 54 (set to "Auto" right now) but can't currently determine
what mode it is in.  (I'll see if 
another computer with wireless has more tools than the 770 to determine the
wireless mode.)

Is something like iwconfig working on the 770 (has someone already compiled
this?) or are there other 
ways to determine the current wireless config of the WLAN while connected?
Comment 21 Walter Jansen (reporter) 2006-01-24 18:21:27 UTC
To those reporting a stable WLAN connection _without_ ping or radio: Does the
access point do SSID broadcasting? 
I have a feeling that this might keep up the connection, too.
Rgds,
Walter
Comment 22 Patrik Flykt nokia 2006-01-25 08:47:52 UTC
(In reply to comment #21)
> To those reporting a stable WLAN connection _without_ ping or radio: Does the
> access point do SSID broadcasting?

My home WLAN doesn't do SSID broadcasting and my connection stays up. I don't
need to ping or use radio either. And no, I'm not running anything newer than
the available 3.2005.51-*.

If only I had this mysterious connection drop in my device... :-(
Comment 23 Detlef Schmicker 2006-01-25 13:10:00 UTC
Did you check with ifconfig (RX count and TX count), if there is any transfer
on
the wlan interface.
I have SSID braodcasting and dropping of the connection.

Detlef Schmicker

(In reply to comment #22)
> (In reply to comment #21)
> > To those reporting a stable WLAN connection _without_ ping or radio: Does the
> > access point do SSID broadcasting?
> 
> My home WLAN doesn't do SSID broadcasting and my connection stays up. I don't
> need to ping or use radio either. And no, I'm not running anything newer than
> the available 3.2005.51-*.
> 
> If only I had this mysterious connection drop in my device... :-(
Comment 24 Patrik Flykt nokia 2006-01-25 13:21:44 UTC
(In reply to comment #23)
> Did you check with ifconfig (RX count and TX count), if there is any transfer 
> on the wlan interface.

IIRC connection manager didn't show any sent or received traffic but I'll
recheck with ifconfig.
Comment 25 Jussi Kukkonen 2006-01-26 01:58:46 UTC
(In reply to comment #18)
> 
> 2) Does this bug happen with all brands of Access Points? Can anyone report a
>    type of AP that works?

I've had mixed results with my el-cheapo D-Link Wireless router (DI514):
* With no authentication and encryption: very good connection.
* With WPA-PSK: varying results, but mostly bad: "connection interrupted" every
  few minutes

SSID broadcast is on. Signal strength is good. My image is 2005.51-13.
When problems appear, I get similar messages into dmesg as Comment 0. Let me
know if you want a sample.

Could someone else with connection problems test what happens if they remove
encryption/authentication on the AP? At least in my case there seems to be a
correlation with problems and WPA...
Comment 26 paul neefjes 2006-01-26 10:21:12 UTC
Can someone from Nokia please confirm that this is a hardware problem. My two 
colleagues have the exact same configuration without any problems. If Nokia 
could just confirm that and replace the defect devices, it would safe a lot of 
people a lot of time.
Comment 27 Jussi Kukkonen 2006-01-26 23:27:32 UTC
(In reply to comment #25)
> Could someone else with connection problems test what happens if they remove
> encryption/authentication on the AP? At least in my case there seems to be a
> correlation with problems and WPA...

 I'm forced to take that back (sorry for the spam, should have tested more
before sending comment 25). I've spent the evening testing open-AP / WEP /
WPA-PSK, and found no difference in them, they were all appallingly bad. 
 My test case was downloading a 2,5 MB pdf, and during every download I had to
re-connect ~10 times.

 The strange thing here is that I _have_ had very good connections with the same
hardware (e.g. I remember downloading a 10MB pdf without re-connecting once). I
thought the variable was WPA, but obviously it wasn't. 
 Maybe it's the moon phase?
Comment 28 Patrik Flykt nokia 2006-01-27 10:16:12 UTC
Yesterday we finally received two units that drop wlan connections. We are
investigating the issue.
Comment 29 Adam Ernst 2006-02-11 23:16:11 UTC
(In reply to comment #28)
> Yesterday we finally received two units that drop wlan connections. We are
> investigating the issue.

Any news? My 770 exhibits this behavior as well.
Comment 30 Luciano Sanchez 2006-02-16 00:05:58 UTC
> Is something like iwconfig working on the 770 (has someone already compiled this?) or are there 
other 
> ways to determine the current wireless config of the WLAN while connected?

It seems that someone has made iwconfig available at last. 

BTW, I have observed that disabling the power management 
(iwconfig wlan0 power off) improves a lot the 
time between dropouts. My tablet has been more than 30 minutes
connected, and it was not up more than a minute before. 
The problem is not solved though. The connection still dies.
Anybody else tried this?
Comment 31 Igor 2006-02-20 21:29:11 UTC
Created an attachment (id=52) [details]
dmesg output when 770 drops connection

This is the dmesg output which covers 3 modes of the operation
- 770 not connected to WRT54GL
- 770 connected to WRT54GL
- 770 drops the connection for no apparent reason
Comment 32 Igor 2006-02-20 21:41:00 UTC
more info here
http://maemo.org/pipermail/maemo-users/2006-February/000682.html

In short:
- WRT45GL with the latest firmware 4.30.2
- 770 with latest firmware 51-13
Comment 33 Patrik Flykt nokia 2006-02-21 09:46:39 UTC
Seems that there is no quick sw solution to this problem. The WLAN driver may
be
investigated more thoroughly later on depending on the workload or our WLAN
kernel hacker(s) and the number of affected devices.
Comment 34 Ward Vandewege 2006-02-27 01:41:29 UTC
(In reply to comment #33)
> Seems that there is no quick sw solution to this problem. The WLAN driver may 
be
> investigated more thoroughly later on depending on the workload or our WLAN
> kernel hacker(s) and the number of affected devices.

Hrm, that's bad news. My 770 suffers from the problem too. My AP is an apple 
airport express. If I keep traffic flowing (internet radio, e.g.) the connection 
never drops. Otherwise, sometimes it drops multiple times a minute, sometimes it 
works fine for half an hour. Could this problem be related to interference?

I use a nokia bluetooth keyboard. Has progress been made on narrowing down the 
problem? Serial numbers of the 770s, accessories, installed software and 
versions, etc?
Comment 35 Kimmo Koivisto 2006-02-28 15:07:00 UTC
I have exactly the same problem with WLAN connections, however, it never drops
GPRS connections, so my workaround is to use GPRS over bluetooth in my mobile
phone instead of WLAN for now. (version 3.2005.51-13)
Comment 36 Stephane Derville 2006-02-28 20:51:31 UTC
(In reply to comment #33)
> Seems that there is no quick sw solution to this problem. The WLAN driver may be
> investigated more thoroughly later on depending on the workload or our WLAN
> kernel hacker(s) and the number of affected devices.

Sorry Patrick but I consider this issue as a major issue. The nokia 770 is an
internet tablet over WLAN. This feature doesn't work as it should on my device.
Like if I had a nokia phone that I can't phone with.  I can't wait for a better
workload of your team, my 90 days return period is runnig.

The workaround "traffic flowing" (internet radio, e.g.) is ok for now but what
about when using VoIP, I will hear the radio and my buddy at the same time. Not
great.

Nokia has to replace the defect devices if it is not a sw issue.
Comment 37 Igor 2006-03-01 07:47:36 UTC
addendum to the comment #31

I've tried(tested) another 770 (which I borrowed from the friend of mine) under
same conditions. 
Result: It behaves like my unit. No difference. 770 drops the connections
intermittently.

OS version 51-13
Comment 38 Patrik Flykt nokia 2006-03-01 10:04:05 UTC
(In reply to comment #36)
> my 90 days return period is runnig.

If your return period is running out, feel free to replace it as there does not
seem to be a quick sw solution at hand for the moment.
Comment 39 Detlef Schmicker 2006-03-01 13:55:10 UTC
Can anybody please sumarize the findings. 

Is it correct, that there are Nokia 770 versions with different hardware. Some
of them are showing this bug? Can you give the serial numbers of the devices
with this bug.

As there is no sw solution, how do we get the devices exchanged, if we do not
have a 90 day return periode? You handle this bug a little like a secret I think.
Comment 40 Chris Creasey 2006-03-09 01:11:59 UTC
I've just found this page and am annoyed to find many other people having the
same problem.
Nokia, can you summarize. I'll be returning my 770 as faulty otherwise.

(In reply to comment #39)
> Can anybody please sumarize the findings. 
> 
> Is it correct, that there are Nokia 770 versions with different hardware. Some
> of them are showing this bug? Can you give the serial numbers of the devices
> with this bug.
> 
> As there is no sw solution, how do we get the devices exchanged, if we do not
> have a 90 day return periode? You handle this bug a little like a secret I think.
Comment 41 Chris Creasey 2006-03-11 18:55:44 UTC
I observe exactly the same behaviour, the bluetooth GPRS connection will stay
up
indefinately, the WLAN drops out after a minute or so normally.(version
3.2005.51-13)


(In reply to comment #35)
> I have exactly the same problem with WLAN connections, however, it never drops
> GPRS connections, so my workaround is to use GPRS over bluetooth in my mobile
> phone instead of WLAN for now. (version 3.2005.51-13)
Comment 42 Chris Creasey 2006-03-13 00:42:33 UTC
Thanks Luciano,

I've just tried you solution below and it works for me. I've gone from the
average connection time of about 1 minute to a connection time of 2hours 24mins
and still counting.....
I'm new to linux and it took me a few hours to get and set up xterm, root access
and iwconfig (this took the longest since it could not find its libraries)
anyway it looks like this stops the problem on my device.
I'm running (version 3.2005.51-13) and a belkin 54g AP.

My next challenge is to get the connection software to automatically disable
power management, not sure how this can be done. I (and especially my wife)
don't want to have to connect and then open xterm, change to the right
directory, run 'iwconfig wlan0 power off' each time I start a connection.

SO NOKIA, please sort this out with a patch before the 2006 release of the
software, which I guess is delayed.

I've paid
Comment 43 Jussi Kukkonen 2006-03-22 20:28:29 UTC
Patrik Flykt:
> If your return period is running out, feel free to replace it as there does 
> not seem to be a quick sw solution at hand for the moment.

Sorry for bugspam, I just wanted to warn others: There doesn't seem to be a
"quick" hardware solution either...

I took the device to Nokia maintenance in Helsinki, waited for three weeks and
got the device back (with a receipt that just said "Repaired in Germany").
Connection dropping is still there, as frustrating as ever.
Comment 44 Pomerol 2006-03-22 22:15:53 UTC
(In reply to comment #33)
> Seems that there is no quick sw solution to this problem. The WLAN driver may be
> investigated more thoroughly later on depending on the workload or our WLAN
> kernel hacker(s) and the number of affected devices.

My apologies for the intrusion, but I do have some information about the number
of affected devices.  I tested two devices purchased at the US retailer CompUSA
within the span of a two week period in February, and both have this problem. 
In general the connection keeps dropping about every 2-5 pages (the problem goes
away if I ssh to the devices with the TCPKeepAlive option).  I admit that my
sample size is small and selective, but the statistic indicates that in some
local areas the number of affected devices can be very high (i.e. 100%).

Re: Comment #44.  Thanks for the heads up.  I was about to do the same but then
changed my mind after tech support at Nokia denied that they know about the problem.
Comment 45 Ramsin Israel 2006-03-23 18:12:14 UTC
I could personally tell you guys that my previous 770 (which I broke) that I 
swapped out for a new one (@CompUSA) didn't have the same problem. The only 
thing I could think of is with the previous 770 I had, it was flashed with a 
patched firmware (root enable patch) from my work PC. This one I have now is 
flashed with a patched firmware (root patch) from my home PC.
Comment 46 Stephane Derville 2006-03-24 21:51:44 UTC
> I took the device to Nokia maintenance in Helsinki, waited for three weeks and
> got the device back (with a receipt that just said "Repaired in Germany").
> Connection dropping is still there, as frustrating as ever. 

I took the device to Nokia maintenance in France, waited for 2 weeks. The
receipt mentionned "adjustments" and connection dropping is still there.
Comment 47 Peter Hagg 2006-03-28 10:10:49 UTC
Bug has been reported to upstream component owner. Claiming ownership of bug
report.
Comment 48 Peter Hagg 2006-03-28 10:13:00 UTC
....and re-assigning the bug to myself. Sorry for spamming.
Comment 49 Marius Gedminas 2006-04-19 22:47:17 UTC
I also have this bug.  Various access points, no WEP/WPA, connection is usually
lost afer 5--15 minutes.

If I could ask the connection manager to automatically try reconnecting to the
same wireless network it was last connected, the problem would not be as painful.
Now I have to do the whole dance (get a network connection error, click the
retry button, wait until it searches for wifi networks (why can't it show me the
list from the last time and update it in the background?), click the same SSID I
clicke d on the last time).
Comment 50 Jussi Kukkonen 2006-04-25 11:32:12 UTC
Just in case this was still unclear:

According to my experience this is definitely a hardware problem. I have
received a new unit, and have tested it for aboout two weeks now: It works just
as expected, not  dropping the connection like the previous unit did -- I tested
it with the same OS version and same installed software, using the same APs.
Comment 51 Stephane Derville 2006-04-26 01:21:52 UTC
(In reply to comment #50)
> Just in case this was still unclear:
> 
> According to my experience this is definitely a hardware problem. I have
> received a new unit, and have tested it for aboout two weeks now: It works 
just
> as expected, not  dropping the connection like the previous unit did -- I 
tested
> it with the same OS version and same installed software, using the same APs.
> 

How did you get your unit changed ?
I return mine twice to Nokia support and still no improvement. They keep doing 
some adjustments on the unit.
Comment 52 Peter Hagg 2006-06-07 10:51:03 UTC
Re-assigning to correct owner.
Comment 53 obs cure 2006-06-16 15:59:47 UTC
looks like this is still open. i have the same exact problem and i'm currently
using the ping (arping in my case) hack. but this is only a hack and not really
a neat solution. any news about this please?
Comment 54 Detlef Schmicker 2006-06-16 16:04:09 UTC
My experience is that the Tablet 2006 beta has fixed this bug. It is realy
great, after 6 months i can use the device. And the battery is living much
longer without runing radion in the background all the time .-)
Comment 55 Patrik Flykt nokia 2006-06-16 16:32:12 UTC
(In reply to comment #54)
> My experience is that the Tablet 2006 beta has fixed this bug. It is realy
> great, after 6 months i can use the device.

:-)

The WLAN connection dropping should (note the wording - should) go away starting
with the OS 2006 BETA release. Those of you that want could check wheter this
BETA release fixes the WLAN connection dropping in their device. Do notice that
you are testing a BETA release, make a backup and have a previous OS 2005
release available, should the BETA release be too uncomfortable for use.
Comment 56 Maemo QA (deprecated) 2006-07-11 16:56:20 UTC
Please confirm if this problem still takes place in IT2006.
Comment 57 James Bolt 2006-07-12 04:05:14 UTC
I used to experience this (extremely irritating) bug with 3.2005.51-13; I'd be 
lucky to sustain a wireless connection for 10 minutes. However, with IT2006 Beta
& Final all seems to be resolved, and my 770 will happily stay associated with
my home (Linksys WRT54G, D-Link DWL-1000AP) & various public access points for
hours.
Comment 58 Marco Reichwald 2006-07-15 13:51:53 UTC
Just wanted to report that I still experience the problem with the final 2006
firmware.
Comment 59 Maemo QA (deprecated) 2006-08-03 16:56:59 UTC
Re-assign
Comment 60 Marc Baaden 2006-08-06 03:44:43 UTC
The problem still occurs with IT 2006 final!
Any update whether this is hardware or software failure?
Comment 61 Maemo QA (deprecated) 2006-08-08 15:53:16 UTC
In reply to comment #58 and comment #60. I'm sorry that there has not been an
update on this issue. If you are still having this problem with IT 2006, then
please contact Nokia service desk. This is most propably a hardware issue.
Comment 62 Walter Jansen (reporter) 2006-08-22 12:30:56 UTC
Hi,
I'm running IT 2006 final since several weeks now, and the problem seems to be
fixed, at least for my setup (see original report).
I had only two connection drops since then, and they might have had other reasons.
So far, so good. I'm experiencing extremely annoying browser problems now, but
these will go into a new bug report.
Thanks for fixing at least this one!
Rgds,
Walter
Comment 63 Marius Gedminas 2006-08-28 20:50:40 UTC
The problem seems to be gone in IT2006.

I bought another 770 and gave the old one away (after upgrading to IT2006 on
both).  A couple a days ago I borrowed it and left it online for two hours.  It
did not lose the wifi.  The new one also has no problems staying online.
Comment 64 Bernard 2006-09-25 23:52:43 UTC
I can confirm this bug still exists in version 1.2006.26-8. After browsing a
few 
minutes the connection drop (sitecom router). The refresh button will
reconnect. 
This problem can be reproduced with the rss-reader. After a suspend rss-reader 
won't connect, but a connection can be made by starting the browser. See 
attached dmesg output.

I hope this will help
Bernard
Comment 65 Bernard 2006-09-25 23:56:05 UTC
Created an attachment (id=114) [details]
dmesg
Comment 66 Jake Kunnari 2007-03-26 16:21:26 UTC
WONTFIX. No fixes to N770 anymore.
Comment 67 Jake Kunnari 2007-03-26 16:22:11 UTC
Closed by Error Manager 26.03.2007