Bug 3289 - (int-84122) E-mail messages and Settings boxes linked in Backup/Restore
(int-84122)
: E-mail messages and Settings boxes linked in Backup/Restore
Status: RESOLVED FIXED
Product: Settings and Maintenance
Backup/Restore
: 4.1 (4.2008.23-14)
: All Maemo
: Low normal (vote)
: 5.0 (1.2009.41-10)
Assigned To: unassigned
: backup-restore-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-06-24 21:38 UTC by Ryan Abel
Modified: 2009-06-10 16:22 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Ryan Abel (reporter) maemo.org 2008-06-24 21:38:47 UTC
SOFTWARE VERSION:
4.2008.23-14

STEPS TO REPRODUCE THE PROBLEM:

1. Open Backup/Restore
2. Tap "New Backup"
3. Uncheck either "E-mail messages" or "Settings"
4. Check either "E-mail messages" or "Settings" (pick the one you didn't pick
in step 3)

EXPECTED OUTCOME:
"E-mail messages" and "Settings" can be checked/unchecked independently of each
other.

ACTUAL OUTCOME:
"E-mail messages" and "Settings" are linked, and unchecking/checking one
unchecks/checks the other.

REPRODUCIBILITY:
Always

OTHER COMMENTS:
Seems like there's no way to backup just one or the other (assuming the GUI
actually corresponds correctly to whatever is going on internally), just both
or neither.

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US)
AppleWebKit/525.18 (KHTML, like Gecko, Safari/525.20) OmniWeb/v622.1.0.101362
Comment 1 Andre Klapper maemo.org 2008-06-30 12:36:56 UTC
Forwarding from internal ticket:
"It is because data related email are located both in gconf and $HOME. I agree
this "temporary" is annoying and confusing. It will be done in Fremantle."

Basically, it is currently required to make backing up mail work in general.
Comment 2 Andre Klapper maemo.org 2009-04-14 16:28:22 UTC
Well, no activity on the internal ticket, and the "Will be done in Fremantle"
comment is 9 months old - I don't trust this.

Quim,
I assume it's still valid in Fremantle (should take 10secs to test)?
Comment 3 Andre Klapper maemo.org 2009-06-10 16:22:36 UTC
I've just tested this,myself in Fremantle and both settings are not linked
against each other anymore. Hence closing as FIXED for Fremantle.

This is a WONTFIX for Diablo as Diablo is in maintenance mode and Nokia will
only provide bugfixes for critical issues if at all.
For your interest the Mer project aims to provide a community backport of
Fremantle for N8x0 devices. See http://wiki.maemo.org/Mer for more information.