Bug 3286 - (int-87036) Allow "refresh repositories" button on toolbar to be pressed in the main view
(int-87036)
: Allow "refresh repositories" button on toolbar to be pressed in the main view
Status: RESOLVED WONTFIX
Product: Settings and Maintenance
Application manager
: 4.1 (4.2008.23-14)
: All Maemo
: Low enhancement with 2 votes (vote)
: 5.0 (1.2009.41-10)
Assigned To: unassigned
: application-manager-bugs
:
: community-diablo, easyfix, patch
:
:
  Show dependency tree
 
Reported: 2008-06-24 19:23 UTC by kenneth
Modified: 2009-10-22 07:57 UTC (History)
6 users (show)

See Also:


Attachments
Enable refresh button in the main view (399 bytes, patch)
2008-07-20 15:21 UTC, Daniel Martin Yerga
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description kenneth (reporter) 2008-06-24 19:23:16 UTC
right now, if one start the application manager, the update button on the
toolbar is locked until one of the two web catalog areas have been opened.

please allow this button to be pressed on the main view.
Comment 1 Andre Klapper maemo.org 2008-06-30 12:42:54 UTC
Can you provide a step by step how-to?
After starting the application manager on the N810, i only have an "Install"
button and three icons down there in the toolbar.

If you refer to the "Check for Updates" button in the "Web catalogues" section,
below the "Show installable applications": For me it's not locked when
starting.
Comment 2 Ryan Abel maemo.org 2008-06-30 12:59:54 UTC
(In reply to comment #1)
> Can you provide a step by step how-to?
> After starting the application manager on the N810, i only have an "Install"
> button and three icons down there in the toolbar.
> 

You want the last one on the right.

> If you refer to the "Check for Updates" button in the "Web catalogues" section,
> below the "Show installable applications": For me it's not locked when
> starting.
> 

He wants this
http://www.legacyoflies.com/devuploads/general_antilles/application-manager-grayed.jpg
to look like this
http://www.legacyoflies.com/devuploads/general_antilles/application-manager-ungrayed.jpg
;)

(Note, the screenshot with the ungrayed update-repositories button is the
Application manager in Red Pill mode, so the functionality seems to be there,
the Red Pill-check just needs to be removed.)
Comment 3 Andre Klapper maemo.org 2008-06-30 13:10:49 UTC
Argh, wordings... I always called that button "Refresh" :-) Thanks!
Comment 4 kenneth (reporter) 2008-06-30 15:43:07 UTC
update, refresh, semantics can be a bitch ;)

but yes, i dont see the need to enter into any of the web catalog sections
before hitting the refresh buttons.

and if what the general says is true, im starting to suspect that one to many
dev at nokia spends all his time with the app manager in red pill mode...
Comment 5 Eero Tamminen nokia 2008-07-03 11:56:04 UTC
I wonder whether we could have the "red-pill mode" as a normal option
in the application manager settings (with appropriate warnings), is
there really a need to hide?
Comment 6 Ryan Abel maemo.org 2008-07-03 14:13:32 UTC
(In reply to comment #5)
> I wonder whether we could have the "red-pill mode" as a normal option
> in the application manager settings (with appropriate warnings), is
> there really a need to hide?
> 

Red Pill presents a quite a number of ways to easily drop you into a reboot
loop, so the structure would have to be reevaluated if it were to become an
easy-to-get-to use option. It's really a discussion outside the scope of this
bug, and probably shouldn't be addressed here.

Enabling the button in the main screen without Red Pill just needs to happen,
the Red Pill discussion can happen elsewhere. :D
Comment 7 Daniel Martin Yerga 2008-07-20 15:21:48 UTC
Created an attachment (id=831) [details]
Enable refresh button in the main view

Well, this is another 'easyfix' feature. So I have added an "one line patch" to
implement this. The patch is against the version in diablo (1:2.1.16) not
against the svn one.

Actually there is a function in the code to enable the refresh button, so
enabling it in the main view worked (simply change a false to true).
Comment 8 Andre Klapper maemo.org 2008-07-21 13:17:58 UTC
Cool. Thanks for the patch!
Comment 9 Eero Tamminen nokia 2008-10-22 14:33:03 UTC
> Actually there is a function in the code to enable the refresh button, so
> enabling it in the main view worked (simply change a false to true).

Is it disabled when red-pill mode is changed to blue-pill mode
(I mean should something else be patched also)?
Comment 10 Daniel Martin Yerga 2008-10-25 15:00:37 UTC
(In reply to comment #9)
> Is it disabled when red-pill mode is changed to blue-pill mode
> (I mean should something else be patched also)?
> 

The "enable_refresh (boolean)" function checks if it isn't in red-pill mode, it
does sensitive the button (if you pass true), or insensitive (if you pass false
to the function). If it's in red-pill, the function does nothing. 
When you change from red-pill to blue-pill, it 'redo' the main view (in this
case, if you are in the main view) with the new setting (blue-pill), and the
button continues being sensitive.

Now the only view where the refresh button is insensitive is in the installed
applications view, if you are in blue-pill mode, in red-pill mode the refresh
button is sensitive. Could be a bit inconsistent, but there could to do less
sense to have it available.

I hope you can understand my morning English ;)
Comment 11 Quim Gil nokia 2009-02-01 01:39:41 UTC
Marius, your take on this?

In the Fremantle AM it looks like the refresh icon can be pressed already in
the main view but the whole port is still too tender to tell for sure.

Also, why not having the "search" icon active in the main view already?

(I would even activate the "info" icon showing a basic explanation of what is
all about for pure end users not familiar with such tool, but I know that this
won't fly for the UI guys)  :)
Comment 12 Marius Vollmer nokia 2009-02-02 13:15:18 UTC
(In reply to comment #11)
> Marius, your take on this?
> 
> In the Fremantle AM it looks like the refresh icon can be pressed already in
> the main view but the whole port is still too tender to tell for sure.

Yes.  I am not too deeply involved with the Application any more,
unformatunately, but my impression is that the toolbar will completely
disappear from the main view.

We could fix the inconsistency by letting enable_refresh always making the
button sensitive in red-pill mode (instead of doing nothing), right?

> Also, why not having the "search" icon active in the main view already?

There is nothing to search.  The search button searches through the list you
see.

> (I would even activate the "info" icon showing a basic explanation of what is
> all about for pure end users not familiar with such tool, but I know that this
> won't fly for the UI guys)  :)

Yeah.  There is the "Help" entry in the menu and a "?" icon in the title of
dialogs for this.  But I think that is going away, too.
Comment 13 Ryan Abel maemo.org 2009-02-03 02:10:08 UTC
(In reply to comment #12)
> (In reply to comment #11)
> > Marius, your take on this?
> > 
> > In the Fremantle AM it looks like the refresh icon can be pressed already in
> > the main view but the whole port is still too tender to tell for sure.
> 
> Yes.  I am not too deeply involved with the Application any more,
> unformatunately . . .
>

Who, then, should we get in touch with about continued h-a-m improvements?
Comment 14 Marius Vollmer nokia 2009-02-03 13:12:45 UTC
(In reply to comment #13)
> > Yes.  I am not too deeply involved with the Application any more,
> > unformatunately . . .
> 
> Who, then, should we get in touch with about continued h-a-m improvements?

The official guy in charge is Richard Sun <richard.sun@nokia.com>.
Comment 15 Andre Klapper maemo.org 2009-06-08 14:04:46 UTC
> my impression is that the toolbar will completely disappear from the main view

This impression is also confirmed by the current Spec. :-)
By default in Diablo all toolbar items in the Main view are disabled anyway, so
it makes sense.
INVALID for Fremantle, WONTFIX for Diablo.

CC'ing Carsten because the patch might be interesting for Mer.
Comment 16 Lucas Maneos 2009-10-22 07:57:20 UTC
Marking patches of interest to Diablo (Maemo4) community updates, please excuse
the noise.