Bug 3275 - Browser address bar still on screen when typing into text fields
: Browser address bar still on screen when typing into text fields
Status: RESOLVED INVALID
Product: Browser
User interface
: unspecified
: N800 Linux
: Low normal (vote)
: ---
Assigned To: unassigned
: browser-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-06-22 17:25 UTC by Tony Green
Modified: 2008-06-22 17:56 UTC (History)
0 users (show)

See Also:


Attachments
Screenshot of OS2008 2.2007.50-2 (56.67 KB, image/png)
2008-06-22 17:56 UTC, Andrew Flegg
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Tony Green (reporter) 2008-06-22 17:25:47 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)
OS2008 Version 2.2007.51-3
STEPS TO REPRODUCE THE PROBLEM:
Launch browser
Go to a page with a text field (either simple text input field or textarea)
Click in text input field

EXPECTED OUTCOME:
on-screen keyboard should pop up, but the location bar should disappear. This
was the way it worked before I upgraded from 2.2007.50-2 to 2.2007.51-3 

ACTUAL OUTCOME:
on-screen keyboard pops up, but the location bar is still displayed at the top
of it as if I'd clicked in that to enter a URL. This results in less of the
screen being available to display the contents of the page.
REPRODUCIBILITY:
(always/sometimes/once)
always
EXTRA SOFTWARE INSTALLED:
bzip2
dbd-mysql
dbi
fbreader
gpe-calendar
gpesyncd
httpd
maemo-periodic
maemo-recorder
map
mysql
ogg-support
opessh-client
openssh-server
osso-xterm
personal-menu
pwsafe
rsync
stardict
vim
OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux armv6l; en-GB; rv:1.9a6pre)
Gecko/20071128 Firefox/3.0a1 Tablet browser
8SE_2.2007.51-3
Comment 1 timeless 2008-06-22 17:46:00 UTC
sorry, out of the box, this has *never* been the behavior.

the only case when the urlbar would autohide is if you have:
view>show toolbar>normal screen/full screen unchecked.

tested w/ 2.2006.39-14 and 2.2007.51-3

otherwise it'll always be visible regardless of the currently focused field.
Comment 2 Andrew Flegg maemo.org 2008-06-22 17:56:09 UTC
Created an attachment (id=785) [details]
Screenshot of OS2008 2.2007.50-2
Comment 3 Andrew Flegg maemo.org 2008-06-22 17:56:20 UTC
SOFTWARE VERSION:
N810 running OS2008 2.2007.50-2
N810 running OS2008 2.2007.51-3

STEPS TO REPRODUCE:
0) Close keyboard. Open Control Panel > Text Input > On-screen
2) Tick "Enable stylus input methods"
3) Click "OK"
4) From home screen, select browser menu > Open new browser window
5) On the default Nokia start page, tap stylus in Google search box.

OUTCOME:
* Browser viewport is shrinked
* Toolbar, including URL address bar, moves up.
* On-screen keyboard is shown.

Both 2.2007.50-2 and 2.2007.51-3 work the same on the two N810s here.

COMMENTS:
This is how it's always worked since OS2005, as far as I can remember. The
version against which it is claimed this is a regression, I can confirm acts
the same way as 2.2007.51-3.

Therefore, resolving as invalid. Any change to this behaviour is an enhancement
(and personally, one I'd not like to see as it's inconsistent with all other
toolbar-based applications, such as Notes) and part of a series of wider UI
issues with on-screen keyboards.