Bug 3264 - Garage is (re)sending a "maemo logo competition" mail every hour
: Garage is (re)sending a "maemo logo competition" mail every hour
Status: RESOLVED FIXED
Product: maemo.org Website
Garage
: unspecified
: All Linux
: High normal (vote)
: ---
Assigned To: Ferenc Szekely
: garage@maemo.org
:
:
:
:
  Show dependency tree
 
Reported: 2008-06-18 18:53 UTC by Luca Ognibene
Modified: 2008-07-16 22:50 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Luca Ognibene (reporter) 2008-06-18 18:53:16 UTC
I'm receiving mails from garage with subject "maemo.org logo competition is
open!" every hour, 16:50, 17:50 and 18:50.. 
Don't know if it's everyone or just me.


OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.9b5)
Gecko/2008041518 Firefox/3.0b5
Comment 1 Ryan Abel maemo.org 2008-06-18 19:11:04 UTC
Confirmed by quite a few people in #maemo
Comment 2 Niels Breet maemo.org 2008-06-18 21:44:25 UTC
Ferenc is on it. The mailer has been disabled for now, until we find out why
the database wasn't updated.
Comment 3 Andre Klapper maemo.org 2008-06-20 12:12:59 UTC
So the users' messages on the mailing list that this problem has stopped are
only because we disabled the mailer? Hmm, keeping this open then...
Comment 4 Dave Neary maemo.org 2008-06-30 16:14:12 UTC
Hi,

Anyone know what happened here? I only sent the mail once, but I'd like to know
whether there's a DB issue, or an issue with my announcement (so I don't make
the same mistake again next time).

Dave.
Comment 5 Ferenc Szekely maemo.org 2008-06-30 16:53:28 UTC
Not entirely sure, but I suspect it is a GForge problem. Your announcement was
just fine, but the mass-mailing functionality is disabled now on garage. I did
not yet have the time to investigate the root cause of this.
Comment 6 Andre Klapper maemo.org 2008-07-01 01:55:30 UTC
Not high priority currently as per last comment.
Comment 7 Quim Gil nokia 2008-07-02 14:10:17 UTC
Ferenc has committed this bug to the Sprint2. Changing priority to High.
Comment 8 Quim Gil nokia 2008-07-04 01:19:16 UTC
Hum, it would be good to send _one_ announcement about the Maemo Summit
throught this system...
Comment 9 Andre Klapper maemo.org 2008-07-14 14:25:25 UTC
Ferenc, any news here? :-/
Comment 10 Ferenc Szekely maemo.org 2008-07-16 17:10:39 UTC
fixed. 

the massmail cron job of gforge had a bug and it never updated the massmail
table properly. so whenever the job was started by cron the system thought that
there are recipients who did not receive the mail yet form the previous batch.

anybody willing to test it ;)
Comment 11 Quim Gil nokia 2008-07-16 17:26:38 UTC
Me! Can I send an announcement about the Maemo Summit? Still yesterday people
like penguinbait or gnuite didn't know what was going on.

I can do it right now if you are checking the cron and can stop the mailing if
we get a second wave.
Comment 12 Niels Breet maemo.org 2008-07-16 19:48:44 UTC
The bug is still present. Everybody should at least receive the summit mail
twice. I have disabled the mass-mailer in cron for now.
Comment 13 Quim Gil nokia 2008-07-16 19:50:53 UTC
Considering that we are going to use this service once a month at most, I
propose to close this bug as wontfix and just do the manual ON --> SEND --> OFF
every time we have something to say.
Comment 14 Ferenc Szekely maemo.org 2008-07-16 21:06:24 UTC
the locking mechanism of the massmail script is buggy too. sending out ~13000
mails takes some longer than 1 hr, the time between 2 iterations of the cron
job. the locking supposed to make sure that there is only one instance of the
script running at a time. checking how to fix that too..
Comment 15 Ferenc Szekely maemo.org 2008-07-16 22:50:12 UTC
for some reason the 'new' gforge which we installed a month (or so) ago did not
have the fix for the broken cron locking mechanism. i found the fix in gforge's
own svn repo. the massmailer seems to behave nicely now.

there can be multiple instances running of the massmail script, but only one
can do 'damage' at a time. all the others will have to wait until the 1st one
in the queue finished its job. and this first one will take care of the
database update properly, which was my 1st fix earlier today... i mark it
fixed, but we have to test it in 'real life' obviously. next announcement
please :)