Bug 3241 - Links to user and user's talk pages are redlinks, regardless of whether the pages link to actually exist
: Links to user and user's talk pages are redlinks, regardless of whether the p...
Status: RESOLVED FIXED
Product: maemo.org Website
Wiki
: unspecified
: All All
: Medium minor with 1 vote (vote)
: ---
Assigned To: Ferenc Szekely
: midgard@maemo.org
: http://wiki.maemo.org/Special:Recentc...
:
:
:
  Show dependency tree
 
Reported: 2008-06-12 10:08 UTC by Ryan Abel
Modified: 2010-07-01 17:26 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Ryan Abel (reporter) maemo.org 2008-06-12 10:08:53 UTC
STEPS TO REPRODUCE THE PROBLEM:

1. Go to a history page of some sort.
2. Try to click on a username or user talk page link.

EXPECTED OUTCOME:
If the page already exists, you are linked to the page.

ACTUAL OUTCOME:
Regardless of whether it exists, all links are shown as redlinks and link you
to the edit page.

REPRODUCIBILITY:
Always

OTHER COMMENTS:
Anonymous (IP) users seem to be working OK, but registered users do not.

Minor irritation, but is definitely a bug.

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US)
AppleWebKit/525.18 (KHTML, like Gecko, Safari/525.20) OmniWeb/v622.1.0.101362
Comment 1 Quim Gil nokia 2008-06-17 07:39:03 UTC
This is probably due to the fact that MediaWiki capitalizes usernames i.e. my
Garage "qgil" generates a "Qgil" user page in MediaWiki.
Comment 2 Ryan Abel (reporter) maemo.org 2008-06-23 21:47:19 UTC
(In reply to comment #1)
> This is probably due to the fact that MediaWiki capitalizes usernames i.e. my
> Garage "qgil" generates a "Qgil" user page in MediaWiki.
> 

One possible way to fix this is to find either the special message or whatever
it is that generates the userpage links and encapsulate it in a {{ucfirst:}}.

http://en.wikipedia.org/wiki/Help:Magic_words#Formatting
Comment 3 Quim Gil nokia 2008-07-19 16:55:14 UTC
Proposing to next sprint: MEDIUM.
Comment 4 Ferenc Szekely maemo.org 2008-07-23 00:07:31 UTC
Taking it in sprint3.
Comment 5 Quim Gil nokia 2008-11-04 23:57:13 UTC
Demoted to Medium as agreed on the
http://wiki.maemo.org/Maemo.org_Sprints/November_08 meeting.
Comment 6 Jeff Moe 2010-03-06 02:52:51 UTC
*** Bug 6569 has been marked as a duplicate of this bug. ***
Comment 7 Ferenc Szekely maemo.org 2010-06-30 21:45:56 UTC
This has probably been fixed by Dave recently. Tested it here:
http://wiki.maemo.org/index.php?title=Main_Page&action=history. 

Pages that exist appear as orange links and they do point to the right page.
Non-existing pages appear in red and they point to the 'page editor', which is
the correct behavior.
Comment 8 Dave Neary maemo.org 2010-07-01 17:26:30 UTC
yup, I got this one. I might have fixed a few others too that I missed &
haven't closed.