Bug 3228 - found = format_regex.match(data_string) : TypeError: expected string or buffer
: found = format_regex.match(data_string) : TypeError: expected string or buffer
Status: RESOLVED FIXED
Product: maemo.org Website
Garage
: 4.0
: All All
: Medium major (vote)
: ---
Assigned To: Ferenc Szekely
: garage@maemo.org
: https://garage.maemo.org/plugins/scms...
:
:
:
  Show dependency tree
 
Reported: 2008-06-06 16:33 UTC by timeless
Modified: 2008-07-16 15:36 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description timeless (reporter) 2008-06-06 16:33:19 UTC
STEPS TO REPRODUCE THE PROBLEM:
1. load
https://garage.maemo.org/plugins/scmsvn/viewcvs.php/mozilla/tags/microb-engine/microb-engine/1.0.4-34/debian/patches/series.gtk2?view=log&root=browser&pathrev=2476
2. click "Diff to previous 1925"

EXPECTED OUTCOME:
dunno, maybe a "revision log"

ACTUAL OUTCOME:
An Exception Has Occurred
Python Traceback

Traceback (most recent call last):
  File "/usr/local/viewcvs-1.0-dev/lib/viewcvs.py", line 3483, in main
    request.run_viewcvs()
  File "/usr/local/viewcvs-1.0-dev/lib/viewcvs.py", line 370, in run_viewcvs
    self.view_func(self)
  File "/usr/local/viewcvs-1.0-dev/lib/viewcvs.py", line 2761, in view_diff
    data.update({
  File "/usr/local/viewcvs-1.0-dev/lib/viewcvs.py", line 2370, in
rcsdiff_date_reformat
    date = compat.cvs_strptime(date_str)
  File "/usr/local/viewcvs-1.0-dev/lib/compat.py", line 51, in cvs_strptime
    return time.strptime(timestr, '%Y/%m/%d %H:%M:%S')[:-1] + (0,)
  File "_strptime.py", line 291, in strptime
    found = format_regex.match(data_string)
TypeError: expected string or buffer

REPRODUCIBILITY: always for this url (which i believe is legal and system
generated)

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.9.1a1pre) Gecko/2008052503 Minefield/3.1a1pre
Comment 1 Andre Klapper maemo.org 2008-06-09 21:37:27 UTC
I consider this a major loss of function but not critical - there's still other
ways to find out this information.
Comment 2 Ferenc Szekely maemo.org 2008-06-09 21:40:04 UTC
Must be an interesting issue, because other diffs on the same page work just
fine... I will be checking it in a few days.
Comment 3 tuukka.tolvanen nokia 2008-06-13 00:22:15 UTC
there's about two dozen of these:
http://www.google.fi/search?q=%22TypeError:+expected+string+or+buffer%22+site:maemo.org&filter=0
Comment 4 Ferenc Szekely maemo.org 2008-07-16 15:36:01 UTC
fixed. replaced viewcvs with a newer version of viewvc.