Bug 3216 - Mediawiki RSS feeds not working
: Mediawiki RSS feeds not working
Status: RESOLVED FIXED
Product: maemo.org Website
Wiki
: unspecified
: All All
: Medium normal (vote)
: 4.1.1
Assigned To: unassigned
: midgard@maemo.org
: https://wiki.maemo.org/index.php?titl...
:
:
:
  Show dependency tree
 
Reported: 2008-06-03 20:15 UTC by Ryan Abel
Modified: 2008-10-07 16:41 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Ryan Abel (reporter) maemo.org 2008-06-03 20:15:03 UTC
STEPS TO REPRODUCE THE PROBLEM:
1. Go to the RecentChanges page.
2. Try to subscribe to the RSS feed.

EXPECTED OUTCOME:
RSS feed successfully subscribed to.

ACTUAL OUTCOME:
From Safari:
“feed:https://wiki.maemo.org/index.php?title=Special:Recentchanges&feed=rss”.
The error was: “Operation could not be completed. (PubSub error 203.)”
(PubSub:203)"

From RSS Feed Reader:
"Unable to add feed. Address invalid."

REPRODUCIBILITY:
Always

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US)
AppleWebKit/523 (KHTML, like Gecko, Safari/523.10) OmniWeb/v621.0.99313
Comment 1 Niels Breet maemo.org 2008-06-03 20:32:44 UTC
I can't reproduce this bug.

http://validator.w3.org/feed/check.cgi?url=https%3A%2F%2Fwiki.maemo.org%2Findex.php%3Ftitle%3DSpecial%3ARecentchanges%26feed%3Drss

The feed validator validates this feed just fine.
Comment 2 Ryan Abel (reporter) maemo.org 2008-06-03 20:42:46 UTC
Issue shows up in Safari on Leopard and RSS Feed Reader on Diablo (3.2008.22-8)
and Chinook. Will test more later.
Comment 3 Niels Breet maemo.org 2008-06-04 14:03:04 UTC
We have enabled the http rss feed on
http://wiki.maemo.org/index.php?title=Special:Recentchanges&feed=rss

Does that one work better for you?
Comment 4 Ryan Abel (reporter) maemo.org 2008-06-04 18:21:55 UTC
False positive on Safari (complete failure on all RSS feeds), and issue for RSS
Feed Reader with https feeds (will open a new bug for this later). http feed
works fine on-device, though.
Comment 5 Andre Klapper maemo.org 2008-10-07 16:41:34 UTC
(Removing deprecated "Future" Target Milestone.)