Bug 3214 - (int-77110) Timezone switches require me to manually set the correct time.
(int-77110)
: Timezone switches require me to manually set the correct time.
Status: RESOLVED DUPLICATE of bug 2997
Product: Utilities
Clock
: 4.0
: All Linux
: Low normal (vote)
: ---
Assigned To: unassigned
: clock-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-06-03 15:17 UTC by Marius Gedminas
Modified: 2008-12-29 16:39 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Marius Gedminas (reporter) 2008-06-03 15:17:04 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)
2.2007-51-3

STEPS TO REPRODUCE THE PROBLEM:

Let's say the time now is 3:16 PM.

0. Travel from country X to country Y in a different timezone.
1. Open the Clock app
2. Menu -> Tools -> Date and time settings
3. Select home city
4. Choose a different time zone
5. Tap 'Ok'
6. Tap 'Ok'

EXPECTED OUTCOME:

The clock shows the correct time in the new timezone.

ACTUAL OUTCOME:

The clock shows 3:16 PM, which is the correct time in your old timezone, but
entirely the wrong time in the new timezone.

REPRODUCIBILITY:

Always
Comment 1 Andre Klapper maemo.org 2008-06-04 11:45:06 UTC
An internal ticket already exists, copying comments:

"You can force the clock applet to show the correct time by bringing the clock 
app up again, or by letting it go idle long enough that the whole display goes 
dark and then touching it to turn it on again (which obviously causes a 
refresh)."
Comment 2 Marius Gedminas (reporter) 2008-06-04 13:46:21 UTC
I think the internal bug is a different one.  It's not a matter of not
redrawing to show the correct time; it's a matter of actually setting the wrong
system time.

Here's a different procedure to try:

1. Open X Terminal
2. Type 'date; TZ=UTC date'

You will see something like 

  Wed Jun 4 13:40:47 CEST 2008
  Wed Jun 4 10:40:46 UTC 2008

3. Open clock app, select home city, change it to a different one, press ok
twice
4. Go back to xterm and type 'date; TZ=UTC date' again

What I would expect is to see approximately the same UTC time and an adjusted
local time.

What I actually see is a different UTC time, which indicates that the clock app
not only changed my timezone, it also changed the system time:

  Wed Jun 4 13:41:19 CEST 2008
  Wed Jun 4 11:41:19 UTC 2008
Comment 3 Marius Gedminas (reporter) 2008-06-04 13:49:24 UTC
I suspect this may be a simple user interface issue.

When I go to Date and time settings, I get a dialog where I can set the date
and time.  When I then press 'Select home city' and change it, I get back to
the date/time settings dialog *which still shows the old time* in the input
box, so when I press Ok again I actually set the date & time.

What should happen instead is that when I change the home city and go back to
the date & time dialog, the timezone difference should be applied to the time
in the entry box.
Comment 4 Marius Gedminas (reporter) 2008-06-04 13:51:19 UTC
Also note that if I do this:

1. Date & time settings
2. Select home city
3. Select it
4. Press Ok in the 'select home city' dialog
5. Press Cancel in the 'date & time settings' dialog

then home city is not set.  This means the user interface won't allow me to
change the timezone without changing the system time.  That's not a problem if
the user interface makes sure I can't change the (UTC) system time to a
different value without actually interacting with the time input box.
Comment 5 Andre Klapper maemo.org 2008-12-29 16:39:59 UTC
Seems to be a dup of bug 2997.

*** This bug has been marked as a duplicate of bug 2997 ***