Bug 3199 - Display applet source should be open
: Display applet source should be open
Status: RESOLVED WONTFIX
Product: Licensing Change Requests
General
: unspecified
: All Maemo
: Low enhancement with 3 votes (vote)
: ---
Assigned To: unassigned
: licensing-requests
:
:
:
:
  Show dependency tree
 
Reported: 2008-05-30 04:08 UTC by Adam Harwell
Modified: 2010-02-16 19:55 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Adam Harwell (reporter) maemo.org 2008-05-30 04:08:31 UTC
I'm requesting that the source to the Display statusbar applet be opened, as
it would help community projects (like this one
https://garage.maemo.org/projects/adv-backlight/
http://www.internettablettalk.com/forums/showthread.php?t=16531) implement
more feature-rich, customizable, and useful community versions of the Nokia
applet, thus increasing overall platform appeal and usefulness, and customer
satisfaction, and reducing the pressure on Nokia to implement things like bug
#375 and #1261.

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14)
Gecko/20080404 Firefox/2.0.0.14
Comment 1 Faheem Pervez maemo.org 2008-05-30 17:48:37 UTC
*** This bug has been confirmed by popular vote. ***
Comment 2 Andre Klapper maemo.org 2008-06-06 12:59:33 UTC
also see https://bugs.maemo.org/show_bug.cgi?id=1584#c7
Comment 3 Quim Gil nokia 2008-06-06 13:31:04 UTC
Hi, opening the applet wouldn't necessarely allow more feature rich display
control to be implemented. The plugin only provides UI and most of the logic is
in mce and dsme. These are probably the components you are looking after.

About the applet itself: as for today opensourcing UI elements is tricky, since
most of the OS2008 UI is closed.

The Statusbar display plugin will get significant changes in Fremantle anyway,
including this code you are requesting to be opened. I will resolve this as
wontfix now, please reconsider your request when Fremantle is public.
Comment 4 Adam Harwell (reporter) maemo.org 2008-06-06 13:52:09 UTC
Ok, though dsme is the part I already figured out... My problem is 100% with UI
related stuff. :)
Comment 5 Ryan Abel maemo.org 2008-06-06 20:25:36 UTC
(In reply to comment #3)
> Hi, opening the applet wouldn't necessarely allow more feature rich display
> control to be implemented. The plugin only provides UI and most of the logic is
> in mce and dsme. These are probably the components you are looking after.
> 

No, the dmse and mce part of things has already been figured out.

The issue is 100% related to the UI part of things, in that Nokia has somehow
managed to put the sliders in an element which achieves certain behaviors which
are correct for a statusbar applet. Compare this to the fall-back that had to
be accepted with Advance Backlight (using the popup element), where the menu is
neither themed correctly nor does it respond correctly to taps (have to close
by taping on the taskbar or statusbar, as opposed to anywhere).

Opening this applet or better documenting the method used would allow Advance
Backlight to behave in the same manner as the stock Nokia applets.
Comment 6 Eero Tamminen nokia 2008-06-12 17:06:25 UTC
(In reply to comment #5)
> (In reply to comment #3)
>> Hi, opening the applet wouldn't necessarely allow more feature rich
>> display control to be implemented. The plugin only provides UI and
>> most of the logic is in mce and dsme. These are probably the components
>> you are looking after. 
> 
> No, the dmse and mce part of things has already been figured out.
> 
> The issue is 100% related to the UI part of things,
>
> in that Nokia has somehow managed to put the sliders in an element which
> achieves certain behaviors which are correct for a statusbar applet.

In this case I guess you should make a bug about having example code for
creating a Hildon (statusbar) menu with sliders.


> Compare this to the fall-back that had to be accepted with Advance
> Backlight (using the popup element), where the menu is neither themed 
> correctly nor does it respond correctly to taps (have to close
> by taping on the taskbar or statusbar, as opposed to anywhere).

The UI code to get the correct looks, is something like this:
  gtk_window_set_is_temporary (GTK_WINDOW (self), TRUE);
  gtk_window_set_type_hint (GTK_WINDOW (self), GDK_WINDOW_TYPE_HINT_MENU);
  gtk_window_set_resizable (GTK_WINDOW (self), FALSE);
  gtk_window_set_decorated (GTK_WINDOW (self), FALSE);
  gtk_container_set_border_width (GTK_CONTAINER (self), 20); // ugh,hardcoded
  gtk_window_set_keep_above (GTK_WINDOW (self), TRUE);

I.e. you use just a plain window and do manually things that Gtk menu
does (including grabs, maybe keyboard handling too).  It's quite icky
stuff.
Comment 7 Andre Klapper maemo.org 2008-10-07 16:36:11 UTC
Removing deprecated "Future" Target Milestone from WONTFIX bugs.
Comment 8 Andre Klapper maemo.org 2009-09-18 23:16:08 UTC
(Splitting product "Home applets" into "Desktop widgets" and "Statusbar
widgets".
Sorry for the bugmail noise. You can filter by searching for this comment.)
Comment 9 Andre Klapper maemo.org 2010-02-16 19:55:15 UTC
(Moving all Licensing Change Requests to a separate Product in Bugzilla.
Sorry for the bugmail noise)