Bug 3099 - Network printing support
: Network printing support
Status: RESOLVED WONTFIX
Product: Desktop platform
general
: 4.0
: All Linux
: Low enhancement with 49 votes (vote)
: ---
Assigned To: unassigned
: HAF QA mailing list
:
:
:
:
  Show dependency tree
 
Reported: 2008-04-16 21:14 UTC by Woody
Modified: 2010-12-14 15:21 UTC (History)
13 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Woody (reporter) 2008-04-16 21:14:37 UTC
Maemo lacks the facility to print to anything from anywhere.

Most mobile devices I have can and do print. Maemo can't.

It would be good to support at least a basic printing structure, as without it
applications where printouts are an advantage are not going to be written for
the platform.
Comment 1 Michel Salim 2008-04-21 22:41:45 UTC
As a basic option, a default PDF virtual printer would be nice. After that, IPP
printing (perhaps with Avahi for auto-discovery of local printers?) and also
SMB printing. Not sure how well CUPS supports Bluetooth printing right now.
Comment 2 Karsten Br├Ąckelmann 2008-05-23 15:04:56 UTC
Re-setting the assignee, since Carlos moved on to other tasks.

Please note that this does not affect the legitimacy of the bug in any way.
It's a purely administrative operation. Sorry for the noise.
Comment 3 Andre Klapper maemo.org 2008-11-24 12:31:49 UTC
This is not planned - setting priority to Low.
Comment 4 Roope Rainisto nokia 2008-12-01 14:13:00 UTC
Yes, perhaps one day, but it's not on the Fremantle/Harmattan agenda yet, there
are more important items.
Comment 5 Quim Gil nokia 2009-01-10 14:02:38 UTC
What are the most reasonable use cases needing printing support for devices
with Maemo inside?

- Print PDFs looks like one. There is a PDF reader, so it makes sense.

- The usual case of printing office documents is less of a use case while there
are no office applications supported. First things first.

- Print web pages? Having a PC/laptop I used to print stuff I needed to bring
with me, for instance the route to some place or the info about something I
wanted to buy. Now I just keep the web pages open/saved in my device, that goes
always with me. The routes are checked on the go.  :)

- Print pictures? Are there many people printing pictures at home nowadays?
There are plenty of services concentrating on this, either you go to the shop
or you can even get them submitted online and get them by mail quite fast. In
any case, with high definition camera support the use case of printing pictures
is less remote.

What else?

It would be good to discuss also how far Maemo is technically from a
productized network print support, and what are the attempts done by third
parties. Printing support hasn't been the strongest feature in Linux, but
perhaps the situation is better nowadays.

What would be the better way to talk to the printers? fwiw Samba support is
being dropped in Fremantle...

I'm no expert and I actually barely user any printer nowadays, but the feature
is interesting and perhaps the discussion too.  :)

There is nothing at wiki.maemo.org and there are some thread in ITt:

nPrint - simple printing solution for N8X0'rs! 
http://www.internettablettalk.com/forums/showthread.php?t=16162

Announce: Small-size alternative tablet PRINT support for OS2007
http://www.internettablettalk.com/forums/showthread.php?t=10891
Comment 6 Alan Bruce maemo.org 2009-01-13 19:26:07 UTC
I voted for this bug, because I think it would be nice to be able to print, but
I'm like Quim here; I have two printers at home and I almost never print
anything anymore. I also used to print things to bring with me, but now I can
put the page on the tablet's screen instead. I've even used the tablet in
airports to check myself in and rent a car, where I used to have a stack of
paper instead.

I'm not terribly disappointed that Diablo's crippled SMB support is being
removed in Fremantle, since I could never use it anyway, but it definitely
makes it much more difficult to do network printing. This pretty much leaves
Bluetooth or an SSH solution as discussed in one of the threads Quim linked to.
Comment 7 mathew 2009-01-14 09:50:11 UTC
I would like to print as PDF and then send through email or annotate PDF in
xournal.
Comment 8 Quim Gil nokia 2009-01-14 09:55:57 UTC
(In reply to comment #7)
> I would like to print as PDF and then send through email or annotate PDF in
> xournal.

Print as PDF from which app(s)?
Comment 9 mathew 2009-01-14 10:03:44 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > I would like to print as PDF and then send through email or annotate PDF in
> > xournal.
> 
> Print as PDF from which app(s)?
> 

I can think of from browser, email client, and text editor
Comment 10 benson 2009-01-14 19:55:31 UTC
More use cases:

* Filling out and printing forms that require paper submission. (I have
actually used my N800 for this. I would import a form, either PDF or rasterized
(scanned or digitally photographed & enhanced from paper), type/write/mark it
up in Xournal, and export as a PDF; then I would use a networked printer with a
web interface to upload and print the PDF. A print infrastructure allowing
printing direct from Xournal would have been _particularly_ nice in my case, as
the printer in question has a rather buggy web interface.) Programs would be
Xournal, and perhaps others of that sort.

* Printing artwork. Some people do rather nice art using the N8x0 as a graphics
tablet, and (were I thus talented) I could see wanting to print those as well.
There's several programs used for this; mpaint, xournal, even sketch.

* Printing notes for open-note, but no-computer, exams. This would be from
Xournal, Maemopad+, and similar.

* Printing source code. Sometimes, when doing _massive_ reorganization, I find
it helpful to print out all the code, lay huge swaths of it on a desk or the
floor, and attack it with 5 or 6 colors of highlighter. (I'm fortunate enough
not to have done any such reorganizations since I got my tablet.) This would be
from any text editor, or perhaps even better with a2ps or such.


As for printing infrastructures, CUPS is probably the network-savviest, and
consequently I'd guess the easiest to get proper behavior out of on a
network-hopping machine like the tablets. It's also the heaviest, but I don't
think it should be enough to be problematic.

I's like to see at least CUPS in, with a local PDF-dropping printer configured
(even if there's no UI to configure other printers), then applications where
printing makes sense can have print support, and the UI and auto-configuration
stuff can be added in later releases, or by the community.

(In reply to comment #4)
> Yes, perhaps one day, but it's not on the Fremantle/Harmattan agenda yet, there
> are more important items. 
What exactly does this mean, at this point? Could even basic infrastructure and
print-to-file (given adequate priority) still get into Fremantle, so apps could
have print capability, or is Harmattan the earliest this could be squeezed in?
Comment 11 Quim Gil nokia 2009-03-09 07:18:06 UTC
System infrastructure to interoperate with printers is a complex task if you
want to offer official support. We are not seeing a strong demand from users
(despite the number of votes here) that would justify the effort. People are
printing less in generals, they have less chancesto have a printer at home and
those willing to print either have a PC and printer or they go and print
specific jobs (e.g pictures or books) in specialized outlets, with a USB stick,
sending the file, etc.

'Export as PDF' (or PS etc) can be implemented at application level for the
apps that make sense to have it. What about resolving this request as wontfix
inviting to open new requests for the official apps that would require such
printed-oriented export function.
Comment 12 Quim Gil nokia 2009-03-11 22:31:00 UTC
Confirming that this is a WONTFIX since it is not in the Maemo SW current
plans.

If someone wants to go ahead implementing this feature go ahead. Let us know if
there is anything that would be required from our side at a platform level.
Comment 13 Michael 2010-01-14 16:29:54 UTC
Conversion of documents to PDF files is important. generic way would be via
printing system.

anyhow i need to create PDF files from photos. This is thought as a kind of
"mobile scanner" device. For archiving purposes this would be fine enough.
Comment 14 Ryan Abel maemo.org 2010-01-21 04:07:05 UTC
*** Bug 8346 has been marked as a duplicate of this bug. ***
Comment 15 Andre Klapper maemo.org 2010-01-21 12:40:27 UTC
*** Bug 8346 has been marked as a duplicate of this bug. ***
Comment 16 Fadi Farah 2010-01-25 09:16:55 UTC
SOFTWARE VERSION: 2.2009.51-1

EXACT STEPS LEADING TO PROBLEM: 
1. Navigate to any program that you can print out from (lets say MicroB)
2. Find an interesting thing to print out.
3. Tap on top or on any menu.

EXPECTED OUTCOME:

A print dialogue with everything a person would expect from a computer (like
print preview, print selection, print page(s), change printers).

ACTUAL OUTCOME:

N/A

REPRODUCIBILITY:

Always

EXTRA SOFTWARE INSTALLED:

Not related

OTHER COMMENTS:

I have been looking around to see if there's a solution for printing from my
N900, and I even posted a thread in the brainstorm thread (in talk.maemo.org)
about this but noone has been paying attention to that, (here's a link to my
thread; http://talk.maemo.org/showthread.php?t=37739).

And even with a simple Google search I got this:
http://www.gossamer-threads.com/lists/maemo/users/55183 , which shows that
Andre was saying that there should be a print option for the N900.

What I am trying to get to is that there's no print option for the N900
what-so-ever, and since it's a mobile computer I believe that there should be
such option fot that. Lets say I was at the university and I couldn't go on the
computer, I should be able to print from my N900 to any Wifi/Bluetooth enabled
printers. Or if I want to print something fast, I should be able to go on my
N900 and print from there.. etc.

I am opening a bug for this because I want to grab some attention on this
situation.

Now I know there's cups (which I don't believe it's supported with Maemo5), but
that also doesn't always work + it's not practical.  And people have been
wanting this feature for a long time! So why not officially include it.

Now I understand that this is not super high priority, but at least this should
be put into consideration and not forgotten.

Thanks in advance,

Fadi Farah
Comment 17 Fadi Farah 2010-01-25 09:35:09 UTC
I could swear I read on that page that andre said that it will be supported in
Maemo 5.. but can't see that anymore..
Comment 18 Andre Klapper maemo.org 2010-05-19 21:36:42 UTC
*** Bug 10210 has been marked as a duplicate of this bug. ***