Bug 3073 - (int-86548) Can't enter non-alphabetic Control Sequences such as Ctrl-\, Ctrl-[...
(int-86548)
: Can't enter non-alphabetic Control Sequences such as Ctrl-\, Ctrl-[...
Status: RESOLVED FIXED
Product: Utilities
X Terminal
: 4.1.3 (5.2008.43-7)
: N800 All
: Low major with 1 vote (vote)
: 5.0 (1.2009.41-10)
Assigned To: unassigned
: osso-xterm-bugs
:
:
: int-107812
:
  Show dependency tree
 
Reported: 2008-04-07 00:38 UTC by Denis DeLaRoca
Modified: 2009-09-28 18:43 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Denis DeLaRoca (reporter) 2008-04-07 00:38:23 UTC
SOFTWARE VERSION: 2.2007.50-2

STEPS TO REPRODUCE THE PROBLEM: Input of <Ctrl><non-alphabetic-char> does not
work, ie., Ctrl-a works, but not Ctrl-\. The last time I recall this working
correctly was under IT OS 2007 version 4.2007.26-8... since and up to the
latest IT OS 2008 I am unable to successfully enter control sequences such as
Ctrl-\ or Ctrl-[ on text apps being run on xterm. This happens only with the
Virtual Keyboard input method. From an external BT keyboard no such problems
exist. 

REPRODUCIBILITY: always.
Comment 1 Eero Tamminen nokia 2008-06-24 12:02:34 UTC
Confirmed also in Diablo.  This happens also for equivalent codes like '|' and
'{'
(which correspond to '\' and '[' when using Control (it just zeros some bits)).
Comment 2 Andre Klapper maemo.org 2009-03-24 16:36:39 UTC
Denis: I assume it's still valid in Fremantle SDK alpha that contains
osso-xterm?
Unfortunately it's WONTFIX for Diablo but I'd love to help pushing this into
Fremantle.
Comment 3 Javier Jardón 2009-03-30 19:00:14 UTC
Still valid in 4.1.3 (5.2008.43-7) maemo release
Comment 4 Lucas Maneos 2009-04-02 00:00:49 UTC
(In reply to comment #2)
> I assume it's still valid in Fremantle SDK alpha that contains
> osso-xterm?

With the information available so far I'm not sure it makes sense for
Fremantle, since the stylus keyboard has been dropped there.  Non-alphabetic
Ctrl combinations are extremely cumbersome to enter with the finger keyboard,
and impossible with the hardware keyboard, at least with the Diablo & N810
layouts respectively (Ctrl+handwriting?  Don't go there!)

On the other hand, Fremantle osso-xterm still has the Ctrl widget in the
toolbar, although it doesn't appear to do anything in scratchbox (but the only
available input method is from the host machine's keyboard so this may not be
the whole story).

Hopefully the beta will come with some input methods to play with...
Comment 5 Andre Klapper maemo.org 2009-07-16 16:51:04 UTC
I entered Ctrl-\ in the Fremantle X-Terminal.
Output is a black square in the terminal.
Is this expected behaviour?

Ctrl-[ does NOT work by the way.
Comment 6 Lucas Maneos 2009-07-17 03:07:40 UTC
(In reply to comment #5)
> I entered Ctrl-\ in the Fremantle X-Terminal.
> Output is a black square in the terminal.
> Is this expected behaviour?

In general you can compare on-device input to remote input in an ssh session.

On the shell prompt it shouldn't produce anything.  If you run cat first and
then type Ctrl-\ it should send it a SIGQUIT and you should see:

~ $ cat
Quit

> Ctrl-[ does NOT work by the way.

On the prompt that shouldn't do anything either but in cat it should display
"^[".
Comment 7 Andre Klapper maemo.org 2009-09-28 18:43:57 UTC
This works for me in the internal Fremantle version.
Closing as FIXED in Fremantle.

This is a WONTFIX for Diablo as Diablo is in maintenance mode and Nokia will
only provide bugfixes for critical issues if at all.
For your interest the Mer project aims to provide a community backport of
Fremantle for N8x0 devices. See http://wiki.maemo.org/Mer for more information.