Bug 304 - (int-28826/int-128109) Automatic proxy configuration URL not obeyed by RSS feed reader
(int-28826/int-128109)
: Automatic proxy configuration URL not obeyed by RSS feed reader
Status: RESOLVED FIXED
Product: RSS feed reader
General
: 5.0/(3.2010.02-8)
: All Maemo
: Medium normal (vote)
: 5.0/(10.2010.19-1)
Assigned To: unassigned
: rss-feed-reader-bugs
:
: ITOS2007HE-garage
:
: 3783
  Show dependency tree
 
Reported: 2005-11-28 18:35 UTC by Simon Pickering
Modified: 2010-04-26 16:20 UTC (History)
2 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Simon Pickering (reporter) maemo.org 2005-11-28 18:35:02 UTC
If using an automatic configuration url for the proxy settings, this is obeyed
by the web browser and internet radio, however the news-reader ignores it.

This is with version 1.2005.42-9 of the Internet Tablet software.
Comment 1 Maemo QA (deprecated) 2006-05-03 14:10:08 UTC
Claiming ownership.
Comment 2 Maemo QA (deprecated) 2006-05-03 14:12:47 UTC
Simon, I'm unable to reproduce this problem due to the network environment I
got
(manual proxy configuration). Would it be possible for you to re-test with a
newer product image, say 2006-13?
Comment 3 Simon Pickering (reporter) maemo.org 2006-05-04 19:07:33 UTC
This bug is still present in the latest software release (5.2006.13-7). 

The symptoms are the same - the web browser and internet radio work when using
the automatic configuration address, but the news-reader doesn't.

I also note that the automatic configuration address cannot have a leading
http:// otherwise nothing will work. This is slightly confusing as the address
surely requires the protocol type? One solution would be to have it work with or
without the http:// (certainly more robust that the current behaviour). 

Likewise the manual proxy addresses won't accept a protocol affix (like http://)
though I'm not sure whether this is accepted practice.


Simon
Comment 4 Maemo QA (deprecated) 2006-05-08 11:26:31 UTC
Thanks for verifying the bug with 2006-13. Bug has been reported to upstream
maintainer.
Comment 6 Lucas Maneos 2008-10-04 21:12:50 UTC
Still present in 4.2008.36-5, with or without "http://" in the proxy
auto-config URL.
Comment 7 Andre Klapper maemo.org 2009-07-14 13:04:49 UTC
Still happening in current Fremantle as per negative test (enter a fake proxy
address and see RSS loading feeds while browser correctly fails).
Comment 8 Andre Klapper maemo.org 2009-07-14 15:29:14 UTC
Funny thing is: I cannot reproduce this issue in 5.2008.43-7.
Entering a fake proxy address makes the RSS feed reader unable to refresh
feeds.
So it seems it's FIXED in latest Diablo, but valid in current Fremantle.
Comment 9 Lucas Maneos 2009-07-14 15:39:36 UTC
(In reply to comment #8)
> Funny thing is: I cannot reproduce this issue in 5.2008.43-7.

Yes, this bug was about "automatic configuration"-type proxy settings. If the
Fremantle version doesn't honour HTTP-type proxy settings that sounds like a
new bug.
Comment 10 Andre Klapper maemo.org 2010-02-09 19:31:10 UTC
Closing as FIXED as per internal comment:

"I tested this issue on version 2010.04-11 after changing the proxy settings as
mentioned in the bug scenario.
When the user tries to add feed in rss it is showing the banner as "unable to
add the feed. Address Invalid".
If the user tries to refresh the feeds which was already added rss will not
refresh it is displaying the old refreshed contents."
Comment 11 Lucas Maneos 2010-03-13 11:37:47 UTC
That doesn't sound like FIXED to me, more like a confirmation of the bug.
Comment 12 Andre Klapper maemo.org 2010-03-15 20:15:11 UTC
I don't think so, as my internal ticket was:

STEPS TO REPRODUCE:
1. Go to Settings > Internet Connections > Connections > Edit > Next > Next >
Next > Advanced
2. Enable "Use proxy"
3. Enter HTTP proxy = example.foo
4. Port number = 80
(5. Enter HTTPS proxy = example.foo)
(6. Port number = 80)
7. Click "Save"
8. Start browser
9. Go to http://www.spiegel.de
10. Get correct Error message 
11. Start RSS feed reader
12. Add feed "http://www.spiegel.de/schlagzeilen/index.rss"
13. Click Refresh icon

EXPECTED OUTCOME:
Global Proxy settings are used.
Hence RSS feed reader should not be able to access the feed as the HTTP proxy
address is a fake one

ACTUAL OUTCOME:
Global Proxy settings are ignored.
RSS feed loads.


Hence if it now does not work with fake proxy settings, it's fixed I'd say.
Comment 13 Andre Klapper maemo.org 2010-03-15 20:55:20 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).
Comment 14 Lucas Maneos 2010-03-15 23:34:02 UTC
(In reply to comment #12)
> 2. Enable "Use proxy"
> 3. Enter HTTP proxy = example.foo
> 4. Port number = 80

Right, I see the mix-up.  The above is manual proxy configuration, which has
been working fine since forever.  This bug is about automatic proxy
configuration (<http://en.wikipedia.org/wiki/Proxy_auto-config>).

So it seems that there was a temporary regression in Fremantle (comment 7 /
int-128109) and that was FIXED, but the original issue is still outstanding
(well, I suppose it might have been fixed but since that would require a
javascript engine and Nokia doesn't seem keen to spend too much effort on the
RSS reader I'm not holding my breath).

I set up a dummy .pac file for testing, to reproduce replace steps 3-7 with:

3. Enable "Automatic configuration".
4. Enter "http://home.maneos.org/maemo/bug304.pac" in "Web address".
5. Tap "Save", "Finish", "Done", "Save".
Comment 15 Andre Klapper maemo.org 2010-04-22 17:45:58 UTC
Lucas, I'm getting lost. :-/
Feel more than welcome to file a fresh new bug report explaining the steps and
explaining what the bug is *not* about.
Comment 16 Lucas Maneos 2010-04-26 16:20:08 UTC
(In reply to comment #15)
> Lucas, I'm getting lost. :-/

Automatic proxy configuration is essentially just a URL that points to a
javascript program that decides the proxy to be used (if any) programmatically
for each request.  See the link in comment 14 for more details.

> Feel more than welcome to file a fresh new bug report explaining the steps and
> explaining what the bug is *not* about.

I think the original report is fine, and realistically this has no chance of
getting fixed in Fremantle so another report at this point would be just noise.

Let's see what Harmattan brings when the relevant API docs are published. 
Ideally it should provide something like libproxy
(<http://code.google.com/p/libproxy/>) for consistent proxy support throughout
the platform.