Bug 3033 - (int-85415) Diablo BusyBox v1.6.1 has broken tar
(int-85415)
: Diablo BusyBox v1.6.1 has broken tar
Status: RESOLVED FIXED
Product: Core
Busybox
: 4.0
: N810 Maemo
: Low normal (vote)
: 4.1.3
Assigned To: unassigned
: busybox-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-03-20 02:45 UTC by Vincent Lefevre
Modified: 2009-03-24 17:29 UTC (History)
5 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Vincent Lefevre (reporter) 2008-03-20 02:45:43 UTC
SOFTWARE VERSION:
OS2008 / 2.2007.50-2

STEPS TO REPRODUCE THE PROBLEM:
1. wget http://www.mpfr.org/mpfr-2.3.1/mpfr-2.3.1.tar.gz
2. tar xzf mpfr-2.3.1.tar.gz

EXPECTED OUTCOME:
The archive should be untar'ed.

ACTUAL OUTCOME:
I get the following error:
tar: invalid tar magic

REPRODUCIBILITY:
always with this archive, no problem with some other archives. Decompressing
the archive first (with gunzip) and using "tar xf mpfr-2.3.1.tar" does not
solve the problem.

OTHER COMMENTS:
On a Debian machine, I got the same problem with Debian's busybox package
(using an even older version), but no problem with BusyBox 1.9.1 from upstream.
So, I assume that an upgrade would fix the problem.
Comment 1 Nick Loeve 2008-05-11 21:10:09 UTC
I can confirm this still happens for some archives i try and the one linked
above also.

SOFTWARE VERSION:

Nokia-N800-51-3:~# cat /etc/osso_software_version   
RX-34+RX-44_2008SE_2.2007.51-3_PR_MR0
Comment 2 Eero Tamminen nokia 2008-05-12 18:04:06 UTC
Confirmed, thanks for the report!

(In reply to comment #0)
> On a Debian machine, I got the same problem with Debian's busybox package
> (using an even older version), but no problem with BusyBox 1.9.1 from
> upstream. So, I assume that an upgrade would fix the problem.

Unfortunately the Busybox version isn't going to be updated yet for the next
release, hopefully for the one after that.


> SOFTWARE VERSION:
> OS2008 / 2.2007.50-2
[...]
(In reply to comment #1)
> I can confirm this still happens for some archives i try and the one linked
> above also.
> 
> SOFTWARE VERSION:
> RX-34+RX-44_2008SE_2.2007.51-3_PR_MR0

This quick-fix release fixed just the booting issue, AFAIK it didn't have
any changes to the rootfs (where the device Busybox resides).
Comment 3 Eero Tamminen nokia 2008-08-13 18:18:25 UTC
Busybox will be updated for the next major release (Fremantle).
Comment 4 Grigori Timonen nokia 2008-09-17 15:24:08 UTC
Looks like provided archive is older format archive (V7) which was created
using --format=v7 (--portability,--old-archive).
Comment 5 Vincent Lefevre (reporter) 2008-09-17 18:59:44 UTC
(In reply to comment #4)
> Looks like provided archive is older format archive (V7) which was created
> using --format=v7 (--portability,--old-archive). 

It was built by GNU tar via "make dist" (automake version was 1.9.6). It seems
that --format=v7 is the default used by automake.
Comment 6 Grigori Timonen nokia 2008-09-18 09:13:39 UTC
Fixed.
Comment 7 Grigori Timonen nokia 2008-09-18 14:46:18 UTC
Fix will be released in next public Diablo release / SSU update.
Comment 8 Andre Klapper maemo.org 2008-09-22 14:52:09 UTC
Fixed in package
busybox 3:1.6.1.legal-1osso16
which is part of the internal build version
5.2008.38

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 9 Andre Klapper maemo.org 2008-09-29 15:50:22 UTC
Note that this fix is not included in today's 4.2008.36-5 update.
Comment 10 Andre Klapper maemo.org 2008-12-17 20:20:55 UTC
Fix for this should be included in today's 5.2008.43-7 SSU update.
Please verify the fix by marking this bug report as VERIFIED if you have some
time.
Comment 11 David Horn 2008-12-18 22:06:35 UTC
Busybox config-deb file change in busybox 3:1.6.1.legal-1osso16: 
CONFIG_FEATURE_TAR_OLDGNU_COMPATIBILITY=y

Looks good to me in 43-7 , but I'm not the original reporter ;)
Comment 12 Vincent Lefevre (reporter) 2008-12-19 02:43:40 UTC
OK on the same tar file.
Comment 13 Lucas Maneos 2009-03-22 16:16:19 UTC
Fremantle alpha busybox is built with CONFIG_FEATURE_TAR_OLDSUN_COMPATIBILITY
(new option) but not CONFIG_FEATURE_TAR_OLDGNU_COMPATIBILITY and again fails to
process the mpfr-2.3.1.tar.gz archive.
Comment 14 Andre Klapper maemo.org 2009-03-23 18:26:49 UTC
Lucas: So this was FIXED for Diablo 4.1.3 but is still a VALID bug for Busybox
1.10.2 in Fremantle SDK alpha?
Comment 15 Lucas Maneos 2009-03-23 19:40:59 UTC
Yes, I guess the option slipped through the cracks.
Comment 16 Eero Tamminen nokia 2009-03-24 16:34:01 UTC
(In reply to comment #14)
> Lucas: So this was FIXED for Diablo 4.1.3 but is still a VALID bug for Busybox
> 1.10.2 in Fremantle SDK alpha?

It would be better to have a separate bug because this bug was fixed in Diablo,
for the Diablo version of Busybox and the new bug is in Fremantle, in the
Fremantle version of Busybox...
Comment 17 Andre Klapper maemo.org 2009-03-24 17:29:17 UTC
Cloned as bug 4237 for Fremantle.
Closing this one.