Bug 303 - (int-79364) Clock should allow configurable 12h/24h display
(int-79364)
: Clock should allow configurable 12h/24h display
Status: RESOLVED FIXED
Product: Utilities
Clock
: 4.0
: All All
: Medium enhancement with 30 votes (vote)
: 5.0 (1.2009.41-10)
Assigned To: Quim Gil
: clock-bugs
:
: enhancement-it2005
:
: 463
  Show dependency tree
 
Reported: 2005-11-28 17:30 UTC by Andrew Flegg
Modified: 2010-11-22 17:23 UTC (History)
9 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Andrew Flegg (reporter) maemo.org 2005-11-28 17:30:17 UTC
The clock application bases its display of a digital clock in 12/24 hour format
on the current locale.

This should be a separate configuration issue as, despite being in the UK, I
would like a 24h clock displayed.
Comment 1 Neil MacLeod maemo.org 2006-01-22 01:09:39 UTC
I'm in the UK too, and I find the inability to specify a 24 hour clock setting
insane in the extreme - if I choose another language, such as Netherlands, I can
have a 24 hour clock! There is absolutely no way that the default clock format
should be a property of the language.
Comment 2 Jussi Kukkonen 2006-01-24 13:47:30 UTC
(In reply to comment #1)
> I'm in the UK too, and I find the inability to specify a 24 hour clock setting
> insane in the extreme - if I choose another language, such as Netherlands, I can
> have a 24 hour clock! There is absolutely no way that the default clock format
> should be a property of the language.

You've mixed up language and region. I just tried, and clock settings are based
on region-locale ("Your region" in the control panel), not language. This is a
standard way to set default time/date settings, isn't it?

This does not invalidate the original bug in Comment 0.
Comment 3 Neil MacLeod maemo.org 2006-01-24 14:48:13 UTC
(In reply to comment #2)
> (In reply to comment #1)
> You've mixed up language and region. I just tried, and clock settings are based
> on region-locale ("Your region" in the control panel), not language. This is a
> standard way to set default time/date settings, isn't it?
> 
> This does not invalidate the original bug in Comment 0.

You're right - it is Region and not Language, I should never trust my memory!

So, by switching Region from English (United Kingdom) to Netherlands I can get a
24 hour clock, but by choosing my correct Region (UK) I'm stuck with a 12 hour
clock.

Using the users Region is the standard way to determine TIMEZONE but never clock
display format (ie. 12/24 hour), as far as I'm aware. My comment supports
comment 0, as the clock display format should be a seperate configuration item
and has nothing to do with the current Region setting - choosing Netherlands as
a region in order to force 24 hour format was simply intended to highlight and
demonstrate the absurdity of the current situation. :)
Comment 4 Maemo QA (deprecated) 2006-05-03 14:05:50 UTC
Claiming ownership.
Comment 5 Maemo QA (deprecated) 2006-05-03 14:09:23 UTC
Re-tested with latest product image (2006-13). The digital clock 12/24 hour
mode
is indeed bound to the region.
Comment 6 Neil MacLeod maemo.org 2006-05-04 03:25:47 UTC
(In reply to comment #5)
> Re-tested with latest product image (2006-13). The digital clock 12/24 hour mode
> is indeed bound to the region.

Hi Maemo QA - does this mean this is accepted as a bug/enhancement and will be
corrected in a future release? You may also be interested in bug #463 which
addresses the date format.

Basically, both time (12/24h) and date (dd/mm/yyyy or mm/dd/yyyy etc) format
should be configurable irrespective of region or language.
Comment 7 Maemo QA (deprecated) 2006-05-04 10:28:22 UTC
(In reply to comment #6)
> Hi Maemo QA - does this mean this is accepted as a bug/enhancement and will be
> corrected in a future release? You may also be interested in bug #463 which
> addresses the date format.

Actually, the feature enhancement hasn't yet been forwarded to upstream
maintainer, but it will as soon as all old bugs in NEW state have been handled
(sorry, some prioritization must be done). This will take some time I'm afraid,
approx 1-2 weeks. The bug report is in ASSIGNED state because the feature
enhancement has been noted and will be forwarded/handled ASAP.

Don't worry, I will keep you and everyone else informed when your and everyone
else's feature enhancements have been forwarded and if it has been approved or not.
 
> Basically, both time (12/24h) and date (dd/mm/yyyy or mm/dd/yyyy etc) format
> should be configurable irrespective of region or language.

I will forward this request as well. The date format issue has also been noted.
Comment 8 Maemo QA (deprecated) 2006-05-22 15:35:00 UTC
Feature request has been forwarded to upstream maintainer.
Comment 9 Andrew Flegg (reporter) maemo.org 2007-01-27 16:24:49 UTC
On 1/26/07, Jakub.Pavelek@nokia.com <Jakub.Pavelek@nokia.com> wrote:
>
> This is based on your country's way of handling it. US/UK will get you
> the AM/PM way, other countries usually use the 24 hour system.

I still can't believe this bug is still here in OS 2007. It was reported
shortly after OS 2005 was released: whoever's drawing up your specs
has made an *enormous* assumption here, which happens to be incorrect.

Apart from the fact it should be user choice, the UK does *not* run on
12 hour clocks. Looking around me I see 24-hour clocks on:

 * my computer
 * my media player
 * my mobile phone
 * my camera
 * my STB
 * my VCR
 * TV listings

I also see them every day at the train station. I probably see more
24-hour clocks than I do 12, and I'm in the UK.

THIS SHOWS A SERIOUS LACK OF I18N/L10N AWARENESS: you can't assume
region/country => 12/24 hour format. You just can't.

Trust me, and other UK users, this "feature" is Just Plain Wrong.
Comment 10 Quim Gil nokia 2007-03-15 11:44:33 UTC
Picking this one.
Comment 11 Mike Lococo 2007-03-26 19:05:39 UTC
I'm pasting this comment
(http://maemo.org/pipermail/maemo-users/2007-March/004650.html) from Quim.Gil
(Nokia community rep), which summarizes the plan for addressing this bug:

----------------------------------------------------------------------------

Hi, thanks for this report.
 
 > Nokia, get rid of the warning each time a non-Nokia application is installed
saying we
Comment 12 mathew 2007-03-26 21:47:02 UTC
(In reply to comment #11)
> It is important from a legal and commercial perspective that users
> accept explicitely each time they install non-supported software. This is 
> normal practice in operating systems covered by an end-user software 
> agreement.

Does Windows throw up a warning message when you install non-Microsoft software? No.

Does Mac OS X throw up a warning message when you install non-Apple software? No.

Does Palm OS throw up a warning message when you install non-Palm software? No.

Hence I deduce that there is no technical or legal requirement to do so.
Frankly, it's disappointing to have such threadbare excuses offered.

> a) Even if it sounds incredible we are following POSIX standards, and we did
> not create them.

OK, so how about telling me how to install my own POSIX locale definition on the
N800? I've got one ready.
Comment 13 Mike Lococo 2007-03-26 22:05:47 UTC
(In reply to comment #12):
I should have pasted only the bits of Quim's comment relevant to this bug. 
Please open a new bug for discussion regarding the behavior of application
manager, as it does not relate to the 12/24 clock enhancement requested here.
Comment 14 Quim Gil nokia 2007-03-27 00:27:14 UTC
Matthew, as far as I know there is no simple (possible?) way to install your 
own POSIX locale definition and make it work in maemo as it is today. We rather 
invest our time making the changes needed in the platform so regular users can 
define specific details about their own locale.

I can't tell officially, but I'd say this feature request will be satisfied one 
day (not soon). In the meantime don't expect much moves from our side, although 
we will be working on this. Sorry, our resources are not unlimited and we need 
to put priorities.

Thanks for your understanding.
Comment 15 mathew 2007-03-27 20:51:57 UTC
(In reply to comment #14)
> Matthew, as far as I know there is no simple (possible?) way to install your 
> own POSIX locale definition and make it work in maemo as it is today. 

Well, that pretty much destroys the "We're following POSIX" excuse then, doesn't it?

Ah well. You're right that there are more important things to work on. It just
seems like this would be something that could be improved quickly and crossed
off the list.
Comment 16 Quim Gil nokia 2007-03-29 07:57:18 UTC
The POSIX thing is not an excuse. Last time I write this down.

As far as I know in order to define your own locale definition you need to go
through Nokia closed source software. If this is true , it would be the reason
why you can't do this alone. I could be totally wrong. I will ask the right
developer in order to know exactly.

Note that our priority is not to help a couple of power users hacking the device
in order to get their expected result. Instead, we want to work in proper UI
functionality to let all users define their locale preferences.

As said, it's not in top of our current priorities, though. This is not an
excuse either, and I won't insist again if you don't mind.
Comment 17 Quim Gil nokia 2007-03-29 12:03:28 UTC
Right. The Nokia closed source is an obstacle only if you want to produce
yourself a dialog to select the 12/24h option in the UI.

Nothing stops you from modifying the posix-locales. The package is in the stage
repository. One could "just" edit the locale file and rebuild the package. This
"just" is not simple at all for a regular user, not even for power users. We
will publish a mini HowTo in maemo.org.

I will report here about bringing the functionality to select the 12/24h
preference as soon as there are news.
Comment 18 Quim Gil nokia 2007-03-30 10:46:16 UTC
Conclusions:

- Our plan is to allow users to select not only 12/24h but most (all?) of their
locale definition through a proper UI in the Settings. This would include
setting preferences for date formats, currencies, sorting types...

- This is not going to happen in the short term, but our plan is to make it
happen in the mid term. This will appear in the public roadmap at maemo.org as
soon as it's confirmed.

- It is technically possible (and actually trivial) to hack posix-locales to
modify the default POSIX configuration for 12/24h associated to i.e. UK.
However, this doesn't solve the problem globally since each system component and
application showing time should also be hacked accordingly in order to get a
consistent result across the system from a user point of view. This is why we
are not going through this (dirty) path even if it wouldm provide a quicker
solution.

- We will set up a wiki page explaining how to do this hack, so people *really*
needing this can go and try themselves. This solution is not targeted to end
users since it requires some experience and a development setting. Needless to
say that this option will not be supported officially at all, we will only
explain HowTo, and then the community will be able to improve the document as
much as you want.

- The good and proper solution would take too much resources if it would be
implemented today. While selecting 12/24h in a desktop is trivial, the resources
this selection swallow in the system are too expensive for the current tablets.
It would seriously compromise a 770 and it would create noticeable delays in a
N800. This is why it's out of question for us not to implement the good solution
at least while we don't find or build better ways not compromising the system
performance.

- The argument of Windows mobile devices, old Palms or Nokia phones allowing
this functionality is valid from a user point of view, but it is not that useful
from a technical perspective, since none of these devices have orperating
systems relying on the POSIX standards, which are the root of the problem for
the 12/24h thing. It might be interesting to investigate how the recent Palms
deal with this but, really, I have invested already enough time with trying to
answer properly this feature request.

Hopefully everything is clearer now. Tagging this feature request as LATER.
Comment 19 Mohammad Anwari maemo.org 2007-04-02 11:37:23 UTC
(In reply to comment #18)
> - It is technically possible (and actually trivial) to hack posix-locales to
> modify the default POSIX configuration for 12/24h associated to i.e. UK.

Yes.

> However, this doesn't solve the problem globally since each system component and
> application showing time should also be hacked accordingly in order to get a
> consistent result across the system from a user point of view. This is why we
> are not going through this (dirty) path even if it wouldm provide a quicker
> solution.

Well, the good news is that the above statement is not true. Just follow the
HOWTO below and all applications shall honor the modification you made.
(Otherwise it's a bug).

The above statement is valid if the changes we make is not in the posix locale,
but in the language and regional applet, e.g. add a setting of choice (12/24
hours format) which saves the setting into gconf. Then all applications must
read this setting. But for the case of modification of the posix-locales,
modification in application side is not needed.

> - We will set up a wiki page explaining how to do this hack, so people *really*
> needing this can go and try themselves. This solution is not targeted to end
> users since it requires some experience and a development setting. Needless to
> say that this option will not be supported officially at all, we will only
> explain HowTo, and then the community will be able to improve the document as
> much as you want.

The HOWTO is here:
http://maemo.org/maemowiki/HowToEditPosixLocaleData
Comment 20 Ralph B 2007-09-17 18:18:38 UTC
I am surprised to see no mention of a simple workaround for this problem,
namely setting LC_TIME=de_DE in /etc/osso-af-init/locale.

After a reboot, this results in 24hr clock display, but preserves other
regional settings (decimal point, 1000s separator etc).

Note that changes to /etc/osso-af-init/locale are overwritten if regional
settings are later changed via the GUI.
Comment 21 Martin 2008-01-06 21:56:55 UTC
I'm astonished -- as were the staff at my local Nokia service point -- that
this bug made it unfixed into OS2008.

It really dents Nokia's reputation (especially when the forced 12-hour mode
doesn't display correctly by UK conventions -- see bug 2721).

If independent control of the 12/24h mode is so hard, surely it'd be better as
a temporary fix to force 24h mode? That's what UK folk would expect if the mode
is not switchable.

Have you thought of this solution? Rename the current "English (UK)" locale to
"English (UK)(12hr)" and supplement it with an additional one, "English
(UK)(24hr)"?

Ralph B's workaround is beyond my skills, I'm afraid, and the
HowToEditPosixLocaleData assumed more than apt for me. I was visited by the
whoosh bird at the mention of "Fully working scratchbox installation" and when
I clicked on the very first link in the narrative it led to a 404ing page.
Anyone care to write a dummies guide to the workaround?
Comment 22 Andrew Flegg (reporter) maemo.org 2008-01-12 17:30:38 UTC
Reopening bug, the LC_TIME fix is sub-optimal as some applications (such as GPE
Calendar) use this when displaying day names - and although this could be an
opportunity for me to learn the German days of the week, I'd rather the device
worked as expected.

There are three options for fixing this:

1) Provide the (promised) GUI to allow editing locale data when the POSIX
definition is obviously wrong, or not to the user's preference (e.g. the
mistake with the UK using 12-hour clocks[1]).

2) Provide two UK locales, one for 12-hour, one for 24-hour.

3) Fix the UK locale - and any others - to use 24-hour clocks.

There are other options:

a) Close as WONTFIX. A perfectly valid option, but one which won't go down
well, of course.

b) Explain how a third party developer can fix the UI to implement (1) above,
and the community will provide the patch for Nokia to merge[2].

This bug has been present in all IT OSes since OS 2005. Users are saying it's
wrong; but it's broken by design so goes unfixed. The source isn't open, so the
community can't provide a real fix which will ship with the device.

Footnotes:

[1] Of course, if you can point us to an open POSIX bug tracker, we can raise
it there too.
[2] It may still be the case that not enough of IT OS' UI is open enough to
allow this. This'd be a shame: Nokia's IP in this regard really isn't that
valuable, and by keeping it closed it ensures that Nokia are the only ones who
can provide the fix here.
Comment 23 Randall Arnold 2008-04-25 00:54:50 UTC
Any updates on this, maemo team?

The language and regional settings peculiarities (numerous bugs and feature
requests along these lines) are becoming sort of an old joke.  There has been
some improvement (yay diablo!) and I understand prioritization completely, but
why can't, say, 10% of the development time be allocated to these
highly-demanded-and-fairly-easy-to-fix-low-hanging-fruits?
Comment 24 Andre Klapper maemo.org 2008-05-26 14:39:39 UTC
so from the UI point of view this is basically adding another checkbox in the
"date and time" dialog of the control panel.
quim, who's in charge of this? this really looks like low hanging fruit and has
lots of votes.
Comment 25 Neil MacLeod maemo.org 2008-05-26 16:26:57 UTC
(In reply to comment #24)
> so from the UI point of view this is basically adding another checkbox in the
> "date and time" dialog of the control panel.
> quim, who's in charge of this? this really looks like low hanging fruit and has
> lots of votes.
> 

Well yes, that's the bare minimum required to fix this bug although in reality
implementation of the solution outlined in comment #18 is essential to bring IT
OS in line with other handheld operating systems (comment #18 would also fix
bug #463).
Comment 26 Vincent Lefevre 2008-05-28 04:21:00 UTC
My current workaround is to edit /etc/osso-af-init/locale to add:
export LC_TIME=fr_CA
(my other locales being fr_FR) so that I can have ISO-8601 dates with French
weekdays. Unfortunately, it is not possible to have an ISO-8601 date with
English weekdays; this is normally done by using en_DK, but this locale isn't
provided.
Comment 27 Quim Gil nokia 2008-06-11 08:53:35 UTC
Some news: 

- The clock configuration will work in Fremantle in the way Andrew described in
the first comment. 

- The configuration at system level discussed later in the thread is much more
complex to solve. The plan is to have this in place for Harmattan.
Comment 28 Ryan Abel maemo.org 2008-06-11 11:43:47 UTC
Setting target milestone according to comment #27.
Comment 29 Bradley Kieser 2008-11-03 00:47:42 UTC
Sorry to be negative but not having 24 clock and proper international standard
dates for UK is really bad.

Should be able to choose:

HH:mm:SS YYYY-MM-DD
Comment 30 Andre Klapper maemo.org 2008-11-18 12:27:19 UTC
Closing as FIXED for Fremantle.

Quoting the UI designer: "In Fremantle there will be a GCONF value for the time
display setting that apps can read."
Comment 31 Neil MacLeod maemo.org 2008-11-18 15:37:56 UTC
(In reply to comment #30)
> Closing as FIXED for Fremantle.
> Quoting the UI designer: "In Fremantle there will be a GCONF value for the time
> display setting that apps can read."

This may be a question with an obvious answer but will the Control Panel UI in
Fremantle allow users to select their preferred time format (12 or 24 hr)
irrespective of region/local/language etc.? It's great that the time format
will be configurable via GCONF, but it would be pretty pointless if UK users
are still forced to accept a 12hr format in the UI.
Comment 32 Richard Zak 2008-11-18 15:39:51 UTC
(In reply to comment #31)
> (In reply to comment #30)
> > Closing as FIXED for Fremantle.
> > Quoting the UI designer: "In Fremantle there will be a GCONF value for the time
> > display setting that apps can read."
> 
> This may be a question with an obvious answer but will the Control Panel UI in
> Fremantle allow users to select their preferred time format (12 or 24 hr)
> irrespective of region/local/language etc.? It's great that the time format
> will be configurable via GCONF, but it would be pretty pointless if UK users
> are still forced to accept a 12hr format in the UI.
> 

Agreed, I second that.  I'm in the USA and I can't stand the 12hr clock.
Comment 33 Andrew Flegg (reporter) maemo.org 2008-11-18 16:29:24 UTC
(In reply to comment #31)
> 
> This may be a question with an obvious answer but will the Control Panel UI in
> Fremantle allow users to select their preferred time format (12 or 24 hr)
> irrespective of region/local/language etc.? It's great that the time format
> will be configurable via GCONF, but it would be pretty pointless if UK users
> are still forced to accept a 12hr format in the UI.

I'm not *too* worried about that (can always knock up our own Control Panel
applet). However, will *all* the time displaying applications in Fremantle take
note of this flag?
Comment 34 Andre Klapper maemo.org 2008-11-18 16:32:07 UTC
Sorry, I myself only know what's been written in comment 30.
Comment 35 Andrew Flegg (reporter) maemo.org 2008-11-18 16:42:44 UTC
(In reply to comment #34)
> Sorry, I myself only know what's been written in comment 30.

Perhaps the Nokia devs could grace us with their presence? :-)
Comment 36 Quim Gil nokia 2008-11-19 11:08:34 UTC
Yes, users can define the 12h/24h setting from the control pannel regular UI.

Yes, the setting selected should rule over whatever default your locale brings.

Just as in the rest of Nokia products.
Comment 37 Chris Pitchford 2009-03-20 14:11:34 UTC
(In reply to comment #36)
> Yes, users can define the 12h/24h setting from the control pannel regular UI.
> 

Where exactly? it must be very well hidden. 

Language and region: Only configurable items are Device language and regional
settings. Both are a drop-down list.. Neither mentions time.. In the summary at
the bottom, the nearest is date format.. and even that isn't configurable.. 

Date and Time: the only option is to change the date and time, not their format

I have a Nokia 770, n800 and an n810.. These devices are litterally the only
devices I own that do not allow me to change to 24hour clocks. I've never had
this problem with a Nokia device (though my first nokia handsets didn't
actually have a clock facility)

> Yes, the setting selected should rule over whatever default your locale brings.
> 
> Just as in the rest of Nokia products.
>
Comment 38 Ralph B 2009-03-20 14:45:39 UTC
(In reply to comment #37)
> (In reply to comment #36)
> > Yes, users can define the 12h/24h setting from the control pannel regular UI.
> > 
> 
> Where exactly? it must be very well hidden. 

You're right. I can't find it either.

I can only assume that since the Target Milestone is "Fremantle" it has been
fixed, but not yet released.
Comment 39 Andre Klapper maemo.org 2009-03-22 13:01:06 UTC
(In reply to comment #37)
> Where exactly? it must be very well hidden. 
> Language and region: Only configurable items are Device language and regional
> settings.

Comment 36 answers comment 31 and refers to Fremantle *only*. This is still a
valid bug for Diablo, but most probably WONTFIX for Diablo as Nokia seems to
have different priorities currently. Such fixes might become available and
backported for Diablo through the Mer project.
Comment 40 Andrew Flegg (reporter) maemo.org 2010-11-22 17:23:22 UTC
For those interested in MeeGo, the Netbook UX suffers from a similar issue:
http://bugs.meego.com/show_bug.cgi?id=10310