Bug 3018 - PGP/MIME message body not shown
: PGP/MIME message body not shown
Status: RESOLVED DUPLICATE of bug 3369
Product: Email
General
: 4.0
: All Linux
: Low normal (vote)
: ---
Assigned To: unassigned
: modest-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-03-10 14:51 UTC by Tilman Vogel
Modified: 2008-12-06 15:23 UTC (History)
2 users (show)

See Also:


Attachments
Email of which the plain text body is not shown in modest. (1.11 KB, text/plain)
2008-03-10 14:52 UTC, Tilman Vogel
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Tilman Vogel (reporter) 2008-03-10 14:51:12 UTC
SOFTWARE VERSION:
1.0-2008.10-1

STEPS TO REPRODUCE THE PROBLEM:
1) Send an email to your account using PGP/MIME format, e.g. with Mozilla
Thunderbird and the Enigmail extension. 

2) Open this email in modest.

EXPECTED OUTCOME:

The message body (text/plain, ...) part of the message is shown in modest.

Signature (application/pgp-signature) part of the message is not checked (as
long as there is no full-blown openpgp on maemo -- hopefully it will be there
soon)

ACTUAL OUTCOME:

The message body is not shown either.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

The exact format of problematic messages is

Content-Type: multipart/signed; micalg=pgp-sha1;
protocol="application/pgp-signature"

I am going to attach an example raw email for verification.

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.12)
Gecko/20080203 SUSE/2.0.0.12-0.1 Firefox/2.0.0.12
Comment 1 Tilman Vogel (reporter) 2008-03-10 14:52:52 UTC
Created an attachment (id=738) [details]
Email of which the plain text body is not shown in modest.
Comment 2 Andre Klapper maemo.org 2008-09-29 16:43:36 UTC
Tilman:
The current implementation of the message viewer only allows to show one
mime part at a time if I'm not wrong, and the other text/plain is not shown
because its mime type is not considered as an attachment by modest.

I think this is another duplicate of bug 3369 - Sergio, am I right?
If so, I should change bug 3369 and its internal representation to a general
bug called "Modest only displays one mime part at a time"...
Comment 3 Andre Klapper maemo.org 2008-11-22 03:23:49 UTC
(In reply to comment #2)
> I think this is another duplicate of bug 3369 - Sergio, am I right?

Sergio: ping
Comment 4 Sergio Villar Senin 2008-11-22 15:36:55 UTC
I'm OK with the solution you propose Andre
Comment 5 Andre Klapper maemo.org 2008-11-22 16:49:48 UTC
Code-wise duplicate (not symptom-wise).

*** This bug has been marked as a duplicate of bug 3369 ***