Bug 3003 - curl default cert-bundle
: curl default cert-bundle
Status: RESOLVED INVALID
Product: Desktop platform
general
: 2.2
: N810 Linux
: Medium normal (vote)
: ---
Assigned To: Carlos Guerreiro
: HAF QA mailing list
:
:
:
:
  Show dependency tree
 
Reported: 2008-03-03 23:26 UTC by Jim Dannemiller
Modified: 2008-11-18 15:16 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Jim Dannemiller (reporter) 2008-03-03 23:26:30 UTC
SOFTWARE VERSION: 2.2007-2
(Control Panel > General > About product)

STEPS TO REPRODUCE THE PROBLEM: curl -v https://s3.amazonaws.com:443

EXPECTED OUTCOME: curl verifies the amazonaws certificate

ACTUAL OUTCOME: curl fails to do this because it doesn't find the
curl-ca-bundle.crt file in /etc/ssl/certs

REPRODUCIBILITY: always
(always/sometimes/once)

EXTRA SOFTWARE INSTALLED: curl, openssl

OTHER COMMENTS:  If you pass the location of the certs bundle explicitly on the
command line like this:

curl -v --cacert /etc/ssl/certs/curl-ca-bundle.crt https://s3.amazonaws.com:443

then the certificate gets verified correctly. So I thought that curl would look
for this file by default, but apparently you have to tell it to do so on the
command line.

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12)
Gecko/20080207 Ubuntu/7.10 (gutsy) Firefox/2.0.0.12
Comment 1 Danny Milosavljevic 2008-07-31 20:08:29 UTC
try "strace curl -v https://s3.amazonaws.com:443" to see where it tries to get
it from by default.
Comment 2 Andre Klapper maemo.org 2008-11-18 15:16:29 UTC
In Diablo (4.1), curl (libcurl3) is not official part of the platform, hence
this bug is INVALID (at least nowadays).
Please contact the package maintainers if this is still an issue in Diablo.