Bug 3001 - it is not possible to programmatically call virtual keyboard
: it is not possible to programmatically call virtual keyboard
Status: RESOLVED WORKSFORME
Product: Desktop platform
Input method framework
: 3.2
: N800 Maemo
: High enhancement (vote)
: ---
Assigned To: Mohammad Anwari
: input-method-framework-bugs
:
: moreinfo
:
:
  Show dependency tree
 
Reported: 2008-03-03 10:56 UTC by mikmach
Modified: 2009-01-25 17:14 UTC (History)
6 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description mikmach (reporter) 2008-03-03 10:56:12 UTC
It is not possible to programmaticallly call virtual keyboard.

This is major problem with fast input of data. I have to open dialog, tap input
line and only after that I can write.

This is excerpt from correspondence with Gene Cash, author of widely appraised
PIM for N800:

> Is it possible to automatically focus on Amount and raise virtual
> keyboard to enter digits instantly?

I wish! This is a major bug. I can focus on the entry box and I've tried
a bunch of things (like faking a click event on it) but I've never been
able to programmatically bring up the keyboard. Very annoying. I spent a
lot of time on it.

Homepage of programs:
http://home.cfl.rr.com/genecash/nokia/index.html

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.1.12)
Gecko/20080201 Firefox/2.0.0.12
Comment 1 Andre Klapper maemo.org 2008-09-15 17:36:41 UTC
I assume this is still an issue on Diablo (4.2008.30-2)?
Comment 2 Andre Klapper maemo.org 2008-11-18 15:24:00 UTC
Please provide a step by step how-to for the latest Diablo release
(4.2008.36-5) so I can try to reproduce this.

If I understand correctly this is a testcase? If so, please confirm:

1. Start browser with default home page
2. See that input focus is in the Google search field

EXPECTED:
Virtual keyboard automatically displayed

ACTUAL OUTCOME:
Need to click into the search field again to get the virtual keyboard displayed
Comment 3 Eero Tamminen nokia 2008-11-24 17:07:55 UTC
Andre, this is a request for a programming API for invoking the virtual
keyboard.

If some text input is always needed by the application, why user would first
need to tap to a field to get input method?
Comment 4 Quim Gil nokia 2008-12-25 14:57:05 UTC
This request seems to be sensible. Is there anything like this contemplated in
the Fremantle/Harmattan plans?
Comment 5 Eero Tamminen nokia 2008-12-29 11:44:46 UTC
It might be possible to get this programmatically by explicitly setting the
focus to an (other) input widget *after* the dialog has been realized (i.e. in
idle callback I guess).
Comment 6 benson 2009-01-05 04:56:35 UTC
Doesn't osso-xterm do this now? On starting xterm, the stylus keyboard is open,
and if it's manually closed, clicking Ctrl in the toolbar causes it to reopen.

Would the way it's done there not satisfy this enhancement?
Comment 7 Mohammad Anwari maemo.org 2009-01-05 11:08:58 UTC
The input method shall be able to be shown programmatically by giving mouse
button press and release event.

More on this can be studied from the source code (look in
hildon_im_context_filter_event() function):
https://stage.maemo.org/svn/maemo/projects/haf/trunk/hildon-input-method-framework/src/hildon-im-context.c

Please try it and confirm the (un)success.
Comment 8 Quim Gil nokia 2009-01-06 17:48:30 UTC
Comments from Mohammad and Eero suggest that this is a WORKSFORME.

Can mikmach or anybody give it a try?
Comment 9 Quim Gil nokia 2009-01-25 17:14:59 UTC
Resolving as WORKSFORME. Please reopen if you have good reasons.