Bug 2984 - Extract data from the rootfs of a reboot-looping device
: Extract data from the rootfs of a reboot-looping device
Status: RESOLVED DUPLICATE of bug 6720
Product: Flasher
Linux
: 5.0-beta2
: All Linux
: Low enhancement with 3 votes (vote)
: ---
Assigned To: unassigned
: flasher-linux-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-02-26 00:26 UTC by David Hagood
Modified: 2009-12-20 00:23 UTC (History)
6 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description David Hagood (reporter) 2008-02-26 00:26:25 UTC
Use case:
Device has been bricked for some reason. User wishes to salvage something of
the system before reflashing.

Flasher program should, if possible, have the option to dump the current rootfs
image to the PC. Then the user could mount the rootfs image and extract any
information.

Additionally, extracting the information might allow for capturing why the unit
is bricked.
Comment 1 Quim Gil nokia 2008-12-29 16:37:20 UTC
Changing summary to make it more clear.
Comment 2 Ryan Abel maemo.org 2008-12-30 02:30:09 UTC
(In reply to comment #1)
> Changing summary to make it more clear.
> 

"Bricked" is significantly less clear here, as "bricked" means totally
unrecoverable, not reboot-looping but reflashable. The original summary is
really more appropriate, but how about a compromise?

Anyway, Carsten Munk was looking into something like this for a new bootmenu.
Comment 3 Lucas Maneos 2008-12-30 16:25:18 UTC
This would be very useful to have, but has security implications (ie retrieval
of private data including account passwords etc from a stolen device).

One way around it might be to require the device lock code in order to retrieve
the rootfs (if nolo is able to retrieve lock_code from mtd1 and the flasher
protocol allows for sending it down the wire), preferably with a delay before
accepting further commands on failure to make brute forcing impractical.

It may already be a lost cause however: I was recently able to recover an n810
by creating a bootmenu+ssh initfs on a healthy tablet and flashing it on the
reboot-looping one.
Comment 4 David Hagood (reporter) 2008-12-30 17:19:39 UTC
I wouldn't be too worried about the security implications of this: the first
rule of computer security is "If the bad guys have physical control of the
system, you have lost."

Things like password locks are designed to prevent somebody with brief access
from getting into the device: somebody from getting in to the device while you
are in the shower at the gym, for example. If they have enough time to whip out
a laptop, hook up a USB cable, reboot the device, hold the HOME key down, and
suck down the file system, then reboot the device again back into its previous
state, all without raising eyebrows - well, they probably just lifted your
wallet instead.
Comment 5 Andre Klapper maemo.org 2009-03-24 15:46:18 UTC
While the idea is interesting I don't expect anyone to work on this (other
priorities), so it might be a WONTFIX from Nokia's point of view.
Pity that Flasher is not open source afaik, otherwise people could come up with
patches. :-/
Comment 6 Eero Tamminen nokia 2009-03-24 18:11:43 UTC
> While the idea is interesting I don't expect anyone to work on this (other
> priorities), so it might be a WONTFIX from Nokia's point of view.

From my point of view it could be kept open. I think the idea is useful (for
both of the presented reasons) although nobody's been working on it yet.
Comment 7 Josh Triplett 2009-12-15 04:45:27 UTC
In trying to debug bug 6350, I had this same desire.  Reflashing the rootfs
unwedges the device, but before doing so for the second time I'd like to grab
the current rootfs and figure out what broke.
Comment 8 Josh Triplett 2009-12-20 00:23:38 UTC
Marking this as a duplicate of bug 6720, as they both seem to describe the same
desire: reading data *from* the device over USB in the pre-booted state.

*** This bug has been marked as a duplicate of bug 6720 ***