Bug 296 - Audio player encodes urls twice
: Audio player encodes urls twice
Status: CLOSED FIXED
Product: X-Discontinued
Audio player (770)
: 1.0
: All Maemo
: Medium normal (vote)
: ---
Assigned To: Maemo QA (deprecated)
: audio-player-bugs
: https://maemo.org/bugzilla/show_bug.c...
:
:
:
  Show dependency tree
 
Reported: 2005-11-26 14:12 UTC by René Seindal
Modified: 2008-12-06 16:21 UTC (History)
0 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description René Seindal (reporter) 2005-11-26 14:12:58 UTC
This bug was mentioned in bug 131 bug apparently doesn't belong there.

The audio player (or maybe the underlying gnomevfs) url-encodes the urls from a
playlist twice, thus making requests for non-existant files.

If my playlist contains the url
http://music.local.seindal.dk/Atomic%20Kitten/Single%20Tracks/Whole%20Again.mp3

I find this in my access logs
192.168.99.160 - - [26/Nov/2005:00:06:38 +0100] "GET
/Atomic%2520Kitten/Single%2520Tracks/Whole%2520Again.mp3 HTTP/1.1" 404 1158 "-"
"gnome-vfs/2.8.4.11 neon/0.24.6" 0 music.seindal.dk

and hence the audio player requests the url
http://music.local.seindal.dk/Atomic%2520Kitten/Single%2520Tracks/Whole%2520Again.mp3

Note how the %20 (space) becomes %2520 (three characters % 2 0).

The audio player skips the entries because it gets Not Found responses from the
web server and therefore thinks the playlist is in error.

My tablets used to run 2005.42-9 and today I upgraded to 2005.45-8 but the
problem persists.
Comment 1 Maemo QA (deprecated) 2006-05-02 16:57:31 UTC
Claiming ownership.
Comment 2 Maemo QA (deprecated) 2006-05-03 18:55:26 UTC
I'm unable to reproduce this issue due to missing test environment. Could you
by
any chance re-test this issue with a newer release, like 2005-51 or 2006-13?
Comment 3 René Seindal (reporter) 2006-07-08 16:16:03 UTC
At least with OS2006 the problem has disappeared, and also in 2005-51 I
believe.
Comment 4 Maemo QA (deprecated) 2006-07-10 12:26:43 UTC
Thanks for verifying. Closing bug.
Comment 5 elmano carvalho 2007-07-04 19:27:56 UTC
closed