Bug 295 - Spurious crashes at startup or shortly after
: Spurious crashes at startup or shortly after
Status: RESOLVED WORKSFORME
Product: Connectivity
WiFi
: 1.0
: All Maemo
: Medium normal (vote)
: ---
Assigned To: Maemo QA (deprecated)
: wifi-bugs
: http://linux.seindal.dk/item85.html
: moreinfo
:
:
  Show dependency tree
 
Reported: 2005-11-26 02:10 UTC by René Seindal
Modified: 2007-09-03 06:52 UTC (History)
0 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description René Seindal (reporter) 2005-11-26 02:10:13 UTC
It has happened a couple of times that my Nokia 770 crashed on my three or four
times just after reboot.

The first time it came up, I connected to my wifi and clicked "Refresh" in the
News applet. It went unresponsive and rebooted after a while. The next time I
tried to connect twice and it rebooted again. After several attempts it finally
managed to boot and stay up.

Again today it rebooted before it even got to the home screen.  It never got
further than a white screen before it rebooted.

I do have the load/memory applet installed, which might be a factor.
Comment 1 René Seindal (reporter) 2005-11-27 22:06:48 UTC
I have now upgraded to the lastest image 2005.45-8 and not installed the
load/cpu applet.

Today my Nokia 770 has switched off spontaneously three times.  I've been
experimenting with streaming mp3 to the 770, so two times there nothing
happening on the system except the audio player playing streamed music.  The
third time it device was simply lying on the table and I found it switched off
later.

The last time it was playing music, when the display went all white and the
system completely unresponsive, while the music continued for a while, maybe 30
 seconds, maybe a minute, before the unit switched off.

The battery is not empty, not even low.

It doesn't restart, it just switches off.
Comment 2 Maemo QA (deprecated) 2006-05-02 15:53:22 UTC
Claiming ownership.
Comment 3 Maemo QA (deprecated) 2006-05-02 15:55:12 UTC
Rene, is this still and issue with the latest product image (2006-13)?
Comment 4 Christopher Eklund 2006-06-28 00:50:49 UTC
Rene',

Go to my Bug #611, which is the same thing you're experiencing, and see if it 
might not be that reason or cause that is doing this to you.

Virtual memory being corrupted leading to Unceasing Reboots.

I had to turn off Virtual Memory to get the reboots to stop, but there is 
definitely a bug with the Virtual Memory because it was designed as a file 
instead of folders, and if your system crashes while writing to that file it 
becomes corrupted.  If the VM reader reads over the portion that is corrupted, 
the device resets, so it appears that where its corrupted determines how long 
you can go before it crashes.  In my case, it was about 8 seconds before 
reboot, consistently, unceasingly.
Comment 5 René Seindal (reporter) 2006-06-28 10:31:45 UTC
It is not a problem with 2005-51 which is what I use.

I tried to upgrade to 2006-13 but there were too many problems with the news
reader so I reverted.

As for comment #4, that appears to talk about OS2006.  This bug is about OS2005.
Comment 6 Maemo QA (deprecated) 2006-08-03 16:56:54 UTC
Re-assign
Comment 7 Maemo QA (deprecated) 2006-08-03 17:45:50 UTC
Is this problem still taking place with the final IT 2006 firmware?
Comment 8 Jake Kunnari 2007-07-05 13:52:51 UTC
Testd with IT OS2006 3.2006.49-2. I have used my N770 for a couple weeks and no
crashes.