Bug 2926 - "Network connection error." upon associating with network
: "Network connection error." upon associating with network
Status: RESOLVED FIXED
Product: Connectivity
WiFi
: 4.0
: N800 Maemo
: Low major with 1 vote (vote)
: ---
Assigned To: unassigned
: wifi-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-02-11 22:57 UTC by astro
Modified: 2008-07-28 00:05 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description astro (reporter) 2008-02-11 22:57:41 UTC
SOFTWARE VERSION: RX-34_2008SE_2.2007.50-2

STEPS TO REPRODUCE THE PROBLEM: Try to associate with a wireless network

EXPECTED OUTCOME: Success

ACTUAL OUTCOME: "Network connection error."

REPRODUCIBILITY: always, rebooting helps most of the time, until I want to
associate with another network

Nothing suspicious in dmesg, closed source wifi drivers suck.
EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; A; Linux x86_64; en; rv:1.9b3pre)
Gecko/2008020300 (Gentoo) Firefox/3.0b3pre
Comment 1 Jake Kunnari 2008-02-27 16:07:24 UTC
Please update lastest OS2008 version and try again. And if possible give some
more info about your Wlan access point, what software have you installed to
your device.
Comment 2 Andre Klapper maemo.org 2008-06-10 00:41:39 UTC
astro, can you please answer Jake's questions?
Thanks in advance.
Comment 3 astro (reporter) 2008-06-17 19:28:08 UTC
Situation seems to have worsened with RX-34_2008SE_2.2007.51-3. However, I do
now see the following line alot in the dmesg:
cx3110x: WARNING sm_drv_transmit: prism_softmac_frame_tx()  returned error -9.

Access Points are diverse. One is unencrypted madwifi, others are unknown with
WPA-EAP.
Comment 4 Andre Klapper maemo.org 2008-06-20 14:13:32 UTC
OK, but "diverse" does not help us - Please come up with at least one exact
name and its settings, otherwise it's hard to reproduce. Thanks in advance :)
Comment 5 astro (reporter) 2008-06-22 14:03:38 UTC
The one I can access is a Fon Fonera running OpenWRT with kernel 2.6.23.17 and
Madwifi trunk r3314 as single VAP. Settings below. This one works most of the
time, but not always. WPA networks are much more troublesome.

ath0      IEEE 802.11g  ESSID:"air.sin"  Nickname:""
          Mode:Master  Frequency:2.462 GHz  Access Point: 00:xx:xx:xx:xx:xx   
          Bit Rate:0 kb/s   Tx-Power:17 dBm   Sensitivity=1/1  
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=0/70  Signal level=-96 dBm  Noise level=-96 dBm
          Rx invalid nwid:4873  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
Comment 6 Andre Klapper maemo.org 2008-06-27 15:25:25 UTC
Hmm, having one that never works would be an even better testcase. :-D
Comment 7 astro (reporter) 2008-06-29 05:41:55 UTC
With Diablo Wifi is almost dead. I'm not seeing networks anymore, but nothing
in dmesg.
Comment 8 Andre Klapper maemo.org 2008-06-30 13:00:40 UTC
(In reply to comment #7)
> With Diablo Wifi is almost dead. I'm not seeing networks anymore, but nothing
> in dmesg.

What does "almost" mean? Connection manager does not show *any* networks?
Network itself is running, I assume?
Does running "/etc/init.d/networking restart" as root change anything?
Comment 9 astro (reporter) 2008-06-30 15:59:48 UTC
Does not show *any*. restart networking didn't change anything, as chroot
/mnt/initfs /usr/bin/wlan-cal doesn't either.

I'm going to reflash with OS2007 to check if it's not defective H/W.
Comment 10 astro (reporter) 2008-07-06 18:38:32 UTC
Looks like it's working with reflashed Diablo. What I did differently this time
was: don't restore backup on first boot but later.
Comment 11 Andre Klapper maemo.org 2008-07-14 18:31:27 UTC
Hmm, so the issue is "fixed" for you now?
If so I'd close this but will try to keep it in mind if duplicates get
submitted, so this would be handled correctly (yes, I prefer to have
reproducibility before forwarding issues).
Comment 12 Andre Klapper maemo.org 2008-07-21 14:21:19 UTC
ping :)
Comment 13 astro 2008-07-24 21:17:10 UTC
Thanks for your care. It's not glitch-free (DNS & UI issues), but it working Ok
right now.
Comment 14 Andre Klapper maemo.org 2008-07-25 17:56:06 UTC
Strange and not really satisfying, but closing as FIXED.
Please feel free to file bug reports about the other issues you face. Thanks!
Comment 15 astro (reporter) 2008-07-28 00:05:33 UTC
*Might* be related to
http://tabletschool.blogspot.com/2008/07/nokia-n810-n800-how-to-use-tablets-with.html