Bug 2881 - Restore gives error when /home/user is different partition
: Restore gives error when /home/user is different partition
Status: RESOLVED WONTFIX
Product: Settings and Maintenance
Backup/Restore
: 4.0
: N810 Linux
: Low enhancement (vote)
: ---
Assigned To: unassigned
: backup-restore-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-02-03 15:42 UTC by Graham Cobb
Modified: 2009-04-14 17:24 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Graham Cobb (reporter) maemo.org 2008-02-03 15:42:11 UTC
SOFTWARE VERSION: N810 2.2007.50-2
(Control Panel > General > About product)

STEPS TO REPRODUCE THE PROBLEM:

1) As root, create /etc/osso-backup/applications/grctest.conf containing:

<backup-configuration>
  <locations>
    <location type="dir"
              category="documents">/home/user/.grc</location>
  </locations>
</backup-configuration>

2) As user: mkdir ~/.grc

3) As user: echo hello >~/.grc/test

4) Use the Backup/Restore application to create a backup containing just
Documents

5) rm -rf ~/.grc

6) Try to restore backup you just created.

EXPECTED OUTCOME:

~/.grc/test should be restored

ACTUAL OUTCOME:

Restore creates a dialog box titled "Restore incomplete".  This states "1 kB
restored" (although that is not true) and says:

Restore of following data incomplete
Document files Unknown error

REPRODUCIBILITY: always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

This is a critical problem as it prevents GPE backups working!  Actually it
prevents the restoration working, the backups correctly contain the data (as
can be seen using "unzip -t").  The data in GPE (calendar, contacts, etc.) is
very important for some people.  A backup process which cannot restore the data
is worse than useless as it gives a false sense of security!
Comment 1 Graham Cobb (reporter) maemo.org 2008-02-09 00:51:18 UTC
There is an even easier way to reproduce this...

Backup your documents.  Delete one document and try to restore the backup.  The
same error appears and the deleted document is not restored.
Comment 2 Jake Kunnari 2008-02-12 13:21:57 UTC
Hi, i just tried to reproduce this with following steps:
1. create new note file and save it to Documents folder
2. create new backup which contains just documents
3. delete note file
4. Restore backup
5. Check that note file is restored

Device was N810 and IT OS 2.2007.50-2 and it works just fine.
Comment 3 Graham Cobb (reporter) maemo.org 2008-02-18 20:56:30 UTC
I have done some more testing,  It looks like this problem is due to the way I
have configured my system,

I have /home/user mounted from a partition on the internal memory card (so I
can share it when I boot from different partitions for testing GPE with
different configurations).  The backup/restore seems to work on a default
system, but not when I have /home/user mounted from another partition.

This is, of course, not a supported configuration.  It would be nice if
backup/restore worked in this configuration but I have reduced this report to
an enhancement request.

I have tested that GPE backup and restore both work fine on a default
installation.
Comment 4 Andre Klapper maemo.org 2009-04-14 17:24:25 UTC
As far as I can see, there are currently no plans to support this, sorry.