Bug 2867 - Contacts is unable to import phone book of my cellphone
: Contacts is unable to import phone book of my cellphone
Status: RESOLVED DUPLICATE of bug 2781
Product: Contacts
General
: 4.1 (4.2008.23-14)
: All Linux
: Low enhancement (vote)
: ---
Assigned To: rtcomm@maemo.org
: contacts-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-01-31 15:08 UTC by Marcin Juszkiewicz
Modified: 2008-12-06 15:15 UTC (History)
2 users (show)

See Also:


Attachments
Screenshot in GNOME Evolution (38.74 KB, image/png)
2008-11-13 20:17 UTC, Andre Klapper
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Marcin Juszkiewicz (reporter) 2008-01-31 15:08:01 UTC
SOFTWARE VERSION: 2.2007.50-2 on N810

STEPS TO REPRODUCE THE PROBLEM:

Create 600KB phone book and try to import it.

EXPECTED OUTCOME:

196 entries imported

ACTUAL OUTCOME:

"file too big" message

REPRODUCIBILITY:
always

OTHER COMMENTS:

It should be possible to import such phone book into Contacts application. Few
entries has photos attached (usually VGA size).
Comment 1 J├Ârgen Scheibengruber nokia 2008-01-31 16:04:38 UTC
Yes, there is an arbitrary filesize limit of 500KB for imported files, which is
probably to low, at least if we take into account base64 encoded images in VGA
size. I see no reason why we could not handle this, but at the moment we just
don't.
Comment 2 Marcin Juszkiewicz (reporter) 2008-06-24 17:19:47 UTC
Bug also present in Diablo.
Comment 3 Marcin Juszkiewicz (reporter) 2008-06-24 17:31:41 UTC
Checked with smaller phonebook. Now it has 129738 bytes (208 contacts). Also
not imported.
Comment 4 Marcin Juszkiewicz (reporter) 2008-06-24 17:33:55 UTC
128K is less then 600K so changed title
Comment 5 Marcin Juszkiewicz (reporter) 2008-06-26 14:26:58 UTC
I looked more at problem. Here is an example VCard which does not work:

BEGIN:VCARD
VERSION:3.0
N:ENCODING=QUOTED-PRINTABLE:Strojny;J=F3zef
EMAIL;INTERNET;PREF:ren@example.net
END:VCARD

Looks like problem is in entries which are stored as quoted-printable.

BTW - This VCard was 2.1 when sent from phone.
Comment 6 Quim Gil nokia 2008-07-21 08:20:17 UTC
This report appears in the Bug Jar top 10. Any updates?
Comment 7 Andre Klapper maemo.org 2008-07-21 14:12:04 UTC
(In reply to comment #6)
> This report appears in the Bug Jar top 10. Any updates?

And has 0 votes and was set to high priority by the reporter himself.
Not really high priority.
Comment 8 Andre Klapper maemo.org 2008-09-25 16:02:41 UTC
(Reassigning - this is not an applet bug)
Comment 9 Andre Klapper maemo.org 2008-11-13 20:17:11 UTC
Created an attachment (id=1036) [details]
Screenshot in GNOME Evolution

I've imported the vcard from Comment 5 into GNOME Evolution 2.22.3.1, and it
does not work either.

Might be an upstream bug, or an invalid vcard.
Comment 10 Andre Klapper maemo.org 2008-11-13 20:27:52 UTC
This is not valid.
   N:ENCODING=QUOTED-PRINTABLE:Strojny;J=F3zef
is wrong.
   N;ENCODING=QUOTED-PRINTABLE:Strojny;J=F3zef
would be correct, but even this is not displayed correctly in GNOME Evolution
2.22.3.1.

This is exactly the same issue as bug 2781.

*** This bug has been marked as a duplicate of bug 2781 ***