Bug 2836 - Metalayer crawler doesn't get meta info from all oggs
: Metalayer crawler doesn't get meta info from all oggs
Status: CLOSED WONTFIX
Product: Data
metalayer-crawler
: 4.0
: All Linux
: Low normal with 4 votes (vote)
: ---
Assigned To: Felipe Contreras
: metatracker-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-01-25 18:53 UTC by Tuomas Kulve
Modified: 2009-08-11 20:16 UTC (History)
9 users (show)

See Also:


Attachments
script to get ogg tags and fill in the metalayar-crawler db (1.04 KB, text/x-python)
2009-08-11 20:12 UTC, Nicolau Leal Werneck
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description Tuomas Kulve (reporter) 2008-01-25 18:53:35 UTC
SOFTWARE VERSION:

RX-34+RX-44_2008SE_2.2007.50-2_PR_MR0


STEPS TO REPRODUCE THE PROBLEM:

Download bunch off Oggs to the device's flash or mmc.
Install ogg-support.
Start Media Player
Wait until "Refreshing Library" banner disappears.

EXPECTED OUTCOME:

Metalayer Crawler should get meta infos from all oggs to ~/.meta_storage shown
in the Media Player's Library.


ACTUAL OUTCOME:

Only some oggs has the meta info extracted from the file.


REPRODUCIBILITY:

always


EXTRA SOFTWARE INSTALLED:

ogg-support


OTHER COMMENTS:

Maybe it takes longer to get the meta info from oggs and the Metalayer Crawler
timeouts too soon for Oggs? I haven't figured out any differencies between the
oggs with meta info shown and not shown.
Comment 1 Antony Dovgal 2008-02-21 16:59:35 UTC
I can confirm the issue.
The only difference here is that none of the Oggs are recognised, so they all
appear under "(unknown artist)" section in Media Player, which is very
annoying.
Comment 2 Tuomas Kulve (reporter) 2008-02-21 17:03:59 UTC
(In reply to comment #1)

> The only difference here is that none of the Oggs are recognised, so they all
> appear under "(unknown artist)" section in Media Player, which is very
> annoying.

With how many oggs did you try? I have 174 songs and 142 of them are unknown
(few of them might really be missing the meta data).
Comment 3 Antony Dovgal 2008-02-21 17:07:15 UTC
(In reply to comment #2)
> With how many oggs did you try?

More than a hundred Ogg files, all of them created with oggenc.
Comment 4 Antony Dovgal 2008-02-27 17:51:38 UTC
Are there any plans on opensourcing the crawler?
If you're not going to maintain it and fix its bugs, you can just open the
sources and we'll do it ourselves.
Comment 5 10969001 2008-07-04 05:16:12 UTC
i met this bug too .
Comment 6 Antony Dovgal 2008-07-25 17:24:53 UTC
6 months later, still no changes.
Comment 7 Andre Klapper maemo.org 2008-09-22 16:35:00 UTC
After last weekend's Maemo Summit, it's clear that Nokia is working on an Open
Source replacement for metalayer-crawler based on Tracker, so this bug is
obsolete/invalid for Fremantle.
Hence I also don't expect much Metacrawler bugfixing for Diablo anymore, to be
realistic. This might be frustrating for Diablo users, but ressources are
unfortunately limited.

I'm going to close this report as WONTFIX for Diablo (and INVALID for
Fremantle) soon if nobody has strong objections.
Comment 8 Antony Dovgal 2008-09-22 16:46:29 UTC
(In reply to comment #7)
> After last weekend's Maemo Summit, it's clear that Nokia is working on an Open
> Source replacement for metalayer-crawler based on Tracker, so this bug is
> obsolete/invalid for Fremantle.

Good news at last!

> I'm going to close this report as WONTFIX for Diablo (and INVALID for
> Fremantle) soon if nobody has strong objections.

I can perfectly understand the problem with limited resources, but the fact
that Nokia can't/don't/won't fix the bug is not the biggest issue here.

We would like to get the sources of the crawler so that _the users_ could fix
it themselves and (probably) maintain it in the future.

AFAIK it's unlikely Fremantle will support old hardware, so N800 and N810 users
will have to live with the crawler. And having to live with
half-working/half-b0rked tablet is quite poor option for me.

Do you think it's possible to opensource the crawler and let users support it?
Thanks in advance.
Comment 9 Andre Klapper maemo.org 2008-09-22 17:08:00 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > Nokia is working on an Open Source replacement for metalayer-crawler
> > I'm going to close this report as WONTFIX for Diablo (and INVALID for
> > Fremantle) soon if nobody has strong objections.

> I can perfectly understand the problem with limited resources, but the fact
> that Nokia can't/don't/won't fix the bug is not the biggest issue here.
> We would like to get the sources of the crawler so that _the users_ could fix
> it themselves and (probably) maintain it in the future.
> AFAIK it's unlikely Fremantle will support old hardware, so N800 and N810
> users will have to live with the crawler.
> 
> Do you think it's possible to opensource the crawler and let users support it?


I guess that will be VERY hard and require a lot of (lawyers') work, so don't
expect that to happen. Think of 3rd parties owning that code (though I don't
know in special case of crawler).
Quim might have a better point of view, hence CC'ing him.
Comment 10 Quim Gil nokia 2008-09-23 09:46:20 UTC
I'm happy discussing about the future of Metalayer Crawler as much as I'm happy
discussing about possibilities of having Meta Tracker running in its place on
the N8*0 hardware as well. No idea about the current status and possibilities
on both questions but it's worth asking. Please open a new request and assign
it to me.
Comment 11 Antony Dovgal 2008-09-23 10:04:01 UTC
(In reply to comment #10)
> I'm happy discussing about the future of Metalayer Crawler as much as I'm happy
> discussing about possibilities of having Meta Tracker running in its place on
> the N8*0 hardware as well. 

That would do as well. 
Though I'd guess fixing something should be easier than rewriting it from
scratch.

> No idea about the current status and possibilities
> on both questions but it's worth asking. Please open a new request and assign
> it to me.

Ok, what exactly do you want me to put into the new report?
Comment 12 Quim Gil nokia 2008-09-23 10:15:46 UTC
Nobody is writing anything from scratch. Meta Tracker exists already in Ubuntu
and other distros and Nokia is contributing to make it fit for mobile devices.

Opening and fixing Metalayer Crawler might be way more complicated than
concentrating efforts in open source software maintained and deployed by many
parties including Nokia with a leading role.

Anybody could check now whether Meta Tracker has this bug reported here or not.
And fix it if the bug exists.

On the other hand, it is good to invest the time opening Nokia components to
share the development and maintenance, offer it to other platforms and so on.
I'm not so sure whether the work of opening a component is worth when we are
talking about technologies going to the obsolete path...
Comment 13 Quim Gil nokia 2008-09-23 10:19:12 UTC
PS: Now I remember that Urho Konttori (project manager of the Meta Tracker
implementation in Maemo) commented that they were planning to release it for
Diablo for beta testing. Expect more news soon, after the
http://wiki.maemo.org/Desktop_Search_Hackfest
Comment 14 Antony Dovgal 2008-09-23 10:29:49 UTC
(In reply to comment #13)
> PS: Now I remember that Urho Konttori (project manager of the Meta Tracker
> implementation in Maemo) commented that they were planning to release it for
> Diablo for beta testing.

Cool, thanks for the info.
Comment 15 Tuomas Kulve (reporter) 2008-09-27 11:09:01 UTC
It's also possible that this has nothing to do with the MLC but the ogg plugins
provided by me. I tried to debug them a bit but without any success.

The source codes for all the plugins are now in the ogg-support svn:
http://garage.maemo.org/plugins/scmsvn/viewcvs.php/trunk/?root=ogg
Comment 16 Quim Gil nokia 2008-12-04 09:07:46 UTC
Felipe and I have been discussing this bug and how to move forward.

The first Fremantle SDK release is around the corner. It will come with
Tracker, open source replacement of libmetalayer (dropped). Have a look at it.

Hopefully you will prefer to dance with Tracker. But if you still think that
it's worth to find a solution by hacking on libmetalayer we will make an
internal request to open it. We don't see any serious obstacle to release the
sources, just the amount of work this takes (in these really busy days).

As you might understand we prefer to invest our time opening components still
closed in Fremantle, but if closed libmetalayer would become an obstacle for
community progress then fair enough.
Comment 17 Tuomas Kulve (reporter) 2009-01-19 10:40:40 UTC
(In reply to comment #16)

> Hopefully you will prefer to dance with Tracker. 

I don't see any reasons why not. But only when I have a device with Tracker and
without ogg support :)

> As you might understand we prefer to invest our time opening components still
> closed in Fremantle, but if closed libmetalayer would become an obstacle for
> community progress then fair enough.

I debugged issues further and now I get some of the tags from oggs with
Metalayer Crawler (problem was with the plugins that doesn't send the tags at
all).

With Kilikali I do get all of them but MLC doesn't show the album tag. I added
debug prints to gst and when running th MLC from the command line in foreground
it shows that it gets the tags. But I don't have a clue why it doesn't add them
to meta storage.

If the MLC would be opensource I could debug the reason further. Now I'm
running out of ideas.
Comment 18 Andre Klapper maemo.org 2009-03-26 13:00:20 UTC
Tuomas, are you fine with closing this report as WONTFIX (as metalayer-crawler
is discontinued) and file a new ticket against Meta Tracker if this is still an
issue in the Fremantle alpha SDK?
(I wonder if you can already test this as the Media Player itself is not
available in the alpha SDK)
Comment 19 Tuomas Kulve (reporter) 2009-03-26 13:07:20 UTC
(In reply to comment #18)
> Tuomas, are you fine with closing this report as WONTFIX (as metalayer-crawler
> is discontinued) 

Yes. I filed a bug #4082 that's more proper for this issue anyway (as I don't
know where the problem is).
Comment 20 Andre Klapper maemo.org 2009-03-26 13:12:20 UTC
Thanks!
Comment 21 Tuomas Kulve (reporter) 2009-03-26 13:13:44 UTC
Should I verify the bugs I have reported if I agree with the resolved status?
Comment 22 Andre Klapper maemo.org 2009-03-26 13:32:40 UTC
We don't have a clear policy about that, but it's certainly welcome. :)
Comment 23 Nicolau Leal Werneck 2009-08-10 20:39:05 UTC
That is so sad. I mean, the thing already plays the files, it's just the
TAGS!!!... Bug is around for YEARS. We can't even figure out a hack?

Will it work if I edit .meta_storage by hand? Because I rather have all this
work than moving my stuff to mp3.
Comment 24 Andre Klapper maemo.org 2009-08-10 20:43:17 UTC
> Bug is around for YEARS.

Err... What exactly do you refer to here?
Comment 25 Tuomas Kulve (reporter) 2009-08-10 20:47:28 UTC
(In reply to comment #23)
> That is so sad. I mean, the thing already plays the files, it's just the
> TAGS!!!... Bug is around for YEARS. We can't even figure out a hack?

You can vote in bug #4082. I'm pretty sure we could get the tags working with
open source meta layer crawler.
Comment 26 Antony Dovgal 2009-08-11 10:07:01 UTC
(In reply to comment #23)
> That is so sad. 

So it is.

> Will it work if I edit .meta_storage by hand? Because I rather have all this
> work than moving my stuff to mp3.

Yes, .meta_storage is just an SQLite3 db, so you can let the crawler add Ogg
files to it and then set the tags by hand, this what I do to have proper tags
for my Oggs.
Comment 27 Nicolau Leal Werneck 2009-08-11 20:12:18 UTC
Created an attachment (id=1301) [details]
script to get ogg tags and fill in the metalayar-crawler db
Comment 28 Nicolau Leal Werneck 2009-08-11 20:16:15 UTC
(In reply to comment #26)
> Yes, .meta_storage is just an SQLite3 db, so you can let the crawler add Ogg
> files to it and then set the tags by hand, this what I do to have proper tags
> for my Oggs.

I am developing this python script to read the tags from each ogg file in the
db and write them back there. Should I try to make it work with the crawler
somehow? Can I make it be triggered? How do these plugins work anyway?...