Bug 2831 - After restore, Application Manager responds confusingly if no wifi connection is active
: After restore, Application Manager responds confusingly if no wifi connection...
Status: RESOLVED FIXED
Product: Settings and Maintenance
Application manager
: 4.0
: N810 Windows
: High major (vote)
: 5.0-beta2
Assigned To: unassigned
: application-manager-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-01-24 19:29 UTC by Walt Bilofsky
Modified: 2009-07-14 13:37 UTC (History)
3 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Walt Bilofsky (reporter) 2008-01-24 19:29:39 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)

STEPS TO REPRODUCE THE PROBLEM:

Do a restore of a backup.
When N810 restarts, it says "Application Manager required to re-install
applications.  Start Application Manager now?"
Press OK.
It briefly flashes "Connecting" but there is no WiFi connection.
Click the WiFi icon and establish a WiFi connection.

EXPECTED OUTCOME:

Application Manager should proceed to reload applications.

ACTUAL OUTCOME:

It just sits there.  To proceed, the user has to manually select Tools ->
Restore Applications.

REPRODUCIBILITY: always.

RECOMMENDATION:

When Application Manager sees no connection, it should put up a message "No
Internet connection.  Please connect to the Internet now." and give the user a
chance to establish a connection.  The message should have buttons "Connected
Now" (if App Mgr can't just sense when connected) and "Finish Later".  If the
user clicks "Finish Later" he should be told "To complete the restore process,
when an Internet connection is available, run Application Manager again and
select the Tools -> Restore command."
Comment 1 Andre Klapper maemo.org 2008-11-02 22:01:25 UTC
Hi Walt,
did this ever happen again, e.g. when flashing to the Diablo release?
Sounds more like (quite useful) enhancement request to me than a "real bug".
Comment 2 Walt Bilofsky (reporter) 2008-11-03 01:13:02 UTC
Hi, Andre -

It didn't happen when I last reflashed, but I don't remember whether there was
a WiFi connection active when Application Manager started up at that time.

I would argue that it's a bug.  Simply put, from the user's point of view, App
Mgr has hung without explanation, and that's a bug.
Comment 3 Andre Klapper maemo.org 2008-11-03 12:59:58 UTC
Ah, it hangs. Sorry, that wasn't clear enough to me.

I'd really like to see another confirmation for this. (or I should collect all
Flasher/Backup bugs and have a big testing day...)
Comment 4 Andre Klapper maemo.org 2008-11-27 13:12:01 UTC
Hmm. Tried this and it worked for me. I'd really like to have another
confirmation that this is still an issue with the latest version, because I was
unable to reproduce this with 4.1...
Comment 5 Quim Gil nokia 2009-01-24 23:40:55 UTC
Setting HIGH visibility to get more testers.
Comment 6 Andre Klapper maemo.org 2009-06-24 16:38:21 UTC
How can I create a testcase so that AM asks me "Application Manager required to
re-install applications.  Start Application Manager now?"  ?
Comment 7 Andre Klapper maemo.org 2009-06-24 16:59:46 UTC
Ah, I see.
I just tested this again in Fremantle.
Application manager asked me "Application Manager required to re-install
applications. Start Application Manager now?" and then provided the "Select
connection" dialog to me.
Clicking Cancel brings up the Select conncection dialog for a second time.

So this is FIXED in Fremantle.

Unfortunately this is a WONTFIX for Diablo as Diablo is in maintenance mode and
Nokia will only provide bugfixes for critical issues if at all.
For your interest the Mer project aims to provide a community backport of
Fremantle for N8x0 devices. See http://wiki.maemo.org/Mer for more information.
Comment 8 Andre Klapper maemo.org 2009-07-14 13:37:53 UTC
Fix should be included in Fremantle SDK beta 2 hence updating Target Milestone.
If you are the reporter of this bug: Feel free to verify the fix if possible.