Bug 2813 - Fail to upload package update to chinook-extras from Fedora 6 host
: Fail to upload package update to chinook-extras from Fedora 6 host
Status: CLOSED FIXED
Product: maemo.org Website
Downloads
: 4.0
: All Linux
: High major (vote)
: ---
Assigned To: Marcell Lengyel
: downloads@maemo.org
:
:
:
:
  Show dependency tree
 
Reported: 2008-01-21 18:47 UTC by Vladislav Grinchenko
Modified: 2008-02-05 09:26 UTC (History)
1 user (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Vladislav Grinchenko (reporter) 2008-01-21 18:47:26 UTC
SOFTWARE VERSION:

Development platform: Fedora Core 6
SDK: Maemo-4.0 (chinook)
Target platform: Nokia N800
Targeted repository: chinook-extras

STEPS TO REPRODUCE THE PROBLEM:

1. Build and sign up the package for both x86 and ARMEL targets as described
in http://maemo.org/community/application-catalog/extras_repository.html 
(steps 1-5 of the guide).

2. Signed package with valid PGP key.

3. Verified that my garage account ('vlg') is valid.

4. Verified that SSH uses rsa key.

5. Set ~/.ssh/config.Garage to

Host garage 
HostName garage.maemo.org
User vlg
IdentityFile ~/.ssh/id_rsa

6. Since 'dput' wouldn't work on Fedora Core 6, I tried to use 'scp' 
   directly to upload the package:

$ scp -F ~/.ssh/config.Garage *.changes *.dsc *.tar.gz *.deb
vlg@garage.maemo.org:/var/www/extras/incoming/chinook


EXPECTED OUTCOME:

Enter passphrase for key '/home/vlg/.ssh/id_rsa': XXXXX

<output should display file transfer progress>

ACTUAL OUTCOME:

Permission denied (publickey,keyboard-interactive).
lost connection


REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

none

OTHER COMMENTS:

This used to work flawlessly with 'mistral-extras' repository as 
described here: 

http://home.comcast.net/~3rdshift/articles/Nokia770/Maemo-Gtkmm.html#maemoextra
Comment 1 Vladislav Grinchenko (reporter) 2008-01-22 05:47:44 UTC
More info from 'scp' with '-vv' option enabled:

--------------begin------------------

Executing: program /usr/bin/ssh host garage.maemo.org, user vlg, command scp -v
-d -t /var/www/extras/incoming/chinook

OpenSSH_4.3p2, OpenSSL 0.9.8b 04 May 2006

debug1: Reading configuration data /home/vlg/.ssh/config
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to garage.maemo.org [62.61.85.33] port 22.
debug1: Connection established.
debug1: identity file /home/vlg/.ssh/identity type -1
debug2: key_type_from_name: unknown key type '-----BEGIN'
debug2: key_type_from_name: unknown key type 'Proc-Type:'
debug2: key_type_from_name: unknown key type 'DEK-Info:'
debug2: key_type_from_name: unknown key type '-----END'
debug1: identity file /home/vlg/.ssh/id_rsa type 1
debug2: key_type_from_name: unknown key type '-----BEGIN'
debug2: key_type_from_name: unknown key type 'Proc-Type:'
debug2: key_type_from_name: unknown key type 'DEK-Info:'
debug2: key_type_from_name: unknown key type '-----END'
debug1: identity file /home/vlg/.ssh/id_dsa type 2
debug1: Remote protocol version 2.0, remote software version OpenSSH_3.8.1p1
Debian-8.sarge.6
debug1: match: OpenSSH_3.8.1p1 Debian-8.sarge.6 pat OpenSSH_3.*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_4.3
debug2: fd 3 setting O_NONBLOCK
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug2: kex_parse_kexinit:
diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ssh-rsa,ssh-dss
debug2: kex_parse_kexinit:
aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
debug2: kex_parse_kexinit:
aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
debug2: kex_parse_kexinit:
hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit:
hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: first_kex_follows 0 
debug2: kex_parse_kexinit: reserved 0 
debug2: kex_parse_kexinit:
diffie-hellman-group-exchange-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ssh-rsa,ssh-dss
debug2: kex_parse_kexinit:
aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
debug2: kex_parse_kexinit:
aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
debug2: kex_parse_kexinit:
hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit:
hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: none,zlib
debug2: kex_parse_kexinit: none,zlib
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: first_kex_follows 0 
debug2: kex_parse_kexinit: reserved 0 
debug2: mac_init: found hmac-md5
debug1: kex: server->client aes128-cbc hmac-md5 none
debug2: mac_init: found hmac-md5
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug2: dh_gen_key: priv key bits set: 116/256
debug2: bits set: 485/1024
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'garage.maemo.org' is known and matches the RSA host key.
debug1: Found key in /home/vlg/.ssh/known_hosts:27
debug2: bits set: 489/1024
debug1: ssh_rsa_verify: signature correct
debug2: kex_derive_keys
debug2: set_newkeys: mode 1
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug2: set_newkeys: mode 0
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug2: key: /home/vlg/.ssh/id_rsa (0x81df1330)
debug2: key: /home/vlg/.ssh/id_dsa (0x81df1348)
debug2: key: /home/vlg/.ssh/identity ((nil))
debug1: Authentications that can continue: publickey,keyboard-interactive
debug1: Next authentication method: publickey
debug1: Offering public key: /home/vlg/.ssh/id_rsa
debug2: we sent a publickey packet, wait for reply
debug1: Authentications that can continue: publickey,keyboard-interactive
debug1: Offering public key: /home/vlg/.ssh/id_dsa
debug2: we sent a publickey packet, wait for reply
debug1: Authentications that can continue: publickey,keyboard-interactive
debug1: Trying private key: /home/vlg/.ssh/identity
debug2: we did not send a packet, disable method
debug1: Next authentication method: keyboard-interactive
debug2: userauth_kbdint
debug2: we sent a keyboard-interactive packet, wait for reply
debug1: Authentications that can continue: publickey,keyboard-interactive
debug2: we did not send a packet, disable method
debug1: No more authentication methods to try.
Permission denied (publickey,keyboard-interactive).
lost connection

---------------end-------------------

Perhaps someone can spot a problem somewhere. I re-generated my RSA key to rule
it out.
Comment 2 Jake Kunnari 2008-01-22 09:25:16 UTC
Marcell: Could you check this one?
Comment 3 Marcell Lengyel maemo.org 2008-01-22 11:13:45 UTC
I created a new user in garage, invited it to be able to upload to extras,
uploaded the ssh & gpg keys and then used this command:

scp -i .ssh/<user>.key a.txt
<user>@garage.maemo.org:/var/www/extras/incoming/chinook

first I did get the same error as described in the bugreport. I checked the
server logs and there were no information at all about the login attempt. I
retried the command and since then it works every time now. I tried with
different files and everything seems to work.
I have no idea what caused the first permission denied message as there are no
information about it in the logs. Please retry. If it still does not work,
reopen the bugreport and I will enable logging in sshd on garage.
Comment 4 Vladislav Grinchenko (reporter) 2008-01-29 22:09:56 UTC
Marcell,

1) "... invited it to be able to upload to extras, ..."

Perhaps I am not allowed to contribute to extras. My login is 'vlg'. 
To be sure, I have sent 'Subject: upload account to extras' e-mail to
garage[AT]maemo[DOT]org

2) "... uploaded the ssh & gpg keys ..."

How do I do that? On my maemo.org profile page
(https://maemo.org/profile/edit/) there is no way to load either my public ssh
key or gpg key unless I overlooked it. Sourceforge.net has a special form for
adding your ssh key to your profile.

3) "... and then used this command: ..."

My scp still fails on me.
Comment 5 Marcell Lengyel maemo.org 2008-01-30 10:33:54 UTC
> 1) "... invited it to be able to upload to extras, ..."
> 
> Perhaps I am not allowed to contribute to extras. My login is 'vlg'. 
> To be sure, I have sent 'Subject: upload account to extras' e-mail to
> garage[AT]maemo[DOT]org

I have checked and you are allowed. I can send you your ssh publick key, so you
can compare with yours that it is really ok.

> 2) "... uploaded the ssh & gpg keys ..."
> 
> How do I do that? On my maemo.org profile page
> (https://maemo.org/profile/edit/) there is no way to load either my public ssh
> key or gpg key unless I overlooked it. Sourceforge.net has a special form for
> adding your ssh key to your profile.

You have done it already. The process goes like this: you apply for rights to
upload to extras. If granted, you receive a mail with a link to a
garage.maemo.org page with a form where you copy-paste your ssh and gpg keys.
after that you are all set. I have checked and you have an ssh and a gpg key on
garage so I assume that you have done these steps before.


> 3) "... and then used this command: ..."
> 
> My scp still fails on me.

I have checked again and it works for me. There is nothing on the server side
logs about your attempts to log-in. I increased the logging level of sshd,
let's see if I can find out something.
Comment 6 Marcell Lengyel maemo.org 2008-02-04 09:42:14 UTC
Ok, so after some direct e-mail exchange it turned out that there was an old
ssh key in garage, that is why vld could not log in. It had nothing to do to
Fedora. Ssh key is garage was updated and now all should be fine. Please reopen
if there are still problems with ssh login. If not, please change the status to
Verified. Thanks.
Comment 7 Vladislav Grinchenko (reporter) 2008-02-05 05:40:20 UTC
Verified. I can 'scp' packages to extras repositories now. Thanks for the help
provided.