Bug 2796 - Media player should play audio tracks continuously (gapless)
: Media player should play audio tracks continuously (gapless)
Status: RESOLVED WONTFIX
Product: Media player
General
: 5.0:(10.2010.19-1)
: ARM Windows
: Low enhancement with 89 votes (vote)
: ---
Assigned To: unassigned
: media-player-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-01-17 10:13 UTC by Nacho
Modified: 2012-03-24 11:40 UTC (History)
14 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description Nacho (reporter) 2008-01-17 10:13:31 UTC
STEPS TO REPRODUCE THE PROBLEM:

For example, choose an audio album in media player library to be played.

EXPECTED OUTCOME:

After playing the last sample of an audio clip, the first sample of the next
clip in the playlist should be played.

ACTUAL OUTCOME:

There is a gap of silence (about 1 second) between tne end of a clip and the
beginning of the next one. 

REPRODUCIBILITY:
(always/sometimes/once)

Always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

This is especially important, for instance, in albums recorded in a live
performance where all the tracks are a continuum. But also many albums recorded
in studio have each song linked to the next one. Current implementation of the
media player breaks that kind of experience by entering a blank gap. When
playing the last samples of a clip, the first samples of the next should be
buffered (same for clip info, maybe).
Comment 1 Ryan Abel maemo.org 2008-06-17 17:46:57 UTC
*** Bug 2989 has been marked as a duplicate of this bug. ***
Comment 2 Javier Jardón 2009-03-29 22:26:38 UTC
Still valid in 4.1.3 (5.2008.43-7) maemo release
Comment 3 Andre Klapper maemo.org 2009-12-14 19:06:39 UTC
*** Bug 6732 has been marked as a duplicate of this bug. ***
Comment 4 Daniel Martin Yerga 2009-12-21 12:57:42 UTC
*** Bug 7172 has been marked as a duplicate of this bug. ***
Comment 5 Yves-Alexis 2009-12-21 13:01:12 UTC
(In reply to comment #4)
> *** Bug 7172 has been marked as a duplicate of this bug. ***
> 
Hmhm, it seems that the original bug is quite old. Is there any progress on it?
Comment 6 H. Can Celik 2010-01-11 07:54:38 UTC
The title and explanation is kind of little bit off. There is 1 second gap
between the songs where it shouldn't be. The albums I listen usually sounds
like one long song even though they consist of multiple songs.(Tiesto albums,
house music, etc...) However with N900 it pauses between the songs.
Comment 7 manniid 2010-01-11 17:39:56 UTC
Just adding a comment that may help other users find this bug/enhancement more
easily when they search, so that we can hopefully get more votes and
prioritization (my searches didn't find it very easily).

I believe the request is to implement "gapless playback" in Media Player to
eliminate gaps between tracks in DJ Mixes or other albums that consist of
multiple tracks, yet are meant to play continuously without interruption.
Comment 8 Ray 2010-02-03 04:40:51 UTC
Doesn't seem like there will be any fixes/updates regarding this enhancement
Comment 9 Yves-Alexis 2010-03-21 12:17:58 UTC
(In reply to comment #8)
> Doesn't seem like there will be any fixes/updates regarding this enhancement
> 
Any reason?
Comment 10 abrarmi 2010-04-01 18:29:45 UTC
is there any other players for the n900 without this problem?
Comment 11 Arien de Jongste 2010-04-29 20:23:45 UTC
I just listened to an album encoded in the FLAC format. I have the "Extra Codec
Support"-package installed. The album does play back gaplessly. Then I listen
to an album encoded in Musepack format and it does not play gaplessly. Both of
these formats explicitly support gapless playback.
Comment 12 Yves-Alexis 2010-05-02 12:51:58 UTC
I just tried to encode an album using flac, and it doesn't play gapless in the
media player. I'm not sure how to check if they contain any “gapless tag” or
something. Anyway it shouldn't really be necessary imho, the media player
shouldn't just add gaps when it changes tracks at all.
Comment 13 Will 2010-07-23 16:48:23 UTC
I have PR1.2 on my N900

I have also noticed that playback of my gapless Ogg Vorbis albums is not
gapless either.

If the N900 is to compete with the iPhone, it surely should be able to play
back natively gapless audio files such as Ogg Vorbis gaplessly.

When can we expect gapless playback?

Thanks!
Comment 14 Andre Klapper maemo.org 2010-07-23 17:46:19 UTC
Will: maemo.org Bugzilla is a bugtracker for technical issues.
It is neither a forum nor a Nokia contact channel.

Please do not comment on reports if your comment does not provide technical
information for developers. There is http://talk.maemo.org for this type of
communication. Thanks!
Comment 15 Andre Klapper maemo.org 2012-03-24 11:40:18 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia and it seems that there are no
plans for official updates currently, hence nobody plans to work on this
enhancement/wishlist request. 
(And in case you feel like discussing this situation: Nokia Customer Care or
http://talk.maemo.org would be the place to do so as you will not reach Nokia
officials in this community bugtracker - though all of this is really no news.)

Reflecting this status by setting RESOLVED WONTFIX for this
enhancement/wishlist request (see
https://bugs.maemo.org/page.cgi?id=fields.html#status for status explanations).

There is a small chance for issues in those Maemo components that are open
source: Contributed patches could be included and made available in the Maemo 5
Community CSSU updates. 
The Maemo CSSU project is run by a small team of volunteers; see
http://wiki.maemo.org/CSSU for more information.
So in case that you can provide a patch that fixes the reported problem, please
feel encouraged to file a request under
https://bugs.maemo.org/enter_bug.cgi?product=Maemo%205%20Community%20SSU .
Please note: The Maemo CSSU project is not related in any way to Nokia.


( Tag for mass-deleting bugmail: [cleanup20120324] )