Bug 2786 - chat application should allow for sending text messages to cell phones
: chat application should allow for sending text messages to cell phones
Status: RESOLVED WONTFIX
Product: Chat & Call & SMS
Messaging
: 4.0
: All Windows
: High enhancement (vote)
: ---
Assigned To: rtcomm@maemo.org
: im-chat-bugs
:
:
:
:
  Show dependency tree
 
Reported: 2008-01-15 22:10 UTC by pgruebele
Modified: 2008-12-30 19:30 UTC (History)
4 users (show)

See Also:


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description pgruebele (reporter) 2008-01-15 22:10:43 UTC
STEPS TO REPRODUCE THE PROBLEM:

Both yahoo and msn messenger under Windows allow me to send text messages to
telephone numbers.  OS2008 should support this feature.  Not being able to text
people on their cell phones is a big oversight...  I live in the US.

EXPECTED OUTCOME:

ACTUAL OUTCOME:

REPRODUCIBILITY:
(always/sometimes/once)

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:
Comment 1 Andre Klapper maemo.org 2008-06-13 17:56:12 UTC
Is that a free service? I only know that it's possible if you pay for the
transmission here.
Comment 2 pgruebele (reporter) 2008-06-13 19:04:40 UTC
it's free with instant messenger apps like Yahoo Messenger (to USA cell phones
at least).  I can send text messages for free to any text phones (and they can
reply to me).  Of course the cell phone provider may charge for the text
messages, but that has nothing to do with Maemo.
Comment 3 Quim Gil nokia 2008-12-30 02:59:50 UTC
setting HIGH visibility
Comment 4 Mikhail Zabaluev nokia 2008-12-30 11:18:41 UTC
Is this functionality even available in telepathy-haze?
Comment 5 Quim Gil nokia 2008-12-30 12:42:44 UTC
This is not only based on software, leave alone free software. These are
commercial services tied to Yahoo and Microsoft. I guess we would need first
Yahoo! Messenger or MSN available in Maemo. 

As for now both services seem to be available only in the Windows Desktop?
Since both have onlne/mobile versions, perhapos you could get this working via
browser? I'm not in the US so it is very likely that I can't even try.

http://mobile.yahoo.com/messenger/sms
"Carrier charges may apply for sending or receiving text messages. Check your
wireless plans for details"

There is a Desktop and a Mobile version, but in any case it seems assumed for
registration that you own already a mobile phone able to send/receive SMS?


http://get.live.com/messenger/features
"Recipients may be charged a fee by their mobile provider to receive messages."

So again, an operator business needs to be in place.
Comment 6 Tan Miaoqing nokia 2008-12-30 17:32:31 UTC
(In reply to comment #5)

> I guess we would need first Yahoo! Messenger or MSN available in Maemo. 
> 
> As for now both services seem to be available only in the Windows Desktop?

Hi Quim, in fact Yahoo! Messenger and MSN are available in Maemo to some extent
via telepathy-haze (an open source telepathy connection manager). Since it uses
libpurple, it brings all IM services supported by pidgin to Maemo, integrating
with our address book and chat (no VoIP) functionality.

You can find a bit more information here:
http://rtcomm.garage.maemo.org/

However, since we have dedicated pidgin client in Maemo, do you think that it
is worth pushing telepathy-haze as a recommended community application?
Comment 7 Quim Gil nokia 2008-12-30 17:39:44 UTC
(In reply to comment #6)
> Hi Quim, in fact Yahoo! Messenger and MSN are available in Maemo to some extent
> via telepathy-haze

telepathy-haze might bring technical compatibility, but probably not the
business (and legal?) arrangements that Yahoo and Microsoft have sorted out
with carriers and whoever related to provide such feature.

Since I'm a total ignorant about the technical aspects behind that feature,
perhaps one could even be able to mimmic the feature through open source code
and the registration to those services. Still, if Nokia would want to
productize that feature (meaning, having the UI and everything tested in a
sales package or an official install) I'm sure deals would need to be made with
those companies and probably also with the related carriers.
Comment 8 Mikhail Zabaluev nokia 2008-12-30 19:30:10 UTC
OK, so the resolution is: we won't implement it with the components we have
publicly available at the moment.
Sending SMS through commercial service providers should be subject to product
agreements, and any such development would unlikely be tracked in public
anyway.
This does not rule out SMS interoperability in any future Maemo release.